Óñòàíîâêà êîìïëåêñà

Установка комплекса

 Top Next

В данной главе содержатся сведения об установке комплекса программ Термит.Бюджет 2006.

· Установка MS SQL Server 2000


Óñòàíîâêà è àäìèíèñòðèðîâàíèå Microsoft SQL Server 2000

Установка и администрирование Microsoft SQL Server 2000

 Top Previous Next

В разделе содержатся сведения об установке и настройке Microsoft SQL Server 2000.


Óñòàíîâêà Misrosoft SQL Server 2000

Установка Misrosoft SQL Server 2000

Установка Microsoft SQL Server 2000

Тип установки: Server and Client Tools

Имя инсталляции: По умолчанию (Default)

В принципе, не запрещается устанавливать и именованные сервисы. Тогда в настройках BDE нужно будет в поле "Server Name" указать в форме "ComputerName\InstanceName"

Тип установки: Custom
Иначе установщик не предложит выбрать кодовую страницу (см. ниже)

Установка путей: корень любого диска (и Program Files, и Data Files)
При этом серверная часть ПО будет установлена в папку x:\MSSQL. Что кратко и удобно

Выбор компонентов: Не устанавливаем (если нет необходимости) Upgrade Tools

Запуск служб: Один account для всех сервисов (не забыть указать автозапуск для SQL Sever Agent), Local System account
Можно указать и чей-нибудь еще account, но тогда админ не должен забывать об этом, если ему вздумается сменить пароль. Недостаток Local System в том, что сервер не сможет взаимодействовать с сетью, например сбэкапить базу на сетевой ресурс.

Authentification mode: Mixed Mode.
BDE можно научить логиниться в Windows Mode, но это цирковой фокус :)

Collation Setting: Выбрать SQL Collations из списка: Dictionary order, case-insensitive, for use with the 1251(Cyrillic) Character Set
Важно! Это необходимо при создании временных таблиц -- иначе не будет работать сравнение строковых полей, так как строковые поля во временных таблицах создаются с Collation сервера.
Совет. "Хороший стиль программирования" рекомендует Вам указывать Collation явно при создании временной таблицы. Так, например, Бюджетный Проект свободен от вышеупомянутой проблемы и работает с "неправильно установленными серверами" без проблем.

Выбор протоколов: Named Pipes, TCP/IP

Количество лицензий: 300 (много, в общем)

Произвести установку SP4 (SQL2000-KB884525-SP4-x86-ENU.EXE -- да-да, именно так он называется)
Важно! SP4 устанавливается "не всегда", поэтому его надо устанавливать как можно раньше. Чтобы не было жалко времени, бесцельно потраченного на установку сервера. Если SP4 не ставится, надо деинсталлировать сервер и начать все сначала.
Важно! Между установкой сервера и SP4 надо перезагрузить компьютер.
Важно! Если в качестве серверной ОС используется Windows NT 4.0, вам нужно ставить Service Pack 2 вместо Service Pack 4. Оно работает.

Установить максимальный объем памяти для сервера (75 % от имеющейся).

Поставить флаг 'Reserve physical memory'

Создать Maintenance Plan (с ведением отчетности)

· Backup Ежедневно ночью в 2.00
· Реиндексация базы в воскресенье в 8.00

ВАЖНО: Для больших БД (или планирующихся как большие, 10G или более) НЕЛЬЗЯ указывать аттрибут Compressed для каталога backups, хотя и хочется. Вот: http://support.microsoft.com/?id=231347

Создать логин rmUser. В свойствах указать язык по-умолчанию Russian (General - Language - Russian)

Исправить свойства логина sa. В свойствах указать язык по-умолчанию Russian (General - Language - Russian)

Выполнить следующий скрипт для всех установленных прикладных БД (в примере ниже указана БД Termit):

use Termit -- Заменить на имя базы данных Термита

exec sp_revokedbaccess 'rmUser'

exec sp_grantdbaccess 'rmUser', 'rmUser'

exec sp_addrolemember 'Rm', 'rmUser'


Ñîçäàíèå íîâîé ÁÄ íà ñåðâåðå

Создание новой БД на сервере

Чтобы создать новую базу данных на сервере, выполните следующие действия:

1. Создать новую базу данных, используя Enterprise Manager
2. Восстановить в созданную в предыдущем действии базу резервную копию
2.1. В окне действия "Restore database" выбрать опцию "From device" и нажать кнопку "Select device"
2.2. Далее указать файл, содержащий резервную копию БД
2.3. После выбора файла на вкладке "Options" установить указанные опции восстановления и запустить процесс
2.4. Выполнить следующий скрипт для вновь созданной БД (в примере ниже указана БД Termit):
use Termit -- Заменить на имя базы данных Термита
exec sp_revokedbaccess 'rmUser'
exec sp_grantdbaccess 'rmUser', 'rmUser'
exec sp_addrolemember 'Rm', 'rmUser'
3. Настроить доступ для пользователей программы к вновь созданной БД:
3.1. Для проекта Термит.Бюджет
3.1.1. Отредактировать файл-сценарий установки программы на рабочую станцию (файл может называться произвольным образом и имеет расширение rms): в разделе [BDE] добавить две секции, как в указанном примере (или скопировать и отредактировать существующие)
3.1.1.1. В приведенном примере значения "2" и "3" (BDE_MsSQLAlias_2 и BDE_MsSQLAlias_3) - порядковые номера, т.е. для первой БД это будут значения 0 и 1, для второй - 2 и 3, и т.п.
3.1.1.2. Параметр AliasName в первой группе заполняется произвольным именем, во второй - таким же именем, но с постфиксом _Admin
3.1.1.3. Параметр DBServerName заполняется физическим именем сервера, либо макросом %ServerName%, если выше указано значение этого макроса
3.1.1.4. Параметр PhysicalDBName заполняется физическим именем БД на сервера (в обоих группах - одинаковым)
3.1.1.5. Параметр UserName в первой группе заполняется значением rmUser, во втором - sa
3.1.1.6. При использовании пароля для пользователя sa укажите его в параметре Password
3.1.2. В разделе [MtServer_Cluster_0] добавить одну секцию (или скопировать и отредактировать существующую)
3.1.2.1. Здесь также значения "2" и "3" (Alias_2 и Alias_3) - порядковые номера, т.е. для первой БД это будут значения 0 и 1, для второй - 2 и 3, и т.п.
3.1.2.2. В качестве значений созданных параметров необходимо указать имена, которые были указаны в параметрах AliasName в секции [BDE] (см. п. 3.1.1.2)
3.1.3. Отредактировать файл Databases.ini, хранящийся в RmDistr\TermitBudget: добавить в секцию [Databases] одну строку, в левой части (до символа "=" указать имя, которое было в ПЕРВОЙ созданной секции (в приведенном примере - [BDE_MsSQLAlias_2]), в правой части строки (после символа "=") - любое понятное пользователям описание вновь созданной БД
3.1.4. Запустить на каждом рабочем месте, где требуется доступ к новой БД, программу ClientSetup, устанавливая опции, как указано ниже (внимание: данные установки показаны ТОЛЬКО для добавления новой БД на тех рабочих местах, где уже установлена программа Термит.Бюджет)


Íàñòðîéêà ðåçåðâèðîâàíèÿ äàííûõ

Настройка резервирования данных

Как настроить резервирование базы данных на сервере Microsoft SQL Server 2000.

1. Создайте каталог для бэкапов базы. Откройте «Мой компьютер», выберите диск, на котором больше всего места, перейдите на него. Щелкните правой кнопкой мыши в пустом поле и в появившемся меню выберите «Создать» | «Папку». В качестве имени папки укажите db_backup.
2. Созданной папке установите атрибут «Сжатый». Для этого щелкните по ее иконке правой кнопкой мыши и из меню выберите «Свойства». На вкладке «Общие» (она открывается по умолчанию) нажмите кнопку «Другие». В появившемся окне «Дополнительные атрибуты» уберите все галочки, кроме галочки «Сжимать содержимое для экономии места на диске (см. рис. 1).

рис. 1. Установка атрибутов каталога
Нажмите ОК. Нажмите ОК еще раз.
3. Откройте SQL Server Enterprise Manager.
4. Выберите в дереве:
Console Root
Microsoft SQL Servers
SQL Server Group
<имя вашего сервера>
Management
Database Maintenance Plans
(см. рис. 2)

Рис.2. SQL Enterprise Manager

5. Убедитесь, что работа не была сделана кем-то ранее. (Что в списке планов нет ни одного со словом ‘Backup’ в списке действий (‘Actions’).
(см. рис. 2)
6. Щелкните правой кнопкой мышки в чистом поле и в появившемся меню выберите ‘New maintenance plan’. Щелкните в этот пункт меню левой кнопкой.
(см. рис. 2)
7. Появляется Волшебник планов обслуживания базы данных (‘Database maintenance plan wizard’). Нажмите «Далее».
8. Выберите из списка вашу базу данных и нажмите «Далее».
9. Нажмите «Далее» еще раз.
10. Установите галочку ‘Check database integrity’, а затем – галочку ‘Perform this checks before doing backups’ (см. рис. 3).

Рис.3. Настройка проверки целостности базы
11. Далее на появившемся экране расставьте галочки в точности так, как это сделано на рис. 4.

Рис. 4. Настройка бэкапа
12. Щелкните в кнопочку, указанную на рис. 4 и выберите время, в которое будет выполняться ваша задача.

Важно! Процесс сохранения базы весьма длителен (до нескольких часов). Его желательно назначать на выходной день или ночь, чтобы не создавать проблем пользователям. Требования к выбору времени для оптимизации:
a. Сервер должен быть включен в это время
b. Сервер не должен выключиться во время процесса.
c. Во время процесса не должна произойти оптимизация данных (лучше, пусть она случится часа через 3-5 после начала backup’а).
d. Неплохим временем для начала backup’а являются 21-22 часа.
13. Выйдите из диалога выбора времени (‘Schedule’) и нажмите «Далее».
14. Укажите, что вы сами выберете директорию для сохранения (‘Use this directory’) и выберите ее. Определитесь, сколько недель вы сможете хранить сохраненные файлы. В примере на рис. 5 указана 1 неделя, то есть в вашей директории будут лежать 7 файлов. Это необходимый минимум, меньший срок ставить не рекомендуется. Выбор этого количества зависит от места на вашем диске. Не забывайте копировать файлы бэкапов на CD/DVD!
Расставьте галочки согласно рис. 5. Нажмите «Далее».

Рис. 5. Выбор места для файла бэкапа
15. Нажмите «Далее».
16. Поставьте галочку ‘Write report to a text file in directory’ (см. рис 6). Нажмите «Далее».

Рис. 6. Сохранение отчета.
17. Нажмите «Далее».
18. Наберите внятное имя для вашего плана и нажмите «Готово». Готово.
19. Убедитесь, что служба SQL Server Agent запущена (см. рис. 2) и что она стартует автоматически при запуске сервера.
20. Можно было бы посоветовать запустить созданное задание вручную для проверки.

ВНИМАНИЕ! Отсутствие ежедневного бэкапа («вчерашний есть, а сегодняшнего нет») может быть вызвано двумя причинами:

1. отсутствием свободного места на диске — почистите диск;
2. ошибками при проверке базы данных (см. п. 10 выше). В этом случае необходимо немедленно проконсультироваться со специалистами фирмы «Перспектива»!


Íàñòðîéêà îïòèìèçàöèè

Настройка оптимизации

 Top Previous

Как настроить оптимизацию размеров (и индексов) базы данных на сервере Microsoft SQL Server 2000.

1. Откройте SQL Server Enterprise Manager.
2. Выберите в дереве:
Console Root
Microsoft SQL Servers
SQL Server Group
<имя вашего сервера>
Management
Database Maintenance Plans
(см. рис. 1)

Рис.1
3. Убедитесь, что работа не была сделана кем-то ранее. (Что в списке планов нет ни одного со словом ‘Optimizations’ в списке действий (‘Actions’).
(см. рис. 1)
4. Щелкните правой кнопкой мышки в чистом поле и в появившемся меню выберите ‘New maintenance plan’. Щелкните в этот пункт меню левой кнопкой.
(см. рис. 1)
5. Появляется Волшебник планов обслуживания базы данных (‘Database maintenance plan wizard’). Нажмите «Далее».
6. Выберите из списка вашу базу данных и нажмите «Далее».
7. На появившемся экране расставьте галочки в точности так, как это сделано на рис. 2.

Рис.2
8. Щелкните в кнопочку, указанную на рис. 2 и выберите время, в которое будет выполняться ваша задача.

Важно! Процесс оптимизации базы весьма длителен (до нескольких часов). Его желательно назначать на выходной день или ночь, чтобы не создавать проблем пользователям. Требования к выбору времени для оптимизации:
a. Сервер должен быть включен в это время
b. Сервер не должен выключиться во время процесса.
c. Во время процесса не должен произойти ежедневный backup базы данных (лучше, пусть он случится до начала процесса).
d. Совсем не обязательно заниматься этим ежедневно. Оптимизации раз в неделю будет вполне достаточно.
9. Выйдите из диалога выбора времени (‘Schedule’) и нажмите «Далее».
10. Нажмите «Далее» еще раз.
11. Снимите галочку напротив ‘Backup the database as part of…’ и нажмите «Далее».
12. Нажмите «Далее» еще три раза.
13. Наберите внятное имя для вашего плана и нажмите «Готово». Готово.
14. Убедитесь, что служба SQL Server Agent запущена (см. рис. 1) и что она стартует автоматически при запуске сервера.
15. Можно было бы посоветовать сбэкапить базу и запустить созданное задание вручную для проверки, но оно (задание) может парализовать работу организации на весь рабочий день.