Руководство по FastReport
Возврат в начало инструкции
 | Руководство по FastReport (Version 2.45, Редакция 26.03.2003) Copyright © 1998-2001 by A.Tzyganenko
WWW: - http://www.fastreport.ru - http://www.fast-report.com E-mail: - sales: sales@fast-report.com - support: support@fast-report.com |


Введение
Возврат в начало инструкции


Назначение
Возврат в начало инструкции


Описание визуальных объектов
Возврат в начало инструкции


Объект-Текст
Возврат в начало инструкции
Представляет собой произвольным образом обрамленный прямоугольник с многострочным текстом внутри. Задается цвет текста/заливка, тип рамки, толщина рамки и цвет, все параметры шрифта текста, выравнивание текста внутри прямоугольника и ориентация текста (норм./90 градусов). Объект может быть выведен с использованием атрибутов выделения, если выполняется условие выделения.

В мемо объекта можно поместить многострочный текст с переменными. Переменные обрамляются квадратными скобками. При формировании отчета, когда в объекте обнаруживается переменная, вызывается событие, которому передается имя переменной (это может быть и не имя, а выражение - см. разборщик выражений) и ожидается возврат ее значения. Примеры использования переменных:

Длина, см: [Длина]
Длина, см: [Table1."Length_cm"]
Длина, см: [[Длина в дюймах] * 2.54]
Длина, см: [Table1."Length_in" * 2.54]

Редактор объекта позволяет редактировать содержимое мемо, быстро вставлять переменные и поля доступных таблиц БД в мемо, а также редактировать скрипт. Для более удобной работы можно воспользоваться быстрыми клавишами: Insert - вставка переменной; клавиша Ctrl+Enter - аналог кнопки OK; клавиша Ctrl+F - аналог кнопки "Формат".

Помимо основного редактора, имеется редактор, позволяющий выбрать формат переменных. Вызвать его можно либо из контекстного меню объекта, либо из окна редактора мемо (кнопка "Формат"). Переменная может отображаться как текст, число, дата, время, булевское значение. Для каждого из этих типов (кроме текстового представления) можно выбрать один из нескольких способов форматирования, например, для числа можно задать количество знаков после запятой, знак-разделитель целой и дробной части, разделение на разряды. Кроме того, для каждого типа может быть выбран произвольный формат, когда строка форматирования задается вручную (например, #,###,##0.000 для числа). Строки форматирования для каждого из типов описаны в справочной системе Delphi, раздел formatting strings (кроме булевского типа, где строка представлена в формате Значение1;Значение2). Если выбран текстовый тип (по умолчанию), то форматирование производиться не будет.

Указанные опции форматирования будут воздействовать на все переменные, содержащиеся в объекте. Если переменная не может быть отформатирована указанным способом, она выводится как текст.

Если в объекте несколько переменных, для которых нужно разное форматирование, то можно применить другой способ форматирования. Суть его заключается в том, что к переменной дописывается тэг формата:

[Переменная формат], где формат - одно из следующих значений:

· #x.x или #Nx.x или #Nyyyyy - числовое представление. x.x - длина числа/число разрядов после запятой; yyyyy - строка типа #,##0.00 (более подробную информацию можно получить в справочной системе Delphi, раздел formatting strings). Если строка x.x или yyyyy содержит символы ".", ",", "-", то последний такой символ будет использован в качестве разделителя целой и дробной части форматированного числа.
· #Dxxxxx, #Txxxxx - дата и время. xxxxx - строка типа dd.mm.yy.
· #Bxxxxx;yyyyy - булевское значение. Если значение - ложь, то выводится строка xxxxx, иначе yyyyy.

Вот примеры использования форматирования:

[Table1."N1" #9.2] [Table1."N2" #N9-2] [Table1."N3" #N#,##0.00] - для числа
[Table1."Date1" #Ddd.mm.yyyy] [Table1."Time" #Thh:mm:ss] - для даты и времени
[Table1."Bool1" #BFalse;True] [Table1."Bool2" #BНет;Да] - для булевского значения

Следует отметить, что тэги формата не работают в редакторе списка переменных.

В контекстном меню объекта можно задать следующие опции:
· "растягиваемый" - высота объекта будет зависеть от количества строк в нем. При этом опция "растягиваемый" должна быть включена у бэнда, на котором находится объект. При печати бэнда вычисляется его высота, и все объекты с включенным растягиванием выводятся таким образом, что их нижняя граница растягивается до нижней границы бэнда.
· "перенос слов" - если слово не помещается в строке, оно переносится на следующую строку.
· "перенос по слогам" - при переносе слова делается разбивка его на слоги. При этом опция "перенос слов" должна быть включена.

This help file was created with HelpScribble.


Объект-Секция (бэнд)
Возврат в начало инструкции

FastReport, как и все распространенные продукты, является бэнд-ориентированным построителем отчетов. Ниже приведен полный перечень бэндов и выполняемых ими функций.

Название Функция

Report title печатается один раз в начале отчета
Report summary печатается один раз в конце отчета
Page header печатается вверху на каждой странице
Page footer печатается внизу на каждой странице
Master header печатается в начале списка 1-го уровня
Master data данные списка 1-го уровня
Master footer печатается в конце списка 1-го уровня
Detail header печатается в начале списка 2-го уровня
Detail data данные списка 2-го уровня
Detail footer печатается в конце списка 2-го уровня
Subdetail header печатается в начале списка 3-го уровня
Subdetail data данные списка 3-го уровня
Subdetail footer печатается в конце списка 3-го уровня
Overlay печатается на каждой странице нижним слоем
Column header печатается в начале каждой колонки
Column footer печатается в конце каждой колонки
Group header заголовок группы
Group footer печатается после группы

Cross header эта группа бэндов предназначена
Cross data для создания отчетов с переменным количеством
Cross footer столбцов и разбивкой на страницы

В зависимости от типа бэнда вызываются разные редакторы. Редактор для дата-бэндов позволяет выбрать источник данных из списка доступных либо выбрать виртуальный источник данных. При выборе виртуального источника необходимо указать, из скольких записей он состоит. При формировании отчета бэнд с виртуальным источником будет напечатан столько раз, сколько записей было задано.

Редактор для бэнда GroupHeader позволяет ввести условие группировки. Остальные бэнды не имеют редакторов.

В зависимости от типа бэнда в контекстном меню доступны следующие опции:

· "растягиваемый" - высота бэнда определяется максимальной высотой находящихся в нем объектов. У объектов также должна быть включена опция "растягиваемый";
· "разрываемый" - если бэнд не помещается целиком на странице, будут выведены только поместившиеся строки текста, а вывод остальных будет продолжен с новой страницы;
· "формировать новую страницу" - после печати бэнда формирование отчета продолжается с новой страницы. Если опция включена у дата-бэнда, то новая страница будет сформирована после вывода всех подбэндов;
· "на первой странице" - если опция отключена, то бэнд не будет выведен на первой странице;
· "на последней странице" - если опция отключена, то бэнд не будет выведен на последней странице;
· "повторять на всех страницах" - эта опция доступна у бэндов Master header, Detail header, Subdetail header, Group header, VarColumn header. При включении дублирует бэнд на новой странице или колонке.


Объект-Рисунок
Возврат в начало инструкции
Предназначен для вставки графического файла в формате BMP/WMF/ICO (и JPG, если установлен соответствующий модуль) в документ. Редактор объекта позволяет вставить рисунок и очистить содержимое объекта. Рисунок может быть вставлен из поля таблицы БД, если в мемо объекта поместить ссылку на соответствующее поле, например: [Table1."GraphicField"]. Редактор мемо может быть вызван с помощью инспектора объектов либо комбинацией клавиш Ctrl + Enter.

В контекстном меню объекта можно задать следующие опции:
· "растягиваемый" - рисунок растягивается по границам объекта;
· "сохранять пропорции" - если включено растягивание, пропорции рисунка сохраняются;
· "центровка" - рисунок выводится в центре объекта.


Объект-Вложенный отчет
Возврат в начало инструкции

Вложенный отчет - это отчет с размещенным на нем объектом SubReport, который представляет собой ссылку на другой отчет, расположенный на отдельной странице. При формировании такого отчета вместо объекта SubReport будет выведен соответствующий отчет. Объекты SubReport можно располагать на листе друг под другом или рядом. В случае, если объекты надо расположить друг под другом, их необходимо разнести по разным дата-бэндам (т.е. первый отчет - в первом бэнде Master data, второй - во втором и т.д.). На использование SubReports накладываются следующие ограничения:
· нельзя использовать колонки;
· во вложенных отчетах (не в основном!) игнорируются бэнды ReportTitle, ReportSummary, PageHeader, PageFooter, ColumnXXX;
· нельзя использовать разрываемые бэнды;
· нельзя использовать группы.


Объект-Линия
Возврат в начало инструкции

Представляет собой вертикальную либо горизонтальную линию с изменяемым цветом и толщиной. Дизайнер имеет удобные средства для рисования линий. В частности, с помощью линий можно быстро задать внешнее обрамление для таблицы, отличное от внутреннего.


Объект-CheckBox
Возврат в начало инструкции

Представляет собой прямоугольник с крестиком внутри. Если в мемо объекта разместить ссылку на переменную либо на поле таблицы БД, то крестик будет показан при ненулевом значении переменной. В мемо можно также разместить символ "0" либо отличный от нуля.

Примечание. Для использования этого объекта в run-time следует использовать соответствующий компонент из палитры компонентов FR. Если открываемый отчет содержит неподключенные компоненты, то выдастся сообщение об ошибке.


Объект-OLE
Возврат в начало инструкции

Предназначен для вставки OLE объектов в документ. Редактор объекта "OLE" позволяет вставить новый объект и редактировать существующий. Вставка нового объекта производится в стандартном диалоговом окне.

OLE объект может быть вставлен из поля таблицы БД, если в мемо объекта поместить ссылку на соответствующее поле, например: [Table1."OLEField"]. Редактор мемо может быть вызван с помощью инспектора объектов либо комбинацией клавиш Ctrl + Enter.

В контекстном меню объекта опция "растягиваемый" позволяет корректно отображать данные в некоторых случаях (например, при вставке объекта "Лист Excel").

Примечание. Для использования этого объекта в run-time следует использовать соответствующий компонент из палитры компонентов FR. Если открываемый отчет содержит неподключенные компоненты, то выдастся сообщение об ошибке.


Объект-RichText
Возврат в начало инструкции

Предназначен для вставки текста в формате RTF (Rich Text format) в документ. В частности, таким образом можно вставить текст, подготовленный в текстовом процессоре MS Word, предварительно сохранив его в формате RTF. Редактор объекта взят из Delphiи позволяет выполнять все базовые операции над текстом - менять шрифт, выравнивание, создавать маркированные списки. В тексте могут находится переменные, обрамленные квадратными скобками - как и в объекте "Текст". Если текст не вмещается в рамки объекта, то лишние строки просто не выведутся.

RichText объект может быть вставлен из поля таблицы БД, если в мемо объекта поместить ссылку на соответствующее поле, например: [Table1."RichField"]. Редактор мемо может быть вызван с помощью инспектора объектов либо комбинацией клавиш Ctrl + Enter.

Примечание. Для использования этого объекта в run-time следует использовать соответствующий компонент из палитры компонентов FR. Если открываемый отчет содержит неподключенные компоненты, то выдастся сообщение об ошибке.


Объект-Диаграмма
Возврат в начало инструкции

Предназначен для вставки графика или диаграммы в документ. Возможно использование шести типов графиков: линии, точки, столбцы горизонтальные и вертикальные, области и круговые диаграммы. Редактор объекта позволяет задавать различные опции для графика, а также указывать объекты, содержимое которых будет использовано при построении графика.

Для построения графика необходимо указать имена двух объектов типа "Текст", в которых содержится название и соответствующее числовое значение. При построении отчета содержимое этих объектов будет накапливаться в мемо диаграммы.

Если объект содержит число в форматированном виде или комбинацию числа и строки (например, "$1000" или "10 000"), то FR попытается выделить числовую часть из строки. Алгоритм выделения - удаляются все нецифровые символы в начале и в конце строки, после этого удаляются все символы - разделители разрядов (как правило, пробелы). То есть если задано более сложное форматирование, например: "10000км2", то такие объекты использовать уже нельзя. В этом случае следует создать невидимый объект с аналогичным содержимым, но без всякого форматирования, и указывать его имя. Невидимым объект можно сделать с помощью инспектора объектов в дизайнере, установив параметр Visible в 0.

График может быть двух типов: одиночный и множественный (т.е. на одной координатной плоскости изображается несколько графиков). Если опция "Одиночная" включена, содержимое мемо имеет вид:

Заголовок1;Заголовок2;Заголовок3
Число1;Число2;Число3

В противном случае информация в мемо представлена в следующем виде:

Заголовок1;Заголовок2;Заголовок3
Число1.1;Число2.1 (первый график)
Число2.1;Число2.2;Число2.3 (второй график)
Число3.1;Число3.2;Число3.3;Число3.4;Число3.5 (третий график)

То есть в этом случае будут изображены три графика: две точки в первом, три точки во втором, пять точек в третьем.
График можно построить и вручную, если занести в мемо объекта соответствующие значения. Если количество строк заголовка не соответствует количеству значений, график выведен не будет.

Объект позволяет легко строить графики типа "Top10", т.е. график, в котором представлены только первые самые большие значения, а остальные значения просуммированы в отдельную группу с названием. Для этого на закладке "Данные" необходимо указать количество выводимых значений и подпись (обычно в качестве подписи используется слово "Другие").

Примечание. Для использования этого объекта в run-time следует использовать соответствующий компонент из палитры компонентов FR. Если открываемый отчет содержит неподключенные компоненты, то выдастся сообщение об ошибке.


Объект-Штрихкод
Возврат в начало инструкции

Предназначен для вставки штрихкодов в документ. Можно использовать следующие типы штрихкодов: 2 of 5 interleaved, Code39, Code39 Extended, Code128A,B, Code93, Code93 Extended, MSI, PostNet, Codebar, EAN8, EAN13.

Примечание. Для использования этого объекта в run-time следует использовать соответствующий компонент из палитры компонентов FR. Если открываемый отчет содержит неподключенные компоненты, то выдастся сообщение об ошибке.


Объект-Фигура
Возврат в начало инструкции

Предназначен для вставки геометрических фигур (прямоугольник, прямоугольник с закругленными углами, эллипс, треугольник) в документ. Выполняет исключительно декоративную роль.

Примечание. Для использования этого объекта в run-time следует использовать соответствующий компонент из палитры компонентов FR. Если открываемый отчет содержит неподключенные компоненты, то выдастся сообщение об ошибке.


Дизайнер

Описание визуальных объектов
Возврат в начало инструкции


Описание дизайнера
Возврат в начало инструкции
Дизайнер FastReport предоставляет пользователю удобные средства для разработки внешнего вида отчета и позволяет сразу выполнить предварительный просмотр. Интерфейс дизайнера выполнен на современном уровне с использованием панелей инструментов (toolbars), расположение которых можно изменять по своему вкусу. Информация о расположении панелей запоминается в реестре, и при следующем запуске восстанавливается. Также в реестре запоминаются остальные настройки дизайнера.

Дизайнер доступен из среды Delphi в design-time. Для использования дизайнера в скомпилированном проекте необходимо использовать компонент TfrDesigner из палитры компонентов FastReport, либо включить в список uses модуль FR_Desgn. Использование дизайнера в run-time дает возможность пользователю настраивать вид отчета, а также редактировать сформированный отчет.


Клавиши управления
Возврат в начало инструкции
· Стрелки - перемещение по объектам.
· Ctrl + Стрелки - плавное перемещение выделенного объекта или группы объектов.
· Shift + Стрелки - уменьшение/увеличение размеров объекта.
· Alt + Стрелки - склеивание объекта с ближайшим в выбранном направлении.
· Enter - вызов редактора объекта.
· Del - удаление объекта.
· Ctrl + Enter - вызов редактора мемо.
· Ctrl + 1..9 - установка толщины рамки объекта.
· Ctrl + Z - отменить последнее действие. Число уровней отката - до 100.
· Ctrl + Y - повторить отмененное действие.
· Ctrl + G - показать сетку.
· Ctrl + B - выравнивать объекты по сетке. Любые операции мышью (перемещение, изменение размера объекта, вставка нового объекта и пр.) будут выполняться скачкообразно, если выравнивание включено.
· Ctrl + F - обрамить выделенный объект.
· Ctrl + D - снять обрамление с объекта.
· Ctrl + X - вырезать выделенные объекты в буфер.
· Ctrl + V - вставить объекты из буфера.
· Ctrl + C - копировать выделенные объекты в буфер.
· Ctrl + A - выделить все объекты на листе.
· Ctrl + N - новый отчет.
· Ctrl + O - открыть файл с отчетом.
· Ctrl + S - сохранить отчет в файле.
· Ctrl + P - предварительный просмотр отчета.


Управление мышью
Возврат в начало инструкции
· Левая кнопка - выбор объекта; вставка нового объекта; перемещение и изменение размеров объекта или группы объектов.
· Правая кнопка - контекстное меню объекта, над которым находится указатель мыши.
· Двойной щелчок левой кнопкой - вызов редактора объекта. Если двойной щелчок сделать на пустом месте листа, то вызывается диалоговое окно "Параметры страницы".
· Shift + левая кнопка - если объект уже выделен, то снимает с него выделение, иначе объект выделяется. Выделение остальных объектов не изменяется.
· Ctrl + левая кнопка - при нажатии и перемещении мыши рисуется рамка; после отпускания кнопки мыши выделяются все объекты, попавшие в рамку. Такого же эффекта можно добиться, если щелкнуть левой кнопкой мыши на пустом месте листа, и, не отпуская кнопки, потянуть мышь до нужной позиции.
· При перемещении бэнда его объекты перемещаются вместе с ним. Если это нежелательно, то перемещение следует выполнять при нажатой клавише Alt.
· Изменить масштаб выделенных объектов можно, потянув мышкой за красный квадратик на нижнем правом углу группы выделенных объектов.
· При приближении указателя мыши к границе двух соседних объектов вид указателя изменяется. Если при этом нажать левую кнопку и переместить указатель мыши, граница объектов также перемещается (горизонтальный сплиттинг).


Опции дизайнера
Возврат в начало инструкции
Чтобы установить опции дизайнера, воспользуйтесь командой меню "Сервис/Опции". Здесь можно задать используемые единицы измерения (пикселы, миллиметры, дюймы), указать шаг сетки в точках (шаг сетки 18 точек точно соответствует 5мм. Это особо полезно в случаях, когда надо сделать бланк, размеры которого кратны 5мм. Например, платежное поручение делается таким образом за 10 минут).

Также можно указать способ выделения выбранных объектов - контуром или инверсной заливкой.

Если опция "Цветные кнопки" отключена, то все кнопки становятся черно-белыми; при наведении указателя мыши на кнопку она показывается в цвете.

Наконец, опция "Редактирование после вставки" управляет процессом вставки новых объектов. Если опция включена, каждый раз при вставке объекта будет показываться его редактор. При вставке большого количества пустых объектов опцию лучше отключать.


Опции документа
Возврат в начало инструкции
Опции документа можно установить, выбрав пункт меню "Файл/Опции документа".

В выпадающем списке можно выбрать тип принтера из числа установленных в системе. Если в системе нет ни одного принтера, то можно выбрать только "Принтер по умолчанию". Это виртуальный "принтер", который позволяет использовать бумагу любого размера - вплоть до формата А0. Разумеется, печатать на нем нельзя - он всего лишь нужен для обеспечения нормальной работы дизайнера и предварительного просмотра.

Если включена опция привязки принтера к документу, то при открытии документа автоматически будет выбран соответствующий принтер. Если же принтера с таким именем нет в системе, то будет использован принтер, выбранный в Windows по умолчанию.

Опцию "делать два прохода" необходимо включать в случае, если отчет содержит информацию вида "Страница 1 из 15", т.е. ссылку на общее число страниц в отчете.


Опции страницы
Возврат в начало инструкции
Диалоговое окно доступно через пункт меню "Файл/Опции страницы" либо с помощью двойного щелчка левой кнопки мыши на пустом месте страницы. Здесь можно выбрать формат листа из списка поддерживаемых текущим принтером, задать ориентацию. Если принтер поддерживает пользовательские размеры бумаги, то при выборе соответствующего значения из выпадающего списка станут доступны поля для ввода ширины и высоты листа. Следует отметить, что не все принтеры поддерживают произвольные пользовательские размеры (например, драйвер принтера HP LaserJet 6L не дает устанавливать размеры листа меньше чем 76 * 127мм; драйвер принтера HP LaserJet 4L не поддерживает пользовательский формат вообще).

На второй закладке диалога можно задать размеры отступа от краев листа, а также задать опцию "Использовать поля печати". На этом моменте следует остановиться более подробно.

Возможны два варианта страницы в дизайнере: с полями печати и без них. Если поля печати включены (по умолчанию), то они отображаются в дизайнере и все, что находится вне полей, на печать не выводится. Это позволяет добиться максимального соответствия между видом страницы в дизайнере и на бумаге. К примеру, тестовые страницы, напечатанные на струйном, матричном и лазерном принтерах, между собой не отличались.

Но при переходе на другой принтер из-за изменившихся границ печати некоторые объекты могут вылезти за пределы полей и не будут напечатаны. Если отключить поля печати, то предполагается, что страница в дизайнере соответствует области печати, т.е. все, что находится на странице, будет корректно напечатано на любом принтере. Правда, при этом вид страницы в дизайнере будет немного отличаться от распечатанного документа.

Если поля страницы нулевые, то при построении отчета будут использована информация о полях, предоставляемая драйвером принтера. Если же хоть одно из полей ненулевое, то новые поля будут отображены в дизайнере и использованы при построении отчета. Если вы используете матричный принтер, будьте внимательны. Дело в том, что во многих матричных принтерах одно или несколько полей имеет нулевой размер, в связи с чем при формировании отчета и при его распечатке может возникнуть ситуация, когда текст выходит за границы листа. Чтобы избежать этого, явно задавайте поля станицы.

На третьей закладке можно установить некоторые опции для страницы, а также указать количество колонок для печати многоколоночных отчетов. Флажок "Печатать на предыдущем листе" позволяет начать печать страницы начиная со свободного места на предыдущем листе.


Список переменных отчета
Возврат в начало инструкции
Что такое список переменных и для чего он нужен? Предположим, имеется база сотрудников, в которой есть поля N, Name1, Name2, Name3. Вспоминать, что скрывается за такими названиями полей, иногда тяжело даже разработчику базы. Поэтому можно сопоставить полям БД нормально названные переменные (Таб.номер, Фамилия, Имя, Отчество), и в объекты вставлять их (в частности, для вставки переменной в объект "Текст" в редакторе мемо есть соответствующая кнопка).

Кроме того, переменной можно сопоставить не только поле из базы, но и математическое выражение, например, сумму значений полей БД, округленное значение, дату, время и пр.

Для работы со списком переменных нужно выбрать в дизайнере пункт "Список переменных" из меню "Файл". Если отчет создается с нуля, то список переменных будет пуст, и для его заполнения нужно нажать кнопку "Переменные" в нижней части окна. После этого в появившемся окне надо ввести список переменных, который имеет следующую структуру:

КАТЕГОРИЯ1
Переменная1
Переменная2
^ пробел обязателен!
КАТЕГОРИЯ2
Переменная1
Переменная2
....................

Обязательно наличие хотя бы одной категории. Имена переменных пишутся после пробела.

После заполнения списка надо сопоставить каждой переменной значение в основном окне. Для этого нужно выбрать переменную в списке слева и выбрать соответствующее значение в списке справа, пользуясь мышью. В списке справа показаны все источники данных (т.е. невизуальные dbaware-компоненты, наследники от TDataSet), которые доступны в данный момент, и имена их полей. В design-time будут доступны все датасеты, находящиеся в открытых модулях (units). В run-time будут доступны все датасеты, находящиеся в созданных формах или модулях данных (TDataModule).

Кроме того, если выбрать из выпадающего списка справа значение "Прочие переменные", то появится возможность сопоставить переменной одно из следующих значений:
· страница - номер текущей страницы;
· выражение - при выборе этого значения становится активной строка выражения внизу окна, куда можно ввести любое допустимое выражение (выражение не должно содержать тэги форматирования!);
· дата - дата начала формирования отчета;
· время - время начала формирования отчета;
· № строки;
· № строки сквозной;
· № колонки;
· всего страниц - всего страниц в сформированном документе, соответствует TotalPages. Для использования этого значения отчет должен быть двухпроходным (задается в опциях отчета).


Инспектор
Возврат в начало инструкции
Инспектор позволяет манипулировать некоторыми свойствами объектов, а именно: задавать имя объекта, его позицию и размеры, а также видимость. Окно инспектора похоже на Object Inspector в Delphi и функционирует аналогичным образом. Так же, как и остальные панели инструментов, его можно показать или скрыть соответствующей командой меню "Сервис/Панели инструментов". Двойной щелчок на заголовке окна инспектора сворачивает окно в полоску, еще один двойной щелчок - восстанавливает исходные размеры.

Если в строке инспектора набрать вместо числа выражение (например, 55 * 3,5) и нажать Enter, то подставится полученное значение.


Выделение
Возврат в начало инструкции
Для того, чтобы отобразить объект другим шрифтом или цветом в зависимости от какого-либо условия, можно воспользоваться диалогом "Атрибуты выделения". Диалог можно вызвать с помощью кнопки на панели управления рядом с кнопкой цвета шрифта. К примеру, нужно выделить суммы заказов, превышающие 1000$, жирным шрифтом. Для этого в объекте, содержащем сумму заказа, в диалоге указывается условие - Value > 1000 и задаются параметры шрифта. Условие выделения можно указать и по-другому - [Part total] > 1000.

Другой пример использования выделения - для придания отчету презентабельного вида можно сделать чередующуюся раскраску строк данных. Для этого на бэнд надо положить объект "Текст", растянуть его по ширине бэнда, в диалоге выделения набрать условие [LINE#] mod 2 = 0 и указать цвет фона (к примеру, серый).


Создание отчетов

Описание визуальных объектов
Возврат в начало инструкции


Простой отчет (список)
Возврат в начало инструкции
Это самый простой вид отчета. Перед тем, как разрабатывать внешний вид отчета, поместите на форму компоненты TfrReport, TfrDBDataSet, TDataSource, TTable. Настройте свойства компонент:

TfrDBDataSet.DataSource = TDataSource
TDataSource.DataSet = TTable

После этого запустите дизайнер отчетов двойным щелчком мыши на компоненте TfrReport. Далее необходимо разместить на листе бэнд Master data и поместить в него объекты со ссылками на нужные данные. Бэнд Master data необходимо связать с источником данных - компонентом TfrDBDataSet или TfrUserDataSet. Это делается в редакторе бэнда, который можно вызвать двойным щелчком мыши на бэнде.

Можно сразу построить отчет, нажав кнопку предварительного просмотра на панели инструментов или выбрав соответствующую команду из меню дизайнера.

Примечание 1. Бэнд, в котором нет ни одного объекта, при формировании отчета не обрабатывается.

Примечание 2. Если бэнду не назначен источник данных, то используется источник данных из свойства DataSet компонента TfrReport (если свойство ReportType при этом установлено в rtSimple).


Master-Detail отчет
Возврат в начало инструкции
Для построения этого отчета необходимо разместить на листе бэнды Master data и Detail data, затем поместить в них объекты со ссылками на нужные данные. Порядок, в котором бэнды размещаются на листе, не имеет значения - сначала будет напечатана строка из master, потом соответствующие ей строки из detail. Отчет будет формироваться до тех пор, пока есть данные для master. Если надо, чтобы master с его подчиненным списком печатался с нового листа, установите для бэнда флажок "Формировать новую страницу".

У отчета есть особенность - если для текущей строки из master список detail пуст, строка master печататься не будет. Если все же необходимо распечатать такие строки, для бэнда Master data нужно установить флажок "Печатать, если detail пуст".


Master-Detail-Subdetail отчет
Возврат в начало инструкции
Для построения отчета разместите на листе бэнды Master data, Detail data и Subdetail data. В остальном принципы построения такие же, как и для отчета Master-Detail.


Cross-tab отчет
Возврат в начало инструкции
Этот вид отчета предназначен для печати таблицы, число столбцов которой на этапе построения отчета неизвестно. При формировании отчета столбцы, не поместившиеся на странице, будут перенесены на следующую (как это делает всем знакомый MS Excel).

Для построения этого отчета разместите на странице бэнд Master data и бэнд Cross data. Бэнды CrossXXX размещаются на странице вертикально. На пересечении бэндов разместите объект, который будет отображаться в качестве ячейки таблицы. Необходимо разместить объект таким образом, чтобы он полностью помещался в границы области пересечения бэндов. Это все, что нужно для построения базового отчета.

Бэнд Cross footer печатается последним столбцом (например, если нужно отпечатать сумму по строке), а Cross header - первым. Кроме того, если в опциях бэнда включен флажок "Выводить на всех страницах", то при переносе широкой таблицы на смежный лист Cross header будет продублирован.


Отчет с переменной высотой строки
Возврат в начало инструкции
Очень часто приходится печатать отчеты, в которых высота строки данных может изменятся в зависимости от содержимого объектов, находящихся на бэнде (например, счет-фактура - название товара/услуги может быть длинным, на несколько строк текста). FR может печатать бэнды переменной высоты, если у них включена опция "Растягиваемый". Эту опцию также необходимо включить для объектов бэнда, высота которых может меняться. Если окажется, что максимальная высота бэнда меньше первоначальной, то он будет напечатан в первоначальном размере.

Если печатается обрамленная таблица, то опцию надо включить для всех ячеек (чтобы они имели одинаковую высоту, не нарушая обрамления). Объекты со включенной опцией растягиваются таким образом, что их нижний край совпадает с нижним краем бэнда.


Отчет с несколькими строками данных
Возврат в начало инструкции
FR не позволяет размещать на листе два одинаковых бэнда. Исключение составляют data-бэнды и их headers & footers - их можно размещать много (до 32). При печати одинаковые бэнды выводятся друг за другом. Это позволяет формировать отчеты, в которых строка данных состоит из нескольких бэндов, каждый - переменной высоты.

Таким образом можно сделать и Header/Footer для каждой записи. Если все бэнды одной строки данных не помещаются на странице, печать начинается со следующей.

Описанное справедливо для случая, если верхний бэнд имеет источник данных, а остальные - нет. Если же остальным бэндам назначены другие источники данных, то распечатаются сначала все строки из верхнего бэнда, затем из следующего и т.п. - в данном случае получится отчет типа Master-Detail-Detail.


Многоколоночный отчет
Возврат в начало инструкции
Если в обычном отчете при достижении конца страницы формирование продолжается с нового листа, то в многоколоночном - на том же листе, но рядом, т.е. в несколько смежнорасположенных колонок. Обычный отчет можно превратить в многоколоночный, всего лишь задав количество колонок в опциях страницы. Бэнды Column header и Column footer позволяют снабдить каждую колонку заголовком и нижней частью.


Отчет из нескольких страниц
Возврат в начало инструкции
FR позволяет легко делать многостраничные отчеты (например, первая страница - титульный лист, все остальное - прочая информация). Для того, чтобы создать/удалить лист, используйте кнопки на панели инструментов. Если необходимо сформировать несколько таких отчетов (например, для каждой записи таблицы), у компонента TfrReport необходимо установить свойство ReportType = rtMultiple, и в свойстве Dataset указать необходимый источник данных (TfrxxxDataset).


Вложенный отчет
Возврат в начало инструкции
Вложенный отчет - это отчет с размещенным на нем объектом SubReport, который представляет собой ссылку на другой отчет, расположенный на отдельной странице. При формировании такого отчета вместо объекта SubReport будет выведен соответствующий отчет. Объекты SubReport можно располагать на листе друг под другом или рядом. В случае, если объекты надо расположить друг под другом, их необходимо разнести по разным дата-бэндам (т.е. первый отчет - в первом бэнде Master data, второй - во втором и т.д.).

На использование SubReports накладываются следующие ограничения:
· нельзя использовать колонки;
· во вложенных отчетах (не в основном!) игнорируются бэнды ReportTitle, ReportSummary, PageHeader, PageFooter, ColumnXXX;
· нельзя использовать разрываемые бэнды;
· нельзя использовать группы.


Master-Detail отчет
Возврат в начало инструкции
Для построения этого отчета разместите на листе бэнд Master data и два бэнда Detail data. Для бэндов Detail data назначьте соответствующие источники данных. Если назначить источник данных только для верхнего бэнда, то получится отчет с несколькими строками данных.

Разумеется, таким образом можно строить и отчеты типа Master-Master, Master-Detail-SubDetail-SubDetail. Количество одинаковых дата-бэндов может быть до 32.


Композитный (составной) отчет
Возврат в начало инструкции
Композитный отчет позволяет получить отчет, состоящий из нескольких других. Для этого разместите на форме компонент TfrCompositeReport, и программным путем заполните его свойство Reports ссылками на отчеты, которые нужно объединить в один. Отчеты будут формироваться по порядку, причем если страница отчета имеет включенную опцию "Печать на предыдущем листе", то она будет напечатана начиная со свободного места на последнем листе предыдущего отчета.


Отчет с разрываемыми строками
Возврат в начало инструкции
В обычном отчете, если содержимое бэнда не помещается на оставшемся месте листа, то оно выводится на следующей странице (или колонке, если отчет многоколоночный). Если нужно, чтобы на оставшемся месте было напечатано столько строк, сколько вмещается, а печать остальных продолжилась со следующего листа (или колонки), у data-бэнда нужно включить опцию "Разрываемый". Если строка данных состоит из нескольких data-бэндов, то эту опцию нужно включать только у первого бэнда. Разрываться могут не только data-бэнды, но и все остальные, за исключением бэндов CrossXXX.


Отчет без бэндов
Возврат в начало инструкции
Часто бывает необходимо отобразить данные только из одной записи БД, разместив их на бланке. Пример - платежное поручение. В этом случае отчет может вообще не содержать бэндов. Объекты, расположенные непосредственно на листе, при печати выведутся на своих местах.


Отчет с группами
Возврат в начало инструкции
Группы применяются для группировки строк данных с использованием некоторого критерия. В качестве критерия обычно выступает выражение, основанное на полях из набора данных. При формировании отчета FR следит за значением критерия, и, как только оно изменится, формирует новую группу.

Для построения отчета разместите на листе бэнды Group footer и Master data. Назначьте источник данных для Master data, затем в редакторе бэнда Group footer укажите условие группировки. Например, чтобы распечатать список сотрудников в группированном виде (группировка по первой букве фамилии), надо указать примерно такое условие группировки: Copy([Фамилия], 1, 1). При изменении этого условия будет сформирована новая группа.

На использование групп накладываются следующие ограничения:
· нельзя применять группы во вложенных отчетах;
· группа может выступать только в роли списка 1-го уровня, т.е. сначала идет группа, затем - master, detail и т.п.

Исходный отчет Сформированный отчет

Примечание. Для правильной работы групп исходный набор данных должен быть уже отсортирован по условию группировки. Сортировку можно осуществить, применяя запрос (Query) с выражением ORDER BY.


Описание встроенных языковых средств

Описание визуальных объектов
Возврат в начало инструкции


Встроенный интерпретатор
Возврат в начало инструкции
В состав FastReport входит интерпретатор Pascal-подобного языка. Данный интерпретатор является мощным средством, позволяющим в независимости от используемого языка программирования (Delphi или C++Builder) писать скрипты, выполняющиеся при построении отчетов.
В качестве языка используется диалект Pascal, со следующими возможностями:
· операторы: присваивания; условные операторы, операторы циклов и безусловного перехода: if...then...else, while...do, repeat...until, for..to..do, goto;
· операторные скобки begin...end;
· бестиповые переменные, массивы;
· обращение к свойствам и методам объектов FastReport через точечную нотацию.

Язык по сравнению с Object Pascal сильно упрощен. Так, используются следующие упрощения:
· все переменные имеют тип Variant; отсутсвует описание переменных;
· все переменные являются глобальными, нет локальных переменных;
· отсутствуют такие типы данных, как "класс", "запись", перечисляемый тип и т.п.;
· нет возможности написания собственных процедур или функций;
· нет операторов прерывания цикла (break, continue);
· количество параметров, передаваемых в процедуру или функцию, может быть не более 3;
· в связи с тем, что переменные не имеют типа, контроль типов данных невозможен - это следует учитывать при написании логических выражений;
· массивы могут быть только одномерными.

Несмотря на значительные упрощения, интерпретатор позволяет выполнять довольно сложную обработку информации. Из скрипта доступны все свойства и методы объектов отчета, а также поля таблиц БД. В скрипте можно создавать переменные и массивы, которые будут доступны во всем отчете. О возможностях встроенного языка говорит тот факт, что такая довольно сложная задача, как печать сумм группы в ее заголовке (сама сумма считается в подвале группы) средствами языка FastReport делается элементарно.

Скрипты и объекты
В каждом объекте может быть размещен один или несколько (блок) операторов. Редактирование скрипта производится в окне редактора текста (для того, чтобы увидеть скрипт, надо нажать кнопку в верхней части окна). Скрипт выполняется каждый раз перед печатью объекта. По сути, скрипт является обработчиком события OnBeforePrint объекта.

Скрипт имеется не только у объектов. И бэнды, и страницы отчета также имеют свой скрипт. Вызвать скрипт бэнда можно, вызвав редактор свойства OnBeforePrint бэнда (из инспектора объектов, либо выделив бэнд и нажав Ctrl+Enter). Вызвать скрипт страницы отчета можно, вызвав редактор свойства OnBeforePrint страницы (для этого надо щелкнуть на пустом месте страницы и вызвать редактор из инспектора объектов). Диалоговая форма, как и страница отчета, имеет скрипт - свойство OnActivate. Скрипт остальных объектов может быть вызван через их свойство Memo либо при нажатии Ctrl+Enter.

Написание кода
В скрипте можно использовать свойства и методы объектов отчета, поля таблиц БД, различные константы. Также можно создавать переменные и массивы, которые будут доступны во всем отчете. Кроме того, можно использовать процедуры и функции.

Использование переменных
Переменную описывать не надо, она имеет тип Variant. В имени переменной можно использовать латинские буквы, цифры и знак подчеркивания. Переменную из скрипта можно использовать в объектах, и наоборот, переменную из списка переменных можно использовать в скрипте. Скриптовые переменные хранятся в объекте TfrVariables, к которому есть доступ через глобальную переменную frVariables.
Пример использования промежуточной переменной:

begin
  Cust := [CustomerData.RepQuery."CustNo"];
  if FinalPass then
    TotalSales := Arr[Cust] else
    TotalSales := 0;
end;

В этом примере создается переменная Cust, которой присваивается значение поля таблицы БД.

Кроме этого, можно обращаться к переменным, определенным в словаре данных, к системным переменным, а также пользовательским переменным. При этом переменные могут содержать в имени недопустимые с точки зрения синтаксиса символы (например, системная переменная Page#). Обращаться к таким переменным следует с использованием квадратных скобок:

begin
  a := [Page#];
end

Обращение к полям БД
В скрипте могут быть использованы ссылки на поле из таблицы БД. Обращение к полям выполняется в следующем виде:
[Имя формы.Имя таблицы."Имя поля"]
Полная форма обращения применяется в случае, если компонент-таблица и компонент-отчет расположены на разных формах (или модулях данных). Если компоненты расположены на одной форме, обращение может быть вида [Имя таблицы."Имя поля"].
Форма обращения ["Имя поля"] использует для поиска поля таблицу, которая является основной для бэнда, в котором такое обращение произошло. Например, имея бэнд master data, к которому через источник данных подключена таблица Customer.db, мы можем в пределах всего отчета обращаться к полям таблицы с использованием краткой формы. Использование полной формы обращения не приводит к замедлению работы - в ядре FastReport имеется кэш, который хранит обращения к полям БД.

Массивы
В скрипте, помимо переменных, можно создавать массивы. Массивы могут быть только одномерными, но можно организовать доступ к элементам массива таким образом, что можно трактовать массив как двумерный или с болшим количеством измерений.

Пример использования массива:

begin
  MyArr[0] := 'a'; MyArr[1] := 'b'; MyArr[3] := 'd';
  MyArr[2] := MyArr[0] + MyArr[1] + 'c' + MyArr[3];
end;

Фактически значения элементов массива хранятся в списке frVariables в виде
Arr_имя массива_индекс. Т.е. в вышеприведенном примере мы получим содержимое frVariables:

Arr_MyArr_0 := 'a'
Arr_MyArr_1 := 'b'
Arr_MyArr_2 := 'abcd'
Arr_MyArr_3 := 'd'

Константы
В скрипте можно использовать константы. Простейший пример - использование числовых, строковых и логических констант:

begin
a := 0;
b := 'abcd';
c := True;
d := 'That''s all!';
end;

Обратите внимание на использование одинарной кавычки внутри строковой константы - как и в Pascal, ее надо дублировать: d := 'That''s all!'.
Кроме простых констант, в скрипте доступны константы - названия цветов, стилей шрифта и пр. Вот список констант, которые можно использовать:

· цвета: clWhite, clBlack и т.п. - все стандартные цвета + системные цвета;
· результат работы диалогового окна: mrNone, mrOk, mrCancel;
· служебные: CRLF, Null;
· стиль шрифта: fsBold, fsItalic, fsUnderline;
· рамка объекта: frftNone, frftRight, frftBottom, frftLeft, frftTop;
· выравнивание текста в объекте "Текст": frtaLeft, frtaRight, frtaCenter, frtaVertical, frtaMiddle, frtaDown;
· выравнивание по бэнду: baNone, baLeft, baRight, baCenter, baWidth, baBottom.

Кроме того, определены константы для подключаемых объектов, например, csCheck для объекта "CheckBoxObject". Все, что можно видеть в выпадающих списках свойств в инспекторе объектов, можно использовать как константу в скрипте.

Обращение к объектам
В скрипте можно обращаться к свойствам и методам объектов отчета. К объектам отчета относятся визуальные объекты, элементы управления, бэнды, страницы отчета, сам отчет. Для обращения к объекту применятся точечная нотация, например: Memo1.Text. Для обращения к собственным свойствам или методам точечная нотация необязательна.
Свойства, к которым возможно обращение, отображены в инспекторе объектов. К некоторым комплексным свойствам (например, Font) возможно обращение как к Font.Name, Font.Size и т.п.:

begin
Memo1.Font.Name := 'Courier New';
Memo1.Font.Size := 10;
Memo1.Font.Color := clRed;
Memo1.Font.Style := fsBold + fsItalic
end;

К свойствам типа TStrings (Memo, SQL, Items и пр.) возможен доступ по индексу:

if Memo1.Lines[1] = 'a' then
Memo1.Lines[1] := 'b'

Также к таким свойствам могут применяться операции Add, Delete, Clear и Count:

if Memo1.Lines.Count > 10 then
Memo1.Lines.Delete(10)
else
begin
Memo1.Lines.Clear;
Memo1.Lines.Add('a');
end;

Полный список свойств и методов объектов см. в разделе "Свойства и методы объектов". Следует отметить, что обращение к несуществующему методу или свойству не приведет к сообщению об ошибке. Поэтому следует быть осторожным при написании кода.

Использование процедур и функций
В скрипте могут содержаться вызовы процедур и функций. Особенность интерпретатора, а точнее, парсера, который отвечает за обработку процедур/функций, состоит в том, что процедура или функция может иметь не более трех параметров. В скрипте могут использоваться как встроенные процедуры, так и внешние, определенные в проекте. Список встроенных процедур и функций см. в разделе "Описание встроенных процедур и функций".
Примечание. При обращении к процедуре или функции нельзя ставить пробел между именем процедуры и открывающей скобкой.

Модификация объектов
В скрипте можно выполнить любые модификации объекта (либо других объектов) - например, изменение размеров, цвета, содержимого и пр. Следует учесть, что объекты, которые уже обработаны, модифицированы быть не могут. То есть, попытка из объекта, лежащего на бэнде report summary, изменить содержимое объекта из report title, ни к чему не приведет. Однако, сделав отчет двухпроходным, мы сможем выполнить такую модификацию.
Аналогичным образом обстоят дела в случае многостраничного отчета. Мы можем обращаться к любому объекту по его имени (имя в пределах отчета уникально). Но модифицированы могут быть только объекты, которые еще не обрабатывались. Если все же требуется модификация уже обработанного объекта, следует сделать отчет двухпроходным.


Встроенные функции

Агрегатные функции
Возврат в начало инструкции
Могут применяться в бэндах ReportSummary, PageFooter, MasterFooter, DetailFooter, SubdetailFooter, GroupFooter, CrossFooter.
· Sum(<expression> [,band] [,1]). Вычисляет сумму выражения expression для ряда строк данных. Если параметр band не задан, то сумма считается по строке данных, соответствующей данному бэнду (по бэндам MasterData, DetailData, SubdetailData); иначе сумма считается только по бэнду с именем band. Если в расчет надо включить невидимые бэнды, надо указывать третий параметр (1). Пример использования:
Sum([Part total], Band1);
Sum([[Part total] + [Part price]]);
Sum([Part total], Band1, 1).
· Avg, Min, Max. Синтаксис аналогичен функции Sum. Функция Avg вычисляет среднее арифметическое, функция Min возвращает минимальное, функция Max - максимальное значение из ряда.
· Count(<band>). Возвращает количество строк данных. Пример использования:
Count(Band1).

Функции работы со строками
· Str(<value>). Преобразует число в строку.
· Copy(<string>, <from>, <count>). Возвращает подстроку (аналогично одноименной функции в Delphi).
· If(<expression>, <string1>, <string2>). Возвращает строку string1, если выражение expression истинно; иначе возвращает строку string2.
· FormatFloat(<formatstr>, <value>). Преобразует числовое значение value в строку, используя форматирование formatstr. Возможные значения formatstr описаны в документации к Delphi, раздел "Formatting strings".
· FormatDateTime(<formatstr>, <value>). Преобразует дату/время value в строку, используя форматирование formatstr. Возможные значения formatstr описаны в документации к Delphi, раздел "Formatting strings".
· StrToDate(<value>). Преобразует строку в дату.
· StrToTime(<value>). Преобразует строку во время.
· UpperCase(<value>). Преобразует символы строки в верхний регистр.
· LowerCase(<value>). Преобразует символы строки в нижний регистр.
· NameCase(<value>). Преобразует символы строки в нижний регистр, а первый символ - в верхний.
· Length(<string>). Возвращает длину строки.
· Trim(<string>). Отбрасывает пробелы в начале и в конце строки и возвращает результат.
· Pos(<substring>, <string>). Возвращает позицию подстроки <substring> в строке <string>.

Арифметические функции
· Int(<value>). Возвращает целую часть числа value.
· Frac(<value>). Возвращает дробную часть числа.
· Round(<value>). Возвращает округленное значение.
· value1 Mod value2. Возвращает остаток от деления value1 на value2.
· MinNum(<value1>, <value2>). Возвращает меньшее из двух чисел.
· MaxNum(<value1>, <value2>). Возвращает большее из двух чисел.

Прочие функции
· Input(<caption> [,<default>]). Выводит на экран диалоговое окно с заголовком caption и строкой ввода. Если задан параметр default, то это значение появится в строке ввода. После ввода пользователя возвращает введенную строку.
· Date. Возвращает дату начала формирования отчета.
· Time. Возвращает время начала формирования отчета.
· Line#. Возвращает номер строки данных; нумерация начинается с начала группы. Например:
Master data
1. Detail data
2. Detail data
3. Detail data
Master data
1. Detail data
2. Detail data
· LineThrough#. Возвращает номер строки данных; нумерация строк начинается с начала отчета, например:
Master data
1. Detail data
2. Detail data
3. Detail data
Master data
4. Detail data
5. Detail data
· Column#. Возвращает номер колонки в cross-tab отчете.
· Page#. Возвращает номер текущей страницы.
· TotalPages. Возвращает общее количество страниц в сформированном отчете. Для использования этой функции отчет должен быть двухпроходным.
· DayOf(<date>). Возвращает день даты.
· MonthOf(<date>). Возвращает месяц даты.
· YearOf(<date>). Возвращает год даты.
· MessageBox(<text>, <caption>, <buttons_and_icons>). Выводит стандартное окно диалога с текстом <text> и заголовком <caption>. Набор кнопок и иконка окна задается в параметре <buttons_and_icons>. Возвращает значение, соответствующее нажатой кнопке (mrOk, mrCancel, mrYes, mrNo). В качестве <buttons_and_icons> можно использовать значения:

Кнопки Иконка
mb_Ok mb_IconError
mb_OkCancel mb_IconQuestion
mb_YesNo mb_IconInformation
mb_YesNoCancel mb_IconWarning

Процедуры и функции для манипуляции построением отчета
· CurY. Возвращает текущую позицию по Y (в пикселах), с которой будет выведен очередной бэнд. Этому свойству можно также присвоить нужное значение для смены позиции. Это позволяет строить довольно экзотические отчеты.
· FreeSpace. Возвращает высоту оставшегося свободного места на странице в пикселах.
· FinalPass. Возвращает истину, если отчет двухпроходный и выполняется последний проход.
· PageHeight. Возвращает высоту страницы в пикселах с учетом высоты бэнда Page footer.
· PageWidth. Возвращает ширину страницы в пикселах.
· StopReport. Останавлявает построение отчета.
· NewPage. Начинает формирование отчета с новой страницы.
· NewColumn. Начинает формирование отчета с новой колонки, если отчет многоколоночный.
· ShowBand(<band>). Показывает бэнд <band>.


 Экспортировать линии рамок объектов.


 При редактировании объекта "Текст" использовать тот же шрифт, что и в объекте.


 Имя нового алиаса, представляющего эту базу данных. Если вы работаете с IBX или ADO, здесь указывается имя файла с базой данных. Чтобы выбрать файл, воспользуйтесь кнопкой справа.


 Имя компонента - базы данных.


 Установка этой опции приведет к печати кода в виде читаемого текста.


 Установка этой опции приведет к формированию дополнительного проверочного кода.


 Устанавливает выравнивание текста по левому краю в выделенном объекте "Текст".


 Устанавливает единицы измерения, выраженные в дюймах.


 Содержимое OLE контейнера.


 Список возможных типов фигуры.


 Задает шаг сетки, равный 18 экранным пикселам, что соответствует 5мм.


 Размер поля. Имеет значение, если выбран тип поля "строка".


 Добавляет пару полей (из подчиненного и основного набора данных) в список связанных полей. Для добавления выделите поле в подчиненном наборе, пользуясь мышью, затем соответствующее ему поле в основном наборе, и нажмите эту кнопку.


 Показывает в цвете кнопки на панелях инструментов и в окне предварительного просмотра. Если опция отключена, то кнопка показывается в цвете только при наведении на нее указателя мыши.


 Перед формированием отчета запросить значение параметра в диалоге.


 Показывает диалог - редактор параметров запроса.


 Если опция включена, то после помещения нового объекта на страницу вызывается его редактор.


 Взять значение параметра из основного (master) источника данных. Для этого в окне редактирования запроса надо назначить основной источник данных.


 Текст запроса.


 Элемент является строкой ввода.


 Для построения графика необходимо указать имена двух объектов типа "Текст", в которых содержится название и соответствующее числовое значение. При построении отчета содержимое этих объектов будет накапливаться в мемо диаграммы. В этом поле указывается имя объекта, содержащего числовое значение.


 Создает новую базу данных. Это обязательно при работе с IBX или ADO.


 Параметры соединения с БД. Здесь можно указать имя пользователя, пароль и другие нужные параметры. Замечание: разные драйверы БД используют разные наименования параметров.


 При установленной опции будет выводиться окно запроса имени пользователя и его пароля, когда вы подключаетесь к БД. Если эти параметры уже заданы в списке параметров БД, эту опцию можно отключать.


 Список доступных БД. Выберите нужную БДиз списка, потом выберите таблицу из списка ниже. Для выбора локальных таблиц (Paradox, DBase) можно воспользоваться кнопкой "Обзор".


 Список доступных таблиц в выбранной базе данных.


 Вы можете выбрать таблицу прямо из файла (если вы используете локальные таблицы Paradox, DBase совместно с BDE).


 Размер шрифта для использования в редакторе текста.


 Тип штрихкода.


 Образец шрифта, используемого в редакторе текста.


 Коэффициент масштабирования по X.


 Экспортировать изображения.


 В этом поле можно задать более понятное название для элемента (набора данных или его поля), выбранного в списке в правой части окна.


 Код, котрый нужно напечатать. Для вставки в это поле переменной FR или поля таблицы БД используйте кнопку справа от строки ввода.


 В этом поле можно задать более понятное название для элемента, выбранного в списке в правой части окна.


 Символ-разделить формата CSV.


 Конвертировать выходной файл в таблицу.


 Имя шрифта для использования в редакторе скрипта.


 Выключает все линии рамки выделенного объекта. Команда также доступна при нажатии Ctrl+D.


 Вставка в документ рисунка. Рисунок может быть загружен из графического файла в формате BMP, ICO, WMF, EMF, JPG (рисунки в формате JPG доступны в Delphi 3 и выше).


 Открывает существующий документ (файл в формате FRF). Команда также доступна при нажатии Ctrl+O.


 Выделяет все объекты на странице. Команда также доступна при нажатии Ctrl+A.


 Показывает на странице точечную сетку для более удобного размещения объектов. Повторное нажатие прячет сетку. Шаг сетки может быть задан в диалоговом окне, которое можно вызвать из меню "Сервис", "Настройка". Команда также доступна при нажатии Ctrl+G.


 Выравнивание объектов по сетке. При перемещении объекта мышью или при изменении его размеров положение и размеры объекта меняются скачкообразно, в соответствии с шагом сетки. Это позволяет более ровно размещать объекты на листе. Команда также доступна при нажатии Ctrl+B.


 Включает или выключает верхнюю линию рамки выделенного объекта.


 Устанавливает портретную ориентацию листа.


 Устанавливает единицы измерения, выраженные в миллиметрах.


 Задает условие, при выполнении которого объект будет выведен с атрибутами выделения.


 Показывает редактор списка переменных.


 Располагает выбранные поля друг за другом по горизонтали.


 Ищет текст, начиная с первой страницы.


 Диаграмма может быть двух типов: одиночная и множественная (т.е. на одной координатной плоскости изображается несколько графиков). Множественная диаграмма может быть использована, например, в отчете с группами, многоуровневом отчете или cross-tab отчете.


 Печать только текущей страницы.


 Редактирует содержимое OLE контейнера.


 Вызывает окно редактора формата переменных. Редатор переменных доступен также из контекстного меню объекта. Для быстрого вызова можно воспользоваться комбинацией клавиш Ctrl+F.


 Задает шаг сетки, равный 4 экранным пикселам.


 Добавляет к каждому полю заголовок. В качестве заголовка используется имя поля.


 Поле для ввода номеров печатаемых страниц.


 Показывать координатные оси на диаграмме. Для круговой диаграммы эту опцию надо отключать.


 Создает новую таблицу БД.


 Имя нового lookup поля.


 Список полей подчиненного набора данных.


 Тип выбранного параметра.


 Выбор основного (master) набора данных.


 Список форматов бумаги, которые поддерживаются выбранным принтером. Если принтер поддерживает пользовательский формат бумаги, то при выборе соответствующего значения становятся доступны поля для ввода размера.


 Показывать название в качестве пометки.


 Поле из набора данных lookup, которое является ключевым.


 Поле из набора данных lookup, которое будет отображаться в списке.


 Местонахождение таблиц БД, на основе которых построен запрос. Здесь может быть значение из выпадающего списка либо путь к каталогу с таблицами. Это поле можно оставить пустым, в этом случае алиас или путь надо указывать в тексте запроса.


 Выражение фильтра для таблицы.


 При включении флажка перетаскивание или изменение размеров объектов сопровождается их немедленной прорисовкой. Иначе прорисовывается только контур объекта.


 Список функций, доступных в выбранной категории.


 Указывает, в каком порядке надо печатать листы документа, если задана печать нескольких копий.


 Удалять пустые строки из выходного документа.


 Задает промежуток между соседними колонками.


 Поле из основного набора данных, которое ссылается на ключевое поле из lookup набора данных.


 Строки списка. Если в строке присутствует символ ";", например, "декабрь;12", то в списке будет выведено слово "декабрь", а при выборе этого значения будет подставлена строка "12".


 Поля, связанные с полями из основного источника данных. Для редактирования связанных полей воспользуйтесь кнопкой в правой части строки.


 Если опция включена, то у бэндов отображается закладка с заголовком, иначе бэнд отображается в виде серой полосы без закладки.


 Список доступных лотков принтера.


 Из этого списка можно выбрать, какие страницы печатать: все, четные или нечетные.


 Конвертировать текст в DOS-кодировку.


 Считывает текст SQL запроса из файла


 Записывает текст SQL запроса в файл


 Показывать название и процент в качестве пометки.


 Нижнее поле страницы.


 Устанавливает единицы измерения, выраженные в экранных пикселах.


 Задает фон для объекта, выводимого с атрибутами выделения.


 Поле для ввода выражения. Становится доступно при включении флажка "Выражение". При этом введенное выражение назначится текущей переменной.


 Список бэндов, которые пересекаются с бэндом Cross data. Для каждого бэнда в списке можно назначить свой источник данных. Для этого выберите бэнд щелчком мыши, а затем выберите соответствующий ему источник.


 Список полей в выбранной таблице БД. Для отметки полей, вставляемых в отчет, щелкайте мышкой по нужным полям, удерживая клавишу Ctrl. Чтобы отметить группу подряд идущих полей, щелкните мышкой на первом поле, и, нажав клавишу Shift, щелкните на последнем.


 Если опция включена, то при поиске будет учитываться регистр.


 Печать всех страниц.


 Трехмерное отображение диаграммы.


 Включает или выключает перенос слов в длинных строках редакторов текста и скрипта.


 Текст, который будет отображаться внутри элемента.


 Определяет позицию страницы отчета в окне дизайнера.


 Использовать символы псевдографики при экспорте рамок.


 При включении флажка становится доступным поле для ввода выражения.


 Для построения графика необходимо указать имена двух объектов типа "Текст", в которых содержится название и соответствующее числовое значение. При построении отчета содержимое этих объектов будет накапливаться в мемо диаграммы. В этом поле указывается имя объекта, содержащего название.


 Элемент является выпадающим списком.


 При редактировании объекта "Текст" использовать фиксированные установки шрифта.


 Вставлять символы разрыва страницы в выходной файл.


 Список наборов данных, используемых в текущем отчете. Остальные данные, имеющиеся в приложении, будут недоступны.


 Объект позволяет легко строить графики типа "Top10", т.е. график, в котором представлены только первые самые большие значения, а остальные значения просуммированы в отдельную группу с названием. В этом поле указывается количество выводимых значений.


 Список всех источников данных для бэндов, имеющихся в приложении. Для использования только нужных источников, перетащите их в список в правой части окна.


 Размер шрифта для использования в редакторе скрипта.


 Список источников данных для бэндов, используемых в текущем отчете.


 Образец шрифта, используемого в редакторе скрипта.


 Открывает ранее сохраненный отчет (файл с расширением .frp). Команда также доступна при нажатии клавиш Ctrl+O.


 Вызывает диалог сохранения файла. По умолчанию сохраняет отчет в файле .frp. Если доступны фильтры экспорта, то соответствующие типы файлов появятся в выпадающем списке "Тип файла". Команда также доступна при нажатии клавиш Ctrl+S.


 Вызывает диалог печати файла. Команда также доступна при нажатии клавиш Ctrl+P.


 Осуществляет поиск строки текста в сформированном отчете. Эта команда доступна также при нажатии клавиш Ctrl+F (начать поиск) и F3 (продолжить поиск).


 Закрывает окно.


 Отображает номер текущей страницы.


 Отображает страницы отчета. При нажатии правой кнопки мыши выводится контекстное меню, в котором можно сменить масштаб изображения, а также редактировать содержимое текущей страницы, добавить новую страницу или удалить текущую.


 Показывать название и числовое значение в качестве пометки.


 Настройка параметров шрифта.


 Показывает выпадающее меню для выбора масштаба изображения. Команда также доступна при нажатии клавиши "Пробел".


 Устанавливает или снимает подчеркивание у шрифта.


 Устанавливает выравнивание текста влево.


 Устанавливает выравнивание текста по центру.


 Устанавливает выравнивание текста вправо.


 Устанавливает или снимает маркировку в выделенном фрагменте.


 Устанавливает отступ для первой строки абзаца.


 Устанавливает отступ для всех строк абзаца, кроме первой.


 Устанавливает отступ справа для текста.


 Содержимое объекта.


 Устанавливает или снимает наклон у шрифта.


 Записывает содержимое в файл формата .RTF.


 Отменяет последнее выполненное изменение.


 Показывает диалог установки параметров шрифта.


 Позволяет быстро вставить переменную в текст.


 Показывает список установленных в системе шрифтов.


 Устанавливает размер шрифта.


 Устанавливает или снимает утолщение у шрифта.


 Открывает файл в формате .RTF.


 data-бэнд

Бэнд, который может быть подключен к источнику данных. Data-бэндами являются Master data, Detail data, Subdetail data, Cross data.


 Очищает список связанных полей.


 Печать только выбранных страниц.


 Создает новый запрос (Query).


 Список связанных полей.


 Список всех наборов данных, имеющихся в приложении. Для того, чтобы использовать только нужные данные, перетащите их в список в правой части окна.


 Имя драйвера БД (при работе с BDE).


 Ориентация штрихкода.


 Вызывает диалог настройки параметров страницы. Команда доступна также при двойном щелчке мышью на пустом месте страницы.


 Вставка горизонтальной или вертикальной линии в документ. При нажатии кнопки включается режим рисования, при котором курсор мыши принимает вид карандаша. Для отмены режима нажмите кнопку со стрелкой на этой панели.


 Вставка подключаемого (Add-In) объекта в документ.


 Мастера, установленные в системе. Список мастеров также доступен в меню "Сервис", "Мастера".


 Включает или выключает правую линию рамки выделенного объекта.


 Выбор цвета заливки объекта. При нажатии кнопки показывает выпадающий список цветов. Если в списке выбран цвет "Другие", то показывает стандартный диалог выбора цвета.


 Устанавливает толщину рамки выделенного объекта. Команда также доступна при нажатии Ctrl+1..9.


 Ориентация шрифта для выбранного объекта "Текст". В нажатом положении выводит вертикальный шрифт.


 Устанавливает вертикальное выравнивание текста (по верхнему краю, по центру и по нижнему краю) в выделенном объекте "Текст".


 Устанавливает выравнивание текста по правому краю в выделенном объекте "Текст".


 Выбор цвета шрифта. При нажатии кнопки показывает выпадающий список цветов. Если в списке выбран цвет "Другие", то показывает стандартный диалог выбора цвета.


 Устанавливает или снимает подчеркивание для шрифта, которым отображается выделенный объект "Текст".


 Выбор цвета рамки объекта. При нажатии кнопки показывает выпадающий список цветов. Если в списке выбран цвет "Другие", то показывает стандартный диалог выбора цвета.


 Устанавливает или снимает наклон для шрифта, которым отображается выделенный объект "Текст".


 Устанавливает выравнивание текста по обоим краям в выделенном объекте "Текст".


 При нажатой кнопке курсором мыши можно выделять объекты, перемещать их и изменять размеры.


 Включает все линии рамки выделенного объекта. Команда также доступна при нажатии Ctrl+F.


 Вставка секции (бэнда) в документ.


 Вставка в документ объекта "Текст". Объект предназначен для отображения многострочного текста, полей из таблицы БД, служебной информации (например, номера страницы, даты, времени).


 Сохраняет документ в файле. Если документ новый, запрашивает имя файла. Если в списке "Тип файла" выбран шаблон FastReport, то будет показан диалог для описания шаблона. Команда также доступна при нажатии Ctrl+S.


 Отменяет последнее действие. Система помнит список из последних 100 изменений. Некоторые операции (удаление страницы, установка опций) не могут быть отменены. Команда также доступна при нажатии Ctrl+Z.


 Повторяет отмененное действие. Система помнит список из последних 100 отмененных действий. Команда также доступна при нажатии Ctrl+Y.


 Перемещает выделенный объект или группу объектов на передний план.


 Создает новый пустой документ. Новый документ можно также создать на основе шаблона, воспользовавшись командой меню "Файл", "Новый...".


 Добавляет новую страницу в документ.


 Меняет позицию и размеры выделенных объектов таким образом, чтобы они располагались в узлах сетки.


 Закрывает окно дизайнера.


 Показывает диалог, в котором можно задать атрибуты выделения. Эта команда доступна, если выбран объект "Текст".


 Перемещает выделенный объект или группу объектов на задний план.


 Панель инструментов, с помощью которой можно задать выравнивание объектов относительно друг друга или в окне. При выравнивании учитывается, какой из объектов был выделен первым.


 Добавляет в отчет диалоговую страницу.


 Включает или выключает левую линию рамки выделенного объекта.


 Название шрифта, которым отображается выбранный объект "Текст". Чтобы сменить шрифт, щелкните мышью на этом поле и выберите нужный шрифт из списка. Желательно использовать шрифты с символом "Тт" - TrueType, так как они лучше масштабируются.


 Размер шрифта, которым отображается выбранный объект "Текст". Чтобы сменить размер, щелкните мышью на кнопке со стрелкой в правой части поля и выберите нужный размер из списка. Если такого размера в списке нет, щелкните мышью на самом поле и введите размер вручную, после этого нажмите Enter.


 Устанавливает или снимает утолщение для шрифта, которым отображается выделенный объект "Текст".


 Текущая страница документа. Если в документе несколько страниц, то в верхней части страницы появятся дополнительные закладки. Чтобы вывести нужную страницу, щелкните мышкой на соответствующей закладке.


 Располагает выбранные поля друг за другом по вертикали.


 Если опция включена, то рядом с диаграммой выводится поясняющая подпись.


 Список полей набора данных, которые можно добавить в список доступных полей. Для того, чтобы добавить группу полей в список, щелкните мышкой на первом поле группы, затем, удерживая клавишу Shift, щелкните на последнем поле.


 Показывает редактор для выделенного набора данных. Команда также доступна с помощью двойного щелчка мыши на нужном наборе данных.


 Устанавливает альбомную ориентацию листа.


 Показывает диалог настройки принтера.


 Показывать пометки над каждым значением.


 Присвоить параметру конкретное значение.


 Показывает диалог - редактор списка доступных полей.


 При включении флажка создает бэнды Page header и Master data.


 Высота бумаги.


 Показывать числовое значение в качестве пометки.


 Строка ввода параметра функции. Для визуального ввода используйте кнопку в правой части строки.


 Имя таблицы.


 Действия над объектом, которые можно запретить.


 Опция позволяет начать печать страницы начиная со свободного места на предыдущем листе.


 Показывать процент в качестве пометки.


 Выбор индекса для таблицы.


 Список доступных категорий функций. При выборе категории в списке справа отображаются функции, входящие в категорию.


 Поле, в котором отображается построенное выражение. Поле также доступно для ручного редактирования.


 Задает количество колонок на странице для многоколоночных отчетов.


 Список полей, доступных в текущем наборе данных. Если список пуст, то будут доступны все поля набора данных.


 Список доступных таблиц БД.


 Список категорий форматирования. Переменная может отображаться как текст, число, дата, время, булевское значение.


 Список переменных в выбранной категории. Чтобы вставить переменную в текст, щелкните на ней мышкой.


 Список доступных полей в выбранной таблице БД.


 Показывает диалог выбора полей для добавления к списку доступных полей.


 Редактор скрипта. Чтобы показать или скрыть это окно, воспользуйтесь переключателем "Скрипт".


 Список способов форматирования для выбранной категории. Если в списке выбран формат "Другой", то становится доступна строка ввода пользовательского формата.


 Список категорий переменных.


 Показывает диалог, в котором можно создать новое lookup поле на основе поля из другого набора данных.


 Редактор текста.


 Символ-разделитель целой и дробной части числа.


 Выделяет все поля в списке.


 Запоминает все изменения и закрывает окно.


 Количество знаков в дробной части числа.


 Показывает диалог вставки OLE объекта.


 Удаляет выделенные поля из списка.


 Список созданных наборов данных. Двойной щелчок мышью на нужной иконке показывает редактор набора данных.


 Список параметров, имеющихся в тексте запроса.


 Отменяет все изменения и закрывает окно.


 Строка форматирования. Становится доступной, если в списке выбран формат "Другой". Строки форматирования для каждого из типов описаны в справочной системе Delphi, раздел formatting strings (кроме булевского типа, где строка представлена в формате Значение1;Значение2).


 Возможны два варианта страницы в дизайнере: с полями печати и без них. Если поля печати включены, то они отображаются в дизайнере и все, что находится вне полей, на печать не выводится. Если отключить поля печати, то предполагается, что страница в дизайнере соответствует области печати, т.е. все, что находится на странице, будет корректно напечатано на любом принтере. Правда, при этом вид страницы в дизайнере будет немного отличаться от распечатанного документа.


 Загружает рисунок из графического файла.


 Вызывает диалог открытия файла с картинкой.


 Список доступных шаблонов.


 Показывает на листе точечную сетку для более удобного размещения объектов.


 Задает утолщение для шрифта выделения.


 Список принтеров, установленных в системе. Если в системе нет установленных принтеров, то в списке можно выбрать только принтер по умолчанию - это позволит работать с дизайнером и делать предварительный просмотр.


 Позволяет быстро вставить переменную в редактируемый текст. Для быстрого вызова можно воспользоваться клавишей Insert.


 Очищает рисунок.


 Левое поле страницы.


 Поле для ввода краткого описания шаблона.


 Описание выбранного шаблона.


 При перемещении объекта мышью или при изменении его размеров положение и размеры объекта меняются скачкообразно, в соответствии с шагом сетки. Это позволяет более ровно размещать объекты на листе.


 Задает наклон для шрифта выделения.


 Если опция включена, то при открытии отчета выбирается указанный принтер.


 Список переменных. Для того, чтобы назначить переменной значение, выберите из выпадающего списка в правой части окна нужную таблицу БД, затем щелкните мышкой на нужном поле из списка полей.


 Список переменных, который имеет следующую структуру:

КАТЕГОРИЯ 1
Переменная1
Переменная2
^ пробел обязателен!
КАТЕГОРИЯ 2
Переменная1
Переменная2
....................
Обязательно наличие хотя бы одной категории. Имена переменных пишутся после пробела.


 Позволяет быстро вставить ссылку на поле таблицы БД в редактируемый текст.


 Верхнее поле страницы.


 Растянуть рисунок по размерам окна.


 Выбранная картинка.


 При перемещении или изменении размеров объект выделяется контуром.


 Задает подчеркивание для шрифта выделения.


 Опцию необходимо включать в случае, если для формирования отчета требуется выполнить два прохода. Это может понадобиться, если отчет содержит информацию об общем количестве страниц.


 Список доступных таблиц БД. В списке также имеется строка "Системные переменные", при выборе которой становятся доступны переменные "дата", "время", "выражение", "номер страницы" и пр.


 Список доступных источников данных - компонентов TfrUserDataSet, TfrDBDataSet. В списке имеются также пункты "Нет" (источник данных не назначен) и "Виртуальный" (назначается источник данных типа TfrUserDataSet с количеством записей, задаваемым в соответствующем поле).


 Список бэндов, которые можно вставить в отчет. Для вставки бэнда выберите нужный тип и нажмите кнопку "ОК".


 Показывает или скрывает редактор скрипта.


 Правое поле страницы.


 Задает прозрачный фон для объекта, выводимого с атрибутами выделения.


 Список доступных полей в выбранной таблице БД. Если выбрана строка "Системные переменные", то в списке становятся доступны переменные "дата", "время", "выражение", "номер страницы" и пр.


 При перемещении или изменении размеров объект выделяется инверсией.


 Поле становится доступно при выборе виртуального источника данных. Задает количество записей в источнике.


 Выражение - условие группировки. При изменении значения выражения будет сформирована новая группа. Для подстановки в строку поля из таблицы БД, используйте кнопку в правой части строки.


 Поле для ввода искомой строки.


 Задает количество печатаемых копий.


 Переключает размер шрифта, используемого в редакторах текста и скрипта.


 HelpScribble

HelpScribble is a help authoring tool written by Jan Goyvaerts. This help file was created with the unregistered version of HelpScribble, which is why you can read this ad. Once the author of this help file is so honest to register the shareware he uses, you will not see this ad again in his help files.
Recompiling the help project with the registered version is all it takes to get rid of this ad.

HelpScribble is a stand-alone help authoring tool. It does not require an expensive word processor. (Only a help compiler as Microsoft likes keeping the .hlp format secret. Not my fault.)

Here are some of HelpScribble's features:

· The Setup program will properly install and uninstall HelpScribble and all of its components, including registry keys.
· Create, edit and navigate through topics right in the main window. No need to mess with heaps of dialog boxes.
· All topics are listed in a grid in the main window so you won't lose track in big help projects. You can even set bookmarks.
· Use the built-in Browse Sequence Editor to easily create browse sequences.
· Use the built-in Window Editor to change the look of your help window and create secondary windows.
· Use the built-in Contents Editor to create Windows 95-style contents files. Works a lot better than Microsoft's HCW.
· No need to mess with Microsoft's SHED: use the built-in SHG Editor to create hotspot bitmaps. Draw your hotspots on the bitmap and pick the topic to link to from the list.
· With the built-in Macro Editor you can easily compose WinHelp macros whenever needed. It will tell you what the correct parameters are and provide information on them.
· If you have a problem, just consult the online help. The help file was completely created with HelpScribble, of course.
· HelpScribble is shareware. However, the unregistered version is not crippled in any way. It will only add a small note to your help topics to encourage you to be honest and to register the shareware you use.

These options are very interesting for Delphi and C++Builder developers:

· If you are a component writer, use the Delphi Parser to build an outline help file for your component. Just fill in the spaces and you are done. HelpScribble can also extract the comments from your source file and use them as the default descriptions.
· If you are an application writer, HelpScribble provides you with a property editor for the HelpContext property. You can select the topic you need from a list of topic titles or simply instruct to create a new topic. No need to remember obscure numbers.
· The property editor also provides a tree view of all the components on your form and their HelpContext properties. This works very intuitively. (Much nicer than those help tools that simply mess with your .dfm files.)
· HelpScribble can perform syntax highlighting on any Delphi source code in your help file.

HelpScribble is shareware, so feel free to grab your copy today from my web site at http://www.ping.be/jg/


.topic 1300

.topic 1300
Представляет собой произвольным образом обрамленный прямоугольник с многострочным  текстом внутри. Задается цвет текста/заливка, тип рамки, толщина  рамки и цвет, все параметры шрифта текста, выравнивание текста внутри прямоугольника и ориентация текста (норм./90 градусов). Объект может быть выведен с использованием атрибутов выделения, если выполняется условие выделения.

В  мемо объекта можно поместить многострочный текст с переменными. Переменные обрамляются квадратными скобками. При формировании отчета, когда в объекте обнаруживается переменная, вызывается событие, которому  передается имя переменной (это может быть и не имя, а выражение - см. разборщик выражений) и ожидается возврат ее значения. Примеры использования переменных:

Длина, см: [Длина]
Длина, см: [Table1."Length_cm"]
Длина, см: [[Длина в дюймах] * 2.54]
Длина, см: [Table1."Length_in" * 2.54]

Редактор объекта позволяет редактировать содержимое мемо, быстро вставлять переменные и поля доступных таблиц БД в мемо, а также редактировать скрипт. Для более удобной работы можно воспользоваться быстрыми клавишами: Insert - вставка переменной; клавиша Ctrl+Enter - аналог кнопки OK; клавиша Ctrl+F - аналог кнопки "Формат".

Помимо основного редактора, имеется редактор, позволяющий выбрать формат переменных. Вызвать его можно либо из контекстного меню объекта, либо из окна редактора мемо (кнопка "Формат"). Переменная может отображаться как текст, число, дата, время, булевское значение. Для каждого из этих типов (кроме текстового представления) можно выбрать один из нескольких способов форматирования, например, для числа можно задать количество знаков после запятой, знак-разделитель целой и дробной части, разделение на разряды. Кроме того, для каждого типа может быть выбран произвольный формат, когда строка форматирования задается вручную (например, #,###,##0.000 для числа). Строки форматирования для каждого из типов описаны в справочной системе Delphi, раздел formatting strings (кроме булевского типа, где строка представлена в формате Значение1;Значение2). Если выбран текстовый тип (по умолчанию), то форматирование производиться не будет.

Указанные опции форматирования будут воздействовать на все переменные, содержащиеся  в объекте. Если переменная не может быть отформатирована указанным способом, она выводится как текст.

Если в объекте несколько переменных, для которых нужно разное форматирование, то можно применить другой способ форматирования. Суть его заключается в том, что к переменной дописывается тэг формата:

[Переменная формат], где формат - одно из следующих значений:

·		#x.x или #Nx.x или #Nyyyyy - числовое представление. x.x - длина числа/число разрядов после запятой; yyyyy - строка типа #,##0.00 (более подробную информацию можно получить в справочной системе Delphi, раздел formatting strings). Если строка x.x или yyyyy содержит символы ".", ",", "-", то последний такой символ будет использован в качестве разделителя целой и дробной части форматированного числа.
·		#Dxxxxx, #Txxxxx - дата и время. xxxxx - строка типа dd.mm.yy.
·		#Bxxxxx;yyyyy - булевское значение. Если значение - ложь, то выводится строка xxxxx, иначе yyyyy.

Вот примеры использования форматирования:

[Table1."N1" #9.2]   [Table1."N2" #N9-2]   [Table1."N3" #N#,##0.00] - для числа
[Table1."Date1" #Ddd.mm.yyyy]   [Table1."Time" #Thh:mm:ss] - для даты и времени
[Table1."Bool1" #BFalse;True]   [Table1."Bool2" #BНет;Да] - для булевского значения

Следует отметить, что тэги формата не работают в редакторе списка переменных.

В контекстном меню объекта можно задать следующие опции:
·		"растягиваемый" - высота объекта будет зависеть от количества строк в нем. При этом опция "растягиваемый" должна быть включена у бэнда, на котором находится объект. При печати бэнда вычисляется его высота, и все объекты с включенным растягиванием выводятся таким образом, что их нижняя граница растягивается до нижней границы бэнда.
·		"перенос слов" - если слово не помещается в строке, оно переносится на следующую строку.
·		"перенос по слогам" - при переносе слова делается разбивка его на слоги. При этом опция "перенос слов" должна быть включена.

This help file was created with HelpScribble.

.topic 1310

FastReport, как и все распространенные продукты, является бэнд-ориентированным построителем отчетов. Ниже приведен полный перечень бэндов и выполняемых ими функций.

Название				Функция

Report title 		 		печатается один раз в начале отчета
Report summary 		печатается один раз в конце отчета
Page header 		 		печатается вверху на каждой странице
Page footer 		 		печатается внизу на каждой странице
Master header 		 		печатается в начале списка 1-го уровня
Master data 		 		данные списка 1-го уровня
Master footer 		 		печатается в конце списка 1-го уровня
Detail header 		 		печатается в начале списка 2-го уровня
Detail data 		 		данные списка 2-го уровня
Detail footer 		 		печатается в конце списка 2-го уровня
Subdetail header 		печатается в начале списка 3-го уровня
Subdetail data 		 		данные списка 3-го уровня
Subdetail footer 		 		печатается в конце списка 3-го уровня
Overlay 		 				печатается на каждой странице нижним слоем
Column header 		 		печатается в начале каждой колонки
Column footer 		 		печатается в конце каждой колонки
Group header 		 		заголовок группы
Group footer 		 		печатается после группы

Cross header    				эта группа бэндов предназначена
Cross data        				для создания отчетов с переменным количеством
Cross footer				столбцов и разбивкой на страницы

В зависимости от типа бэнда вызываются разные редакторы. Редактор для дата-бэндов позволяет выбрать источник данных из списка доступных либо выбрать виртуальный источник данных. При выборе виртуального источника необходимо указать, из скольких записей он состоит. При формировании отчета бэнд с виртуальным источником будет напечатан столько раз, сколько записей было задано.

Редактор для бэнда GroupHeader позволяет ввести условие группировки. Остальные бэнды не имеют редакторов.

В зависимости от типа бэнда в контекстном меню доступны следующие опции:

·		"растягиваемый" - высота бэнда определяется максимальной высотой находящихся в нем объектов. У объектов также должна быть включена опция "растягиваемый";
·		"разрываемый" - если бэнд не помещается целиком на странице, будут выведены только поместившиеся строки текста, а вывод остальных будет продолжен с новой страницы;
·		"формировать новую страницу" - после печати бэнда формирование отчета продолжается с новой страницы. Если опция включена у дата-бэнда, то новая страница будет сформирована после вывода всех подбэндов;
·		"на первой странице" - если опция отключена, то бэнд не будет выведен на первой странице;
·		"на последней странице" - если опция отключена, то бэнд не будет выведен на последней странице;
·		"повторять на всех страницах" - эта опция доступна у бэндов Master header, Detail header, Subdetail header, Group header, VarColumn header. При включении дублирует бэнд на новой странице или колонке.

This help file was created with HelpScribble.

.topic 1320
Предназначен для вставки графического файла в формате BMP/WMF/ICO (и JPG, если установлен соответствующий модуль) в документ. Редактор объекта позволяет вставить рисунок и очистить содержимое объекта. Рисунок может быть вставлен из поля таблицы БД, если в мемо объекта поместить ссылку на соответствующее поле, например: [Table1."GraphicField"]. Редактор мемо может быть вызван с помощью инспектора объектов либо комбинацией клавиш Ctrl + Enter.

В контекстном меню объекта можно задать следующие опции:
·		"растягиваемый" - рисунок растягивается по границам объекта;
·		"сохранять пропорции" - если включено растягивание, пропорции рисунка сохраняются;
·		"центровка" - рисунок выводится в центре объекта.

This help file was created with HelpScribble.

.topic 1330

Вложенный отчет - это отчет с размещенным на нем объектом SubReport, который   представляет собой ссылку на другой отчет, расположенный на отдельной странице. При формировании такого отчета вместо объекта SubReport будет выведен соответствующий отчет. Объекты SubReport можно располагать на листе друг под другом или рядом. В случае, если объекты надо расположить друг под другом, их необходимо разнести по разным дата-бэндам (т.е. первый отчет - в первом бэнде Master data, второй  - во втором и т.д.). На использование SubReports накладываются следующие ограничения:
·		нельзя использовать колонки;
·		во  вложенных  отчетах  (не в основном!)  игнорируются бэнды ReportTitle, ReportSummary, PageHeader, PageFooter, ColumnXXX;
·		нельзя использовать разрываемые бэнды;
·		нельзя использовать группы.

This help file was created with HelpScribble.

.topic 1340

Представляет собой вертикальную либо горизонтальную линию с изменяемым цветом и толщиной. Дизайнер имеет удобные средства для рисования линий. В частности, с помощью линий можно быстро задать внешнее обрамление для таблицы, отличное от внутреннего.

This help file was created with HelpScribble.

.topic 1350

Представляет собой прямоугольник с крестиком внутри. Если в мемо объекта разместить ссылку на переменную либо на поле таблицы БД, то крестик будет показан при ненулевом значении переменной. В мемо можно также разместить символ "0" либо отличный от нуля.

Примечание. Для использования этого объекта в run-time следует использовать соответствующий компонент из палитры компонентов FR. Если открываемый отчет содержит неподключенные компоненты, то выдастся сообщение об ошибке.

This help file was created with HelpScribble.

.topic 1370

Предназначен для вставки OLE объектов в документ. Редактор объекта "OLE" позволяет вставить новый объект и редактировать существующий. Вставка нового объекта производится в стандартном диалоговом окне.

OLE объект может быть вставлен из поля таблицы БД, если в мемо объекта поместить ссылку на соответствующее поле, например: [Table1."OLEField"]. Редактор мемо может быть вызван с помощью инспектора объектов либо комбинацией клавиш Ctrl + Enter.

В контекстном меню объекта опция "растягиваемый" позволяет корректно отображать данные в некоторых случаях (например, при вставке объекта "Лист Excel").

Примечание. Для использования этого объекта в run-time следует использовать соответствующий компонент из палитры компонентов FR. Если открываемый отчет содержит неподключенные компоненты, то выдастся сообщение об ошибке.

This help file was created with HelpScribble.

.topic 1360

Предназначен для вставки текста в формате RTF (Rich Text format) в документ. В частности, таким образом можно вставить текст, подготовленный в текстовом процессоре MS Word, предварительно сохранив его в формате RTF. Редактор объекта взят из Delphiи позволяет выполнять все базовые операции над текстом - менять шрифт, выравнивание, создавать маркированные списки. В тексте могут находится переменные, обрамленные квадратными скобками - как и в объекте "Текст". Если текст не вмещается в рамки объекта, то лишние строки просто не выведутся.

RichText объект может быть вставлен из поля таблицы БД, если в мемо объекта поместить ссылку на соответствующее поле, например: [Table1."RichField"]. Редактор мемо может быть вызван с помощью инспектора объектов либо комбинацией клавиш Ctrl + Enter.

Примечание. Для использования этого объекта в run-time следует использовать соответствующий компонент из палитры компонентов FR. Если открываемый отчет содержит неподключенные компоненты, то выдастся сообщение об ошибке.

This help file was created with HelpScribble.

.topic 1380

Предназначен для вставки графика или диаграммы в документ. Возможно использование шести типов графиков: линии, точки, столбцы горизонтальные и вертикальные, области и круговые диаграммы. Редактор объекта позволяет задавать различные опции для графика, а также указывать объекты, содержимое которых будет использовано при построении графика.

Для построения графика необходимо указать имена двух объектов типа "Текст", в которых содержится название и соответствующее числовое значение. При построении отчета содержимое этих объектов будет накапливаться в мемо диаграммы.

Если объект содержит число в форматированном виде или комбинацию числа и строки (например, "$1000" или "10 000"), то FR попытается выделить числовую часть из строки. Алгоритм выделения - удаляются все нецифровые символы в начале и в конце строки, после этого удаляются все символы - разделители разрядов (как правило, пробелы). То есть если задано более сложное форматирование, например: "10000км2", то такие объекты использовать уже нельзя. В этом случае следует создать невидимый объект с аналогичным содержимым, но без всякого форматирования, и указывать его имя. Невидимым объект можно сделать с помощью инспектора объектов в дизайнере, установив параметр Visible в 0.

График может быть двух типов: одиночный и множественный (т.е. на одной координатной плоскости изображается несколько графиков). Если опция "Одиночная" включена, содержимое мемо имеет вид:

Заголовок1;Заголовок2;Заголовок3
Число1;Число2;Число3

В противном случае информация в мемо представлена в следующем виде:

Заголовок1;Заголовок2;Заголовок3
Число1.1;Число2.1										(первый график)
Число2.1;Число2.2;Число2.3								(второй график)
Число3.1;Число3.2;Число3.3;Число3.4;Число3.5		(третий график)

То есть в этом случае будут изображены три графика: две точки в первом, три точки во втором, пять точек в третьем.
График можно построить и вручную, если занести в мемо объекта соответствующие значения. Если количество строк заголовка не соответствует количеству значений, график выведен не будет.

Объект позволяет легко строить графики типа "Top10", т.е. график, в котором представлены только первые самые большие значения, а остальные значения просуммированы в отдельную группу с названием. Для этого на закладке "Данные" необходимо указать количество выводимых значений и подпись (обычно в качестве подписи используется слово "Другие").

Примечание. Для использования этого объекта в run-time следует использовать соответствующий компонент из палитры компонентов FR. Если открываемый отчет содержит неподключенные компоненты, то выдастся сообщение об ошибке.

This help file was created with HelpScribble.

.topic 1400

Предназначен для вставки штрихкодов в документ. Можно использовать следующие типы штрихкодов: 2 of 5 interleaved, Code39, Code39 Extended, Code128A,B, Code93, Code93 Extended, MSI, PostNet, Codebar, EAN8, EAN13.

Примечание. Для использования этого объекта в run-time следует использовать соответствующий компонент из палитры компонентов FR. Если открываемый отчет содержит неподключенные компоненты, то выдастся сообщение об ошибке.

This help file was created with HelpScribble.

.topic 1390

Предназначен для вставки геометрических фигур (прямоугольник, прямоугольник с закругленными углами, эллипс, треугольник) в документ. Выполняет исключительно декоративную роль.

Примечание. Для использования этого объекта в run-time следует использовать соответствующий компонент из палитры компонентов FR. Если открываемый отчет содержит неподключенные компоненты, то выдастся сообщение об ошибке.

This help file was created with HelpScribble.

.topic 1000
Дизайнер FastReport предоставляет пользователю удобные средства для разработки внешнего вида отчета и позволяет сразу выполнить предварительный просмотр. Интерфейс дизайнера выполнен на современном уровне с использованием панелей инструментов (toolbars), расположение которых можно изменять по своему вкусу. Информация о расположении панелей запоминается в реестре, и при следующем запуске восстанавливается. Также в реестре запоминаются остальные настройки дизайнера.

Дизайнер доступен из среды Delphi в design-time. Для использования дизайнера в скомпилированном проекте необходимо использовать компонент TfrDesigner из палитры компонентов FastReport, либо включить в список uses модуль FR_Desgn. Использование дизайнера в run-time дает возможность пользователю настраивать вид отчета, а также редактировать сформированный отчет.

This help file was created with HelpScribble.

.topic 1010
·		Стрелки - перемещение по объектам.
·		Ctrl + Стрелки - плавное перемещение выделенного объекта или группы объектов.
·		Shift + Стрелки - уменьшение/увеличение размеров объекта.
·		Alt + Стрелки - склеивание объекта с ближайшим в выбранном направлении.
·		Enter - вызов редактора объекта.
·		Del - удаление объекта.
·		Ctrl + Enter - вызов редактора мемо.
·		Ctrl + 1..9 - установка толщины рамки объекта.
·		Ctrl + Z - отменить последнее действие. Число уровней отката - до 100.
·		Ctrl + Y - повторить отмененное действие.
·		Ctrl + G - показать сетку.
·		Ctrl + B - выравнивать объекты по сетке. Любые операции мышью (перемещение, изменение размера объекта, вставка нового объекта и пр.) будут выполняться скачкообразно, если выравнивание включено.
·		Ctrl + F - обрамить выделенный объект.
·		Ctrl + D - снять обрамление с объекта.
·		Ctrl + X - вырезать выделенные объекты в буфер.
·		Ctrl + V - вставить объекты из буфера.
·		Ctrl + C - копировать выделенные объекты в буфер.
·		Ctrl + A - выделить все объекты на листе.
·		Ctrl + N - новый отчет.
·		Ctrl + O - открыть файл с отчетом.
·		Ctrl + S - сохранить отчет в файле.
·		Ctrl + P - предварительный просмотр отчета.

This help file was created with HelpScribble.

.topic 1020
·		Левая кнопка - выбор объекта; вставка нового объекта; перемещение и изменение размеров объекта или группы объектов.
·		Правая кнопка - контекстное меню объекта, над которым находится указатель мыши.
·		Двойной щелчок левой кнопкой - вызов редактора объекта. Если двойной щелчок сделать на пустом месте листа, то вызывается диалоговое окно "Параметры страницы".
·		Shift + левая кнопка - если объект уже выделен, то снимает с него выделение, иначе объект выделяется. Выделение остальных объектов не изменяется.
·		Ctrl + левая кнопка - при нажатии и перемещении мыши рисуется рамка; после отпускания кнопки мыши выделяются все объекты, попавшие в рамку. Такого же эффекта можно добиться, если щелкнуть левой кнопкой мыши на пустом месте листа, и, не отпуская кнопки, потянуть мышь до нужной позиции.
·		При перемещении бэнда его объекты перемещаются вместе с ним. Если это нежелательно, то перемещение следует выполнять при нажатой клавише Alt.
·		Изменить масштаб выделенных объектов можно, потянув мышкой за красный квадратик на нижнем правом углу группы выделенных объектов.
·		При приближении указателя мыши к границе двух соседних объектов вид указателя изменяется. Если при этом нажать левую кнопку и переместить указатель мыши, граница объектов также перемещается (горизонтальный сплиттинг).

This help file was created with HelpScribble.

.topic 1030
Чтобы установить опции дизайнера, воспользуйтесь командой меню "Сервис/Опции". Здесь можно задать используемые единицы измерения (пикселы, миллиметры, дюймы), указать шаг сетки в точках (шаг сетки 18 точек точно соответствует 5мм. Это особо полезно в случаях, когда надо сделать бланк, размеры которого кратны 5мм. Например, платежное поручение делается таким образом за 10 минут).

Также можно указать способ выделения выбранных объектов - контуром или инверсной заливкой.

Если опция "Цветные кнопки" отключена, то все кнопки становятся черно-белыми; при наведении указателя мыши на кнопку она показывается в цвете.

Наконец, опция "Редактирование после вставки" управляет процессом вставки новых объектов. Если опция включена, каждый раз при вставке объекта будет показываться его редактор. При вставке большого количества пустых объектов опцию лучше отключать.

This help file was created with HelpScribble.

.topic 1050
Опции документа можно установить, выбрав пункт меню "Файл/Опции документа".

В выпадающем списке можно выбрать тип принтера из числа установленных в системе. Если в системе нет ни одного принтера, то можно выбрать только "Принтер по умолчанию". Это виртуальный "принтер", который позволяет использовать бумагу любого размера - вплоть до формата А0. Разумеется, печатать на нем нельзя - он всего лишь нужен для обеспечения нормальной работы дизайнера и предварительного просмотра.

Если включена опция привязки принтера к документу, то при открытии документа автоматически будет выбран соответствующий принтер. Если же принтера с таким именем нет в системе, то будет использован принтер, выбранный в Windows по умолчанию.

Опцию "делать два прохода" необходимо включать в случае, если отчет содержит информацию вида "Страница 1 из 15", т.е. ссылку на общее число страниц в отчете.

This help file was created with HelpScribble.

.topic 1060
Диалоговое окно доступно через пункт меню "Файл/Опции страницы" либо с помощью двойного щелчка левой кнопки мыши на пустом месте страницы. Здесь можно выбрать формат листа из списка поддерживаемых текущим принтером, задать ориентацию. Если принтер поддерживает пользовательские размеры бумаги, то при выборе соответствующего значения из выпадающего списка станут доступны поля для ввода ширины и высоты листа. Следует отметить, что не все принтеры поддерживают произвольные пользовательские размеры (например, драйвер принтера HP LaserJet 6L не дает устанавливать размеры листа меньше чем 76 * 127мм; драйвер принтера HP LaserJet 4L не поддерживает пользовательский формат вообще).

На второй закладке диалога можно задать размеры отступа от краев листа, а также задать опцию "Использовать поля печати". На этом моменте следует остановиться более подробно.

Возможны два варианта страницы в дизайнере: с полями печати и без них. Если поля печати включены (по умолчанию), то они отображаются в дизайнере и все, что находится вне полей, на печать не выводится. Это позволяет добиться максимального соответствия между видом страницы в дизайнере и на бумаге. К примеру, тестовые страницы, напечатанные на струйном, матричном и лазерном принтерах, между собой не отличались.

Но при переходе на другой принтер из-за изменившихся границ печати некоторые объекты могут вылезти за пределы полей и не будут напечатаны. Если отключить поля печати, то предполагается, что страница в дизайнере соответствует области печати, т.е. все, что находится на странице, будет корректно напечатано на любом принтере. Правда, при этом вид страницы в дизайнере будет немного отличаться от распечатанного документа.

Если поля страницы нулевые, то при построении отчета будут использована информация о полях, предоставляемая драйвером принтера. Если же хоть одно из полей ненулевое, то новые поля будут отображены в дизайнере и использованы при построении отчета. Если вы используете матричный принтер, будьте внимательны. Дело в том, что во многих матричных принтерах одно или несколько полей имеет нулевой размер, в связи с чем при формировании отчета и при его распечатке может возникнуть ситуация, когда текст выходит за границы листа. Чтобы избежать этого, явно задавайте поля станицы.

На третьей закладке можно установить некоторые опции для страницы, а также указать количество колонок для печати многоколоночных отчетов. Флажок "Печатать на предыдущем листе" позволяет начать печать страницы начиная со свободного места на предыдущем листе.

This help file was created with HelpScribble.

.topic 1040
Что такое список переменных и для чего он нужен? Предположим, имеется база сотрудников, в которой есть поля N, Name1, Name2, Name3. Вспоминать, что скрывается за такими названиями полей, иногда тяжело даже разработчику базы. Поэтому можно сопоставить полям БД нормально названные переменные (Таб.номер, Фамилия, Имя, Отчество), и в объекты вставлять их (в частности, для вставки переменной в объект "Текст" в редакторе мемо есть соответствующая кнопка).

Кроме того, переменной можно сопоставить не только поле из базы, но и математическое выражение, например, сумму значений полей БД, округленное значение, дату, время и пр.

Для работы со списком переменных нужно выбрать в дизайнере пункт "Список переменных" из меню "Файл". Если отчет создается с нуля, то список переменных будет пуст, и для его заполнения нужно нажать кнопку "Переменные" в нижней части окна. После этого в появившемся окне надо ввести список переменных, который имеет следующую структуру:

КАТЕГОРИЯ1
  Переменная1
  Переменная2
^ пробел обязателен!
КАТЕГОРИЯ2
  Переменная1
  Переменная2
  ....................

Обязательно наличие хотя бы одной категории. Имена переменных пишутся после пробела.

После заполнения списка надо сопоставить каждой переменной значение в основном окне. Для этого нужно выбрать переменную в списке слева и выбрать соответствующее значение в списке справа, пользуясь мышью. В списке справа показаны все источники данных (т.е. невизуальные dbaware-компоненты, наследники от TDataSet), которые доступны в данный момент, и имена их полей. В design-time будут доступны все датасеты, находящиеся в открытых модулях (units). В run-time будут доступны все датасеты, находящиеся в созданных формах или модулях данных (TDataModule).

Кроме того, если выбрать из выпадающего списка справа значение "Прочие переменные", то появится возможность сопоставить переменной одно из следующих значений:
·		страница - номер текущей страницы;
·		выражение - при выборе этого значения становится активной строка выражения внизу окна, куда можно ввести любое допустимое выражение (выражение не должно содержать тэги форматирования!);
·		дата - дата начала формирования отчета;
·		время - время начала формирования отчета;
·		№ строки;
·		№ строки сквозной;
·		№ колонки;
·		всего страниц - всего страниц в сформированном документе, соответствует TotalPages. Для использования этого значения отчет должен быть двухпроходным (задается в опциях отчета).

This help file was created with HelpScribble.

.topic 1070
Инспектор позволяет манипулировать некоторыми свойствами объектов, а именно: задавать имя объекта, его позицию и размеры, а также видимость. Окно инспектора похоже на Object Inspector в Delphi и функционирует аналогичным образом. Так же, как и остальные панели инструментов, его можно показать или скрыть соответствующей командой меню "Сервис/Панели инструментов". Двойной щелчок на заголовке окна инспектора сворачивает окно в полоску, еще один двойной щелчок - восстанавливает исходные размеры.

Если в строке инспектора набрать вместо числа выражение (например, 55 * 3,5) и нажать Enter, то подставится полученное значение.

This help file was created with HelpScribble.

.topic 1080
Для того, чтобы отобразить объект другим шрифтом или цветом в зависимости от какого-либо условия, можно воспользоваться диалогом "Атрибуты выделения". Диалог можно вызвать с помощью кнопки на панели управления рядом с кнопкой цвета шрифта. К примеру, нужно выделить суммы заказов, превышающие 1000$, жирным шрифтом. Для этого в объекте, содержащем сумму заказа, в диалоге указывается условие - Value > 1000 и задаются параметры шрифта. Условие выделения можно указать и по-другому - [Part total] > 1000.

Другой пример использования выделения - для придания отчету презентабельного вида можно сделать чередующуюся раскраску строк данных. Для этого на бэнд надо положить объект "Текст", растянуть его по ширине бэнда, в диалоге выделения набрать условие [LINE#] mod 2 = 0 и указать цвет фона (к примеру, серый).

This help file was created with HelpScribble.

.topic 1500
Это самый простой вид отчета. Перед тем, как разрабатывать внешний вид отчета, поместите на форму компоненты TfrReport, TfrDBDataSet, TDataSource, TTable. Настройте свойства компонент:

TfrDBDataSet.DataSource = TDataSource
TDataSource.DataSet = TTable

После этого запустите дизайнер отчетов двойным щелчком мыши на компоненте TfrReport. Далее необходимо разместить на листе бэнд Master data и поместить в него объекты со ссылками на нужные данные. Бэнд Master data необходимо связать с источником данных - компонентом TfrDBDataSet или TfrUserDataSet. Это делается в редакторе бэнда, который можно вызвать двойным щелчком мыши на бэнде.

Можно сразу построить отчет, нажав кнопку предварительного просмотра на панели инструментов или выбрав соответствующую команду из меню дизайнера.

Примечание 1. Бэнд, в котором нет ни одного объекта, при формировании отчета не обрабатывается.

Примечание 2. Если бэнду не назначен источник данных, то используется источник данных из свойства DataSet компонента TfrReport (если свойство ReportType при этом установлено в rtSimple).

This help file was created with HelpScribble.

.topic 1510
Для построения этого отчета необходимо разместить на листе бэнды Master data и Detail data, затем поместить в них объекты со ссылками на нужные данные. Порядок, в котором бэнды размещаются на листе, не имеет значения - сначала будет напечатана строка из master, потом соответствующие ей строки из detail. Отчет будет формироваться до тех пор, пока есть данные для master. Если надо, чтобы master с его подчиненным списком печатался с нового листа, установите для бэнда флажок "Формировать новую страницу".

У отчета есть особенность - если для текущей строки из master список detail пуст, строка master печататься не будет. Если все же необходимо распечатать такие строки, для бэнда Master data нужно установить флажок "Печатать, если detail пуст".

This help file was created with HelpScribble.

.topic 1520
Для построения отчета разместите на листе бэнды Master data, Detail data и Subdetail data. В остальном принципы построения такие же, как и для отчета Master-Detail.

This help file was created with HelpScribble.

.topic 1530
Этот вид отчета предназначен для печати таблицы, число столбцов которой на этапе построения отчета неизвестно. При формировании отчета столбцы, не поместившиеся на странице, будут перенесены на следующую (как это делает всем знакомый MS Excel).

Для построения этого отчета разместите на странице бэнд Master data и бэнд Cross data. Бэнды CrossXXX размещаются на странице вертикально. На пересечении бэндов разместите объект, который будет отображаться в качестве ячейки таблицы. Необходимо разместить объект таким образом, чтобы он полностью помещался в границы области пересечения бэндов. Это все, что нужно для построения базового отчета.

Бэнд Cross footer печатается последним столбцом (например, если нужно отпечатать сумму по строке), а Cross header - первым. Кроме того, если в опциях бэнда включен флажок "Выводить на всех страницах", то при переносе широкой таблицы на смежный лист Cross header будет продублирован.

This help file was created with HelpScribble.

.topic 1540
Очень часто приходится печатать отчеты, в которых высота строки данных может изменятся в зависимости от содержимого объектов, находящихся на бэнде (например, счет-фактура - название товара/услуги может быть длинным, на несколько строк текста). FR может печатать бэнды переменной высоты, если у них включена опция "Растягиваемый". Эту опцию также необходимо включить для объектов бэнда, высота которых может меняться. Если окажется, что максимальная высота бэнда меньше первоначальной, то он будет напечатан в первоначальном размере.

Если печатается обрамленная таблица, то опцию надо включить для всех ячеек (чтобы они имели одинаковую высоту, не нарушая обрамления). Объекты со включенной опцией растягиваются таким образом, что их нижний край совпадает с нижним краем бэнда.

This help file was created with HelpScribble.

.topic 1550
FR не позволяет размещать на листе два одинаковых бэнда. Исключение составляют data-бэнды и их headers & footers - их можно размещать много (до 32). При печати одинаковые бэнды выводятся друг за другом. Это позволяет формировать отчеты, в которых строка данных состоит из нескольких бэндов, каждый - переменной высоты.

Таким образом можно сделать и Header/Footer для каждой записи. Если все бэнды одной строки данных не помещаются на странице, печать начинается со следующей.

Описанное справедливо для случая, если верхний бэнд имеет источник данных, а остальные - нет. Если же остальным бэндам назначены другие источники данных, то распечатаются сначала все строки из верхнего бэнда, затем из следующего и т.п. - в данном случае получится отчет типа Master-Detail-Detail.

This help file was created with HelpScribble.

.topic 1560
Если в обычном отчете при достижении конца страницы формирование продолжается с нового листа, то в многоколоночном - на том же листе, но рядом, т.е. в несколько смежнорасположенных колонок. Обычный отчет можно превратить в многоколоночный, всего лишь задав количество колонок в опциях страницы. Бэнды Column header и Column footer позволяют снабдить каждую колонку заголовком и нижней частью.

This help file was created with HelpScribble.

.topic 1570
FR позволяет легко делать многостраничные отчеты (например, первая страница - титульный лист, все остальное - прочая информация). Для того, чтобы создать/удалить лист, используйте кнопки на панели инструментов. Если необходимо сформировать несколько таких отчетов (например, для каждой записи таблицы), у компонента TfrReport необходимо установить свойство ReportType = rtMultiple, и в свойстве Dataset указать необходимый источник данных (TfrxxxDataset).

This help file was created with HelpScribble.

.topic 1580
Вложенный отчет - это отчет с размещенным на нем объектом SubReport, который представляет собой ссылку на другой отчет, расположенный на отдельной странице. При формировании такого отчета вместо объекта SubReport будет выведен соответствующий отчет. Объекты SubReport можно располагать на листе друг под другом или рядом. В случае, если объекты надо расположить друг под другом, их необходимо разнести по разным дата-бэндам (т.е. первый отчет - в первом бэнде Master data, второй - во втором и т.д.).

На использование SubReports накладываются следующие ограничения:
·		нельзя использовать колонки;
·		во вложенных отчетах (не в основном!) игнорируются бэнды ReportTitle, ReportSummary, PageHeader, PageFooter, ColumnXXX;
·		нельзя использовать разрываемые бэнды;
·		нельзя использовать группы.

This help file was created with HelpScribble.

.topic 1590
Для построения этого отчета разместите на листе бэнд Master data и два бэнда Detail data. Для бэндов Detail data назначьте соответствующие источники данных. Если назначить источник данных только для верхнего бэнда, то получится отчет с несколькими строками данных.

Разумеется, таким образом можно строить и отчеты типа Master-Master, Master-Detail-SubDetail-SubDetail. Количество одинаковых дата-бэндов может быть до 32.

This help file was created with HelpScribble.

.topic 1600
Композитный отчет позволяет получить отчет, состоящий из нескольких других. Для этого разместите на форме компонент TfrCompositeReport, и программным путем заполните его свойство Reports ссылками на отчеты, которые нужно объединить в один. Отчеты будут формироваться по порядку, причем если страница отчета имеет включенную опцию "Печать на предыдущем листе", то она будет напечатана начиная со свободного места на последнем листе предыдущего отчета.

This help file was created with HelpScribble.

.topic 1610
В обычном отчете, если содержимое бэнда не помещается на оставшемся месте листа, то оно выводится на следующей странице (или колонке, если отчет многоколоночный). Если нужно, чтобы на оставшемся месте было напечатано столько строк, сколько вмещается, а печать остальных продолжилась со следующего листа (или колонки),  у data-бэнда нужно включить опцию "Разрываемый". Если строка данных состоит из нескольких data-бэндов, то эту опцию нужно включать только у первого бэнда. Разрываться могут не только data-бэнды, но и все остальные, за исключением бэндов CrossXXX.

This help file was created with HelpScribble.

.topic 1620
Часто бывает необходимо отобразить данные только из одной записи БД, разместив их на бланке. Пример - платежное поручение. В этом случае отчет может вообще не содержать бэндов. Объекты, расположенные непосредственно на листе, при печати выведутся на своих местах.

This help file was created with HelpScribble.

.topic 1630
Группы применяются для группировки строк данных с использованием некоторого критерия. В качестве критерия обычно выступает выражение, основанное на полях из набора данных. При формировании отчета FR следит за значением критерия, и, как только оно изменится, формирует новую группу.

Для построения отчета разместите на листе бэнды Group footer и Master data. Назначьте источник данных для Master data, затем в редакторе бэнда Group footer укажите условие группировки. Например, чтобы распечатать список сотрудников в группированном виде (группировка по первой букве фамилии), надо указать примерно такое условие группировки: Copy([Фамилия], 1, 1). При изменении этого условия будет сформирована новая группа.

На использование групп накладываются следующие ограничения:
·		нельзя применять группы во вложенных отчетах;
·		группа может выступать только в роли списка 1-го уровня, т.е. сначала идет группа, затем - master, detail и т.п.

Исходный отчет						Сформированный отчет

Примечание. Для правильной работы групп исходный набор данных должен быть уже отсортирован по условию группировки. Сортировку можно осуществить, применяя запрос (Query) с выражением ORDER BY.

This help file was created with HelpScribble.#

.topic 1810
В состав FastReport входит интерпретатор Pascal-подобного языка. Данный интерпретатор является мощным средством, позволяющим в независимости от используемого языка программирования (Delphi или C++Builder) писать скрипты, выполняющиеся при построении отчетов.
В качестве языка используется диалект Pascal, со следующими возможностями:
·		операторы: присваивания; условные операторы, операторы циклов и безусловного перехода: if...then...else, while...do, repeat...until, for..to..do, goto;
·		операторные скобки begin...end;
·		бестиповые переменные, массивы;
·		обращение к свойствам и методам объектов FastReport через точечную нотацию.

        Язык по сравнению с Object Pascal сильно упрощен. Так, используются следующие упрощения:
·		все переменные имеют тип Variant; отсутсвует описание переменных;
·		все переменные являются глобальными, нет локальных переменных;
·		отсутствуют такие типы данных, как "класс", "запись", перечисляемый тип и т.п.;
·		нет возможности написания собственных процедур или функций;
·		нет операторов прерывания цикла (break, continue);
·		количество параметров, передаваемых в процедуру или функцию, может быть не более 3;
·		в связи с тем, что переменные не имеют типа, контроль типов данных невозможен - это следует учитывать при написании логических выражений;
·		массивы могут быть только одномерными.

        Несмотря на значительные упрощения, интерпретатор позволяет выполнять довольно сложную обработку информации. Из скрипта доступны все свойства и методы объектов отчета, а также поля таблиц БД. В скрипте можно создавать переменные и массивы, которые будут доступны во всем отчете. О возможностях встроенного языка говорит тот факт, что такая довольно сложная задача, как печать сумм группы в ее заголовке (сама сумма считается в подвале группы) средствами языка FastReport делается элементарно.

Скрипты и объекты
В каждом объекте может быть размещен один или несколько (блок) операторов. Редактирование скрипта производится в окне редактора текста (для того, чтобы увидеть скрипт, надо нажать кнопку  в верхней части окна). Скрипт выполняется каждый раз перед печатью объекта. По сути, скрипт является обработчиком события OnBeforePrint объекта.

Скрипт имеется не только у объектов. И бэнды, и страницы отчета также имеют свой скрипт. Вызвать скрипт бэнда можно, вызвав редактор свойства OnBeforePrint бэнда (из инспектора объектов, либо выделив бэнд и нажав Ctrl+Enter). Вызвать скрипт страницы отчета можно, вызвав редактор свойства OnBeforePrint страницы (для этого надо щелкнуть на пустом месте страницы и вызвать редактор из инспектора объектов). Диалоговая форма, как и страница отчета, имеет скрипт - свойство OnActivate. Скрипт остальных объектов может быть вызван через их свойство Memo либо при нажатии Ctrl+Enter.

Написание кода
В скрипте можно использовать свойства и методы объектов отчета, поля таблиц БД, различные константы. Также можно создавать переменные и массивы, которые будут доступны во всем отчете. Кроме того, можно использовать процедуры и функции.

Использование переменных
Переменную описывать не надо, она имеет тип Variant. В имени переменной можно использовать латинские буквы, цифры и знак подчеркивания. Переменную из скрипта можно использовать в объектах, и наоборот, переменную из списка переменных можно использовать в скрипте. Скриптовые переменные хранятся в объекте TfrVariables, к которому есть доступ через глобальную переменную frVariables.
Пример использования промежуточной переменной:

begin
  Cust := [CustomerData.RepQuery."CustNo"];
  if FinalPass then
    TotalSales := Arr[Cust] else
    TotalSales := 0;
end;

        В этом примере создается переменная Cust, которой присваивается значение поля таблицы БД.

        Кроме этого, можно обращаться к переменным, определенным в словаре данных, к системным переменным, а также пользовательским переменным. При этом переменные могут содержать в имени недопустимые с точки зрения синтаксиса символы (например, системная переменная Page#). Обращаться к таким переменным следует с использованием квадратных скобок:

begin
  a := [Page#];
end

Обращение к полям БД
        В скрипте могут быть использованы ссылки на поле из таблицы БД. Обращение к полям выполняется в следующем виде:
[Имя формы.Имя таблицы."Имя поля"]
Полная форма обращения применяется в случае, если компонент-таблица и компонент-отчет расположены на разных формах (или модулях данных). Если компоненты расположены на одной форме, обращение может быть вида [Имя таблицы."Имя поля"].
Форма обращения ["Имя поля"] использует для поиска поля таблицу, которая является основной для бэнда, в котором такое обращение произошло. Например, имея бэнд master data, к которому через источник данных подключена таблица Customer.db, мы можем в пределах всего отчета обращаться к полям таблицы с использованием краткой формы. Использование полной формы обращения не приводит к замедлению работы - в ядре FastReport имеется кэш, который хранит обращения к полям БД.

Массивы
        В скрипте, помимо переменных, можно создавать массивы. Массивы могут быть только одномерными, но можно организовать доступ к элементам массива таким образом, что можно трактовать массив как двумерный или с болшим количеством измерений.

Пример использования массива:

begin
  MyArr[0] := 'a'; MyArr[1] := 'b'; MyArr[3] := 'd';
  MyArr[2] := MyArr[0] + MyArr[1] + 'c' + MyArr[3];
end;

Фактически значения элементов массива хранятся в списке frVariables в виде
Arr_имя массива_индекс. Т.е. в вышеприведенном примере мы получим содержимое frVariables:

Arr_MyArr_0 := 'a'
Arr_MyArr_1 := 'b'
Arr_MyArr_2 := 'abcd'
Arr_MyArr_3 := 'd'

Константы
        В скрипте можно использовать константы. Простейший пример - использование числовых, строковых и логических констант:

begin
  a := 0;
  b := 'abcd';
  c := True;
  d := 'That''s all!';
end;

Обратите внимание на использование одинарной кавычки внутри строковой константы - как и в Pascal, ее надо дублировать: d := 'That''s all!'.
        Кроме простых констант, в скрипте доступны константы - названия цветов, стилей шрифта и пр. Вот список констант, которые можно использовать:

·		цвета: clWhite, clBlack и т.п. - все стандартные цвета + системные цвета;
·		результат работы диалогового окна: mrNone, mrOk, mrCancel;
·		служебные: CRLF, Null;
·		стиль шрифта: fsBold, fsItalic, fsUnderline;
·		рамка объекта: frftNone, frftRight, frftBottom, frftLeft, frftTop;
·		выравнивание текста в объекте "Текст": frtaLeft, frtaRight, frtaCenter, frtaVertical, frtaMiddle, frtaDown;
·		выравнивание по бэнду: baNone, baLeft, baRight, baCenter, baWidth, baBottom.

        Кроме того, определены константы для подключаемых объектов, например, csCheck для объекта "CheckBoxObject". Все, что можно видеть в выпадающих списках свойств в инспекторе объектов, можно использовать как константу в скрипте.

Обращение к объектам
        В скрипте можно обращаться к свойствам и методам объектов отчета. К объектам отчета относятся визуальные объекты, элементы управления, бэнды, страницы отчета, сам отчет. Для обращения к объекту применятся точечная нотация, например: Memo1.Text. Для обращения к собственным свойствам или методам точечная нотация необязательна.
        Свойства, к которым возможно обращение, отображены в инспекторе объектов. К некоторым комплексным свойствам (например, Font) возможно обращение как к Font.Name, Font.Size и т.п.:

begin
  Memo1.Font.Name := 'Courier New';
  Memo1.Font.Size := 10;
  Memo1.Font.Color := clRed;
  Memo1.Font.Style := fsBold + fsItalic
end;

К свойствам типа TStrings (Memo, SQL, Items и пр.) возможен доступ по индексу:

if Memo1.Lines[1] = 'a' then
  Memo1.Lines[1] := 'b'

Также к таким свойствам могут применяться операции Add, Delete, Clear и Count:

if Memo1.Lines.Count > 10 then
  Memo1.Lines.Delete(10)
else
begin
  Memo1.Lines.Clear;
  Memo1.Lines.Add('a');
end;

Полный список свойств и методов объектов см. в разделе "Свойства и методы объектов". Следует отметить, что обращение к несуществующему методу или свойству не приведет к сообщению об ошибке. Поэтому следует быть осторожным при написании кода.

Использование процедур и функций
        В скрипте могут содержаться вызовы процедур и функций. Особенность интерпретатора, а точнее, парсера, который отвечает за обработку процедур/функций, состоит в том, что процедура или функция может иметь не более трех параметров. В скрипте могут использоваться как встроенные процедуры, так и внешние, определенные в проекте. Список встроенных процедур и функций см. в разделе "Описание встроенных процедур и функций".
        Примечание. При обращении к процедуре или функции нельзя ставить пробел между именем процедуры и открывающей скобкой.

Модификация объектов
В скрипте можно выполнить любые модификации объекта (либо других объектов) - например, изменение размеров, цвета, содержимого и пр. Следует учесть, что объекты, которые уже обработаны, модифицированы быть не могут. То есть, попытка из объекта, лежащего на бэнде report summary, изменить содержимое объекта из report title, ни к чему не приведет. Однако, сделав отчет двухпроходным, мы сможем выполнить такую модификацию.
Аналогичным образом обстоят дела в случае многостраничного отчета. Мы можем обращаться к любому объекту по его имени (имя в пределах отчета уникально). Но модифицированы могут быть только объекты, которые еще не обрабатывались. Если все же требуется модификация уже обработанного объекта, следует сделать отчет двухпроходным.

This help file was created with HelpScribble.

.topic 1800
Могут применяться в бэндах ReportSummary, PageFooter, MasterFooter, DetailFooter, SubdetailFooter, GroupFooter, CrossFooter.
·		Sum(<expression> [,band] [,1]). Вычисляет сумму выражения expression для ряда строк данных. Если параметр band не задан, то сумма считается по строке данных, соответствующей данному бэнду (по бэндам MasterData, DetailData, SubdetailData); иначе сумма считается только по бэнду с именем band. Если в расчет надо включить невидимые бэнды, надо указывать третий параметр (1). Пример использования:
        Sum([Part total], Band1);
        Sum([[Part total] + [Part price]]);
        Sum([Part total], Band1, 1).
·		Avg, Min, Max. Синтаксис аналогичен функции Sum. Функция Avg вычисляет среднее арифметическое, функция Min возвращает минимальное, функция Max - максимальное значение из ряда.
·		Count(<band>). Возвращает количество строк данных. Пример использования:
Count(Band1).

Функции работы со строками
·		Str(<value>). Преобразует число в строку.
·		Copy(<string>, <from>, <count>). Возвращает подстроку (аналогично одноименной функции в Delphi).
·		If(<expression>, <string1>, <string2>). Возвращает строку string1, если выражение expression истинно; иначе возвращает строку string2.
·		FormatFloat(<formatstr>, <value>). Преобразует числовое значение value в строку, используя форматирование formatstr. Возможные значения formatstr описаны в документации к Delphi, раздел "Formatting strings".
·		FormatDateTime(<formatstr>, <value>). Преобразует дату/время value в строку, используя форматирование formatstr. Возможные значения formatstr описаны в документации к Delphi, раздел "Formatting strings".
·		StrToDate(<value>). Преобразует строку в дату.
·		StrToTime(<value>). Преобразует строку во время.
·		UpperCase(<value>). Преобразует символы строки в верхний регистр.
·		LowerCase(<value>). Преобразует символы строки в нижний регистр.
·		NameCase(<value>). Преобразует символы строки в нижний регистр, а первый символ - в верхний.
·		Length(<string>). Возвращает длину строки.
·		Trim(<string>). Отбрасывает пробелы в начале и в конце строки и возвращает результат.
·		Pos(<substring>, <string>). Возвращает позицию подстроки <substring> в строке <string>.

Арифметические функции
·		Int(<value>). Возвращает целую часть числа value.
·		Frac(<value>). Возвращает дробную часть числа.
·		Round(<value>). Возвращает округленное значение.
·		value1 Mod value2. Возвращает остаток от деления value1 на value2.
·		MinNum(<value1>, <value2>). Возвращает меньшее из двух чисел.
·		MaxNum(<value1>, <value2>). Возвращает большее из двух чисел.

Прочие функции
·		Input(<caption> [,<default>]). Выводит на экран диалоговое окно с заголовком caption и строкой ввода. Если задан параметр default, то это значение появится в строке ввода. После ввода пользователя возвращает введенную строку.
·		Date. Возвращает дату начала формирования отчета.
·		Time. Возвращает время начала формирования отчета.
·		Line#. Возвращает номер строки данных; нумерация начинается с начала группы. Например:
        Master data
1. Detail data
2. Detail data
3. Detail data
        Master data
1. Detail data
2. Detail data
·		LineThrough#. Возвращает номер строки данных; нумерация строк начинается с начала отчета, например:
        Master data
1. Detail data
2. Detail data
3. Detail data
        Master data
4. Detail data
5. Detail data
·		Column#. Возвращает номер колонки в cross-tab отчете.
·		Page#. Возвращает номер текущей страницы.
·		TotalPages. Возвращает общее количество страниц в сформированном отчете. Для использования этой функции отчет должен быть двухпроходным.
·		DayOf(<date>). Возвращает день даты.
·		MonthOf(<date>). Возвращает месяц даты.
·		YearOf(<date>). Возвращает год даты.
·		MessageBox(<text>, <caption>, <buttons_and_icons>). Выводит стандартное окно диалога с текстом <text> и заголовком <caption>. Набор кнопок и иконка окна задается в параметре <buttons_and_icons>. Возвращает значение, соответствующее нажатой кнопке (mrOk, mrCancel, mrYes, mrNo). В качестве <buttons_and_icons> можно использовать значения:

        Кнопки						Иконка
        mb_Ok  				mb_IconError
        mb_OkCancel  				mb_IconQuestion
        mb_YesNo  				mb_IconInformation
        mb_YesNoCancel  		mb_IconWarning

Процедуры и функции для манипуляции построением отчета
·		CurY. Возвращает текущую позицию по Y (в пикселах), с которой будет выведен очередной бэнд. Этому свойству можно также присвоить нужное значение для смены позиции. Это позволяет строить довольно экзотические отчеты.
·		FreeSpace. Возвращает высоту оставшегося свободного места на странице в пикселах.
·		FinalPass. Возвращает истину, если отчет двухпроходный и выполняется последний проход.
·		PageHeight. Возвращает высоту страницы в пикселах с учетом высоты бэнда Page footer.
·		PageWidth. Возвращает ширину страницы в пикселах.
·		StopReport. Останавлявает построение отчета.
·		NewPage. Начинает формирование отчета с новой страницы.
·		NewColumn. Начинает формирование отчета с новой колонки, если отчет многоколоночный.
·		ShowBand(<band>). Показывает бэнд <band>.

This help file was created with HelpScribble.

.topic 11
Список полей, доступных в текущем наборе данных. Если список пуст, то будут доступны все поля набора данных.

This help file was created with HelpScribble.

.topic 20
Редактор скрипта. Чтобы показать или скрыть это окно, воспользуйтесь переключателем "Скрипт".

This help file was created with HelpScribble.

.topic 21
Список категорий форматирования. Переменная может отображаться как текст, число, дата, время, булевское значение.

This help file was created with HelpScribble.

.topic 22
Список переменных в выбранной категории. Чтобы вставить переменную в текст, щелкните на ней мышкой.

This help file was created with HelpScribble.

.topic 10
Список доступных таблиц БД.

This help file was created with HelpScribble.

.topic 23
Список доступных полей в выбранной таблице БД.

This help file was created with HelpScribble.

.topic 24
Показывает диалог выбора полей для добавления к списку доступных полей.

This help file was created with HelpScribble.

.topic 31
Список способов форматирования для выбранной категории. Если в списке выбран формат "Другой", то становится доступна строка ввода пользовательского формата.

This help file was created with HelpScribble.

.topic 32
Список категорий переменных.

This help file was created with HelpScribble.

.topic 33
Показывает диалог, в котором можно создать новое lookup поле на основе поля из другого набора данных.

This help file was created with HelpScribble.

.topic 40
Запоминает все изменения и закрывает окно.

This help file was created with HelpScribble.

.topic 41
Символ-разделитель целой и дробной части числа.

This help file was created with HelpScribble.

.topic 42
Выделяет все поля в списке.

This help file was created with HelpScribble.

.topic 50
Отменяет все изменения и закрывает окно.

This help file was created with HelpScribble.

.topic 51
Количество знаков в дробной части числа.

This help file was created with HelpScribble.

.topic 52
Показывает диалог вставки OLE объекта.

This help file was created with HelpScribble.

.topic 53
Удаляет выделенные поля из списка.

This help file was created with HelpScribble.

.topic 54
Список созданных наборов данных. Двойной щелчок мышью на нужной иконке показывает редактор набора данных.

This help file was created with HelpScribble.

.topic 55
Список параметров, имеющихся в тексте запроса.

This help file was created with HelpScribble.

.topic 60
Позволяет быстро вставить переменную в редактируемый текст. Для быстрого вызова можно воспользоваться клавишей Insert.

This help file was created with HelpScribble.

.topic 61
Строка форматирования. Становится доступной, если в списке выбран формат "Другой". Строки форматирования для каждого из типов описаны в справочной системе Delphi, раздел formatting strings (кроме булевского типа, где строка представлена в формате Значение1;Значение2).

This help file was created with HelpScribble.

.topic 62
Возможны два варианта страницы в дизайнере: с полями печати и без них. Если поля печати включены, то они отображаются в дизайнере и все, что находится вне полей, на печать не выводится. Если отключить поля печати, то предполагается, что страница в дизайнере соответствует области печати, т.е. все, что находится на странице, будет корректно напечатано на любом принтере. Правда, при этом вид страницы в дизайнере будет немного отличаться от распечатанного документа.

This help file was created with HelpScribble.

.topic 63
Загружает рисунок из графического файла.

This help file was created with HelpScribble.

.topic 64
Вызывает диалог открытия файла с картинкой.

This help file was created with HelpScribble.

.topic 65
Список доступных шаблонов.

This help file was created with HelpScribble.

.topic 66
Показывает на листе точечную сетку для более удобного размещения объектов.

This help file was created with HelpScribble.

.topic 67
Задает утолщение для шрифта выделения.

This help file was created with HelpScribble.

.topic 68
Список принтеров, установленных в системе. Если в системе нет установленных принтеров, то в списке можно выбрать только принтер по умолчанию - это позволит работать с дизайнером и делать предварительный просмотр.

This help file was created with HelpScribble.

.topic 69
Список категорий переменных.

This help file was created with HelpScribble.

.topic 70
Позволяет быстро вставить ссылку на поле таблицы БД в редактируемый текст.

This help file was created with HelpScribble.

.topic 71
Очищает рисунок.

This help file was created with HelpScribble.

.topic 72
Левое поле страницы.

This help file was created with HelpScribble.

.topic 73
Поле для ввода краткого описания шаблона.

This help file was created with HelpScribble.

.topic 74
Описание выбранного шаблона.

This help file was created with HelpScribble.

.topic 75
При перемещении объекта мышью или при изменении его размеров положение и размеры объекта меняются скачкообразно, в соответствии с шагом сетки. Это позволяет более ровно размещать объекты на листе.

This help file was created with HelpScribble.

.topic 76
Задает наклон для шрифта выделения.

This help file was created with HelpScribble.

.topic 77
Если опция включена, то при открытии отчета выбирается указанный принтер.

This help file was created with HelpScribble.

.topic 78
Список переменных. Для того, чтобы назначить переменной значение, выберите из выпадающего списка в правой части окна нужную таблицу БД, затем щелкните мышкой на нужном поле из списка полей.

This help file was created with HelpScribble.

.topic 79
Список переменных, который имеет следующую структуру:

КАТЕГОРИЯ 1
  Переменная1
  Переменная2
^ пробел обязателен!
КАТЕГОРИЯ 2
  Переменная1
  Переменная2
  ....................
Обязательно наличие хотя бы одной категории. Имена переменных пишутся после пробела.

This help file was created with HelpScribble.

.topic 80
Показывает или скрывает редактор скрипта.

This help file was created with HelpScribble.

.topic 81
Верхнее поле страницы.

This help file was created with HelpScribble.

.topic 82
Растянуть рисунок по размерам окна.

This help file was created with HelpScribble.

.topic 83
Выбранная картинка.

This help file was created with HelpScribble.

.topic 84
При перемещении или изменении размеров объект выделяется контуром.

This help file was created with HelpScribble.

.topic 85
Задает подчеркивание для шрифта выделения.

This help file was created with HelpScribble.

.topic 86
Опцию необходимо включать в случае, если для формирования отчета требуется выполнить два прохода. Это может понадобиться, если отчет содержит информацию об общем количестве страниц.

This help file was created with HelpScribble.

.topic 87
Список доступных таблиц БД. В списке также имеется строка "Системные переменные", при выборе которой становятся доступны переменные "дата", "время", "выражение", "номер страницы" и пр.

This help file was created with HelpScribble.

.topic 88
Список доступных источников данных - компонентов TfrUserDataSet, TfrDBDataSet. В списке имеются также пункты "Нет" (источник данных не назначен) и "Виртуальный" (назначается источник данных типа TfrUserDataSet с количеством записей, задаваемым в соответствующем поле).

This help file was created with HelpScribble.

.topic 89
Список бэндов, которые можно вставить в отчет. Для вставки бэнда выберите нужный тип и нажмите кнопку "ОК".

This help file was created with HelpScribble.

.topic 90
Переключает размер шрифта, используемого в редакторах текста и скрипта.

This help file was created with HelpScribble.

.topic 91
Правое поле страницы.

This help file was created with HelpScribble.

.topic 92
Задает прозрачный фон для объекта, выводимого с атрибутами выделения.

This help file was created with HelpScribble.

.topic 93
Список доступных полей в выбранной таблице БД. Если выбрана строка "Системные переменные", то в списке становятся доступны переменные "дата", "время", "выражение", "номер страницы" и пр.

This help file was created with HelpScribble.

.topic 94
При перемещении или изменении размеров объект выделяется инверсией.

This help file was created with HelpScribble.

.topic 95
Поле становится доступно при выборе виртуального источника данных. Задает количество записей в источнике.

This help file was created with HelpScribble.

.topic 96
Выражение - условие группировки. При изменении значения выражения будет сформирована новая группа. Для подстановки в строку поля из таблицы БД, используйте кнопку в правой части строки.

This help file was created with HelpScribble.

.topic 97
Список доступных таблиц БД.

This help file was created with HelpScribble.

.topic 98
Поле для ввода искомой строки.

This help file was created with HelpScribble.

.topic 99
Задает количество печатаемых копий.

This help file was created with HelpScribble.

.topic 100
Включает или выключает перенос слов в длинных строках редакторов текста и скрипта.

This help file was created with HelpScribble.

.topic 101
Нижнее поле страницы.

This help file was created with HelpScribble.

.topic 102
Устанавливает единицы измерения, выраженные в экранных пикселах.

This help file was created with HelpScribble.

.topic 103
Задает фон для объекта, выводимого с атрибутами выделения.

This help file was created with HelpScribble.

.topic 104
Поле для ввода выражения. Становится доступно при включении флажка "Выражение". При этом введенное выражение назначится текущей переменной.

This help file was created with HelpScribble.

.topic 105
Список бэндов, которые пересекаются с бэндом Cross data. Для каждого бэнда в списке можно назначить свой источник данных. Для этого выберите бэнд щелчком мыши, а затем выберите соответствующий ему источник.

This help file was created with HelpScribble.

.topic 106
Список полей в выбранной таблице БД. Для отметки полей, вставляемых в отчет, щелкайте мышкой по нужным полям, удерживая клавишу Ctrl. Чтобы отметить группу подряд идущих полей, щелкните мышкой на первом поле, и, нажав клавишу Shift, щелкните на последнем.

This help file was created with HelpScribble.

.topic 107
Если опция включена, то при поиске будет учитываться регистр.

This help file was created with HelpScribble.

.topic 108
Печать всех страниц.

This help file was created with HelpScribble.

.topic 109
Трехмерное отображение диаграммы.

This help file was created with HelpScribble.

.topic 110
Вызывает окно редактора формата переменных. Редатор переменных доступен также из контекстного меню объекта. Для быстрого вызова можно воспользоваться комбинацией клавиш Ctrl+F.

This help file was created with HelpScribble.

.topic 111
Устанавливает портретную ориентацию листа.

This help file was created with HelpScribble.

.topic 112
Устанавливает единицы измерения, выраженные в миллиметрах.

This help file was created with HelpScribble.

.topic 113
Задает условие, при выполнении которого объект будет выведен с атрибутами выделения.

This help file was created with HelpScribble.

.topic 114
Показывает редактор списка переменных.

This help file was created with HelpScribble.

.topic 115
Располагает выбранные поля друг за другом по горизонтали.

This help file was created with HelpScribble.

.topic 116
Ищет текст, начиная с первой страницы.

This help file was created with HelpScribble.

.topic 117
Диаграмма может быть двух типов: одиночная и множественная (т.е. на одной координатной плоскости изображается несколько графиков). Множественная диаграмма может быть использована, например, в отчете с группами, многоуровневом отчете или cross-tab отчете.

This help file was created with HelpScribble.

.topic 118
Печать только текущей страницы.

This help file was created with HelpScribble.

.topic 119
Редактирует содержимое OLE контейнера.

This help file was created with HelpScribble.

.topic 120
Устанавливает альбомную ориентацию листа.

This help file was created with HelpScribble.

.topic 121
Устанавливает единицы измерения, выраженные в дюймах.

This help file was created with HelpScribble.

.topic 122
Располагает выбранные поля друг за другом по вертикали.

This help file was created with HelpScribble.

.topic 124
Печать только выбранных страниц.

This help file was created with HelpScribble.

.topic 125
Содержимое OLE контейнера.

This help file was created with HelpScribble.

.topic 126
Список возможных типов фигуры.

This help file was created with HelpScribble.

.topic 127
Если опция включена, то рядом с диаграммой выводится поясняющая подпись.

This help file was created with HelpScribble.

.topic 128
Список полей набора данных, которые можно добавить в список доступных полей. Для того, чтобы добавить группу полей в список, щелкните мышкой на первом поле группы, затем, удерживая клавишу Shift, щелкните на последнем поле.

This help file was created with HelpScribble.

.topic 129
Показывает редактор для выделенного набора данных. Команда также доступна с помощью двойного щелчка мыши на нужном наборе данных.

This help file was created with HelpScribble.

.topic 130
Список форматов бумаги, которые поддерживаются выбранным принтером. Если принтер поддерживает пользовательский формат бумаги, то при выборе соответствующего значения становятся доступны поля для ввода размера.

This help file was created with HelpScribble.

.topic 131
Задает шаг сетки, равный 4 экранным пикселам.

This help file was created with HelpScribble.

.topic 132
Добавляет к каждому полю заголовок. В качестве заголовка используется имя поля.

This help file was created with HelpScribble.

.topic 133
Поле для ввода номеров печатаемых страниц.

This help file was created with HelpScribble.

.topic 134
Показывать координатные оси на диаграмме. Для круговой диаграммы эту опцию надо отключать.

This help file was created with HelpScribble.

.topic 135
Создает новую таблицу БД.

This help file was created with HelpScribble.

.topic 136
Имя нового lookup поля.

This help file was created with HelpScribble.

.topic 137
Список полей подчиненного набора данных.

This help file was created with HelpScribble.

.topic 138
Тип выбранного параметра.

This help file was created with HelpScribble.

.topic 139
Выбор основного (master) набора данных.

This help file was created with HelpScribble.

.topic 150
Высота бумаги.

This help file was created with HelpScribble.

.topic 151
Задает шаг сетки, равный 18 экранным пикселам, что соответствует 5мм.

This help file was created with HelpScribble.

.topic 152
Показывает диалог настройки принтера.

This help file was created with HelpScribble.

.topic 153
Показывать пометки над каждым значением.

This help file was created with HelpScribble.#

.topic 153
Показывать пометки над каждым значением.

This help file was created with HelpScribble.#

.topic 154
Создает новый запрос (Query).

This help file was created with HelpScribble.

.topic 155
Размер поля. Имеет значение, если выбран тип поля "строка".

This help file was created with HelpScribble.

.topic 156
Добавляет пару полей (из подчиненного и основного набора данных) в список связанных полей. Для добавления выделите поле в подчиненном наборе, пользуясь мышью, затем соответствующее ему поле в основном наборе, и нажмите эту кнопку.

This help file was created with HelpScribble.

.topic 157
Присвоить параметру конкретное значение.

This help file was created with HelpScribble.

.topic 158
Показывает диалог - редактор списка доступных полей.

This help file was created with HelpScribble.

.topic 159
При включении флажка создает бэнды Page header и Master data.

This help file was created with HelpScribble.

.topic 160
Опция позволяет начать печать страницы начиная со свободного места на предыдущем листе.

This help file was created with HelpScribble.

.topic 161
Показывает в цвете кнопки на панелях инструментов и в окне предварительного просмотра. Если опция отключена, то кнопка показывается в цвете только при наведении на нее указателя мыши.

This help file was created with HelpScribble.

.topic 162
Показывать числовое значение в качестве пометки.

This help file was created with HelpScribble.

.topic 164
Список связанных полей.

This help file was created with HelpScribble.

.topic 165
Перед формированием отчета запросить значение параметра в диалоге.

This help file was created with HelpScribble.

.topic 166
Показывает диалог - редактор параметров запроса.

This help file was created with HelpScribble.

.topic 167
Строка ввода параметра функции. Для визуального ввода используйте кнопку в правой части строки.

This help file was created with HelpScribble.

.topic 168
Имя таблицы.

This help file was created with HelpScribble.

.topic 169
Действия над объектом, которые можно запретить.

This help file was created with HelpScribble.

.topic 170
Задает количество колонок на странице для многоколоночных отчетов.

This help file was created with HelpScribble.

.topic 171
Если опция включена, то после помещения нового объекта на страницу вызывается его редактор.

This help file was created with HelpScribble.

.topic 172
Показывать процент в качестве пометки.

This help file was created with HelpScribble.

.topic 174
Очищает список связанных полей.

This help file was created with HelpScribble.

.topic 175
Взять значение параметра из основного (master) источника данных. Для этого в окне редактирования запроса надо назначить основной источник данных.

This help file was created with HelpScribble.

.topic 176
Текст запроса.

This help file was created with HelpScribble.

.topic 177
Выбор индекса для таблицы.

This help file was created with HelpScribble.

.topic 178
Список доступных категорий функций. При выборе категории в списке справа отображаются функции, входящие в категорию.

This help file was created with HelpScribble.

.topic 179
Поле, в котором отображается построенное выражение. Поле также доступно для ручного редактирования.

This help file was created with HelpScribble.

.topic 180
Задает промежуток между соседними колонками.

This help file was created with HelpScribble.

.topic 181
Показывать название в качестве пометки.

This help file was created with HelpScribble.

.topic 182
Поле из набора данных lookup, которое является ключевым.

This help file was created with HelpScribble.#

.topic 183
Поле из набора данных lookup, которое будет отображаться в списке.

This help file was created with HelpScribble.

.topic 184
Местонахождение таблиц БД, на основе которых построен запрос. Здесь может быть значение из выпадающего списка либо путь к каталогу с таблицами. Это поле можно оставить пустым, в этом случае алиас или путь надо указывать в тексте запроса.

This help file was created with HelpScribble.

.topic 185
Выражение фильтра для таблицы.

This help file was created with HelpScribble.

.topic 186
При включении флажка перетаскивание или изменение размеров объектов сопровождается их немедленной прорисовкой. Иначе прорисовывается только контур объекта.

This help file was created with HelpScribble.

.topic 187
Список функций, доступных в выбранной категории.

This help file was created with HelpScribble.

.topic 188
Указывает, в каком порядке надо печатать листы документа, если задана печать нескольких копий.

This help file was created with HelpScribble.

.topic 189
Удалять пустые строки из выходного документа.

This help file was created with HelpScribble.

.topic 190
Показывать название и процент в качестве пометки.

This help file was created with HelpScribble.

.topic 191
Поле из основного набора данных, которое ссылается на ключевое поле из lookup набора данных.

This help file was created with HelpScribble.

.topic 192
Строки списка. Если в строке присутствует символ ";", например, "декабрь;12", то в списке будет выведено слово "декабрь", а при выборе этого значения будет подставлена строка "12".

This help file was created with HelpScribble.

.topic 193
Поля, связанные с полями из основного источника данных. Для редактирования связанных полей воспользуйтесь кнопкой в правой части строки.

This help file was created with HelpScribble.

.topic 194
Если опция включена, то у бэндов отображается закладка с заголовком, иначе бэнд отображается в виде серой полосы без закладки.

This help file was created with HelpScribble.

.topic 195
Список доступных лотков принтера.

This help file was created with HelpScribble.

.topic 196
Из этого списка можно выбрать, какие страницы печатать: все, четные или нечетные.

This help file was created with HelpScribble.

.topic 197
Конвертировать текст в DOS-кодировку.

This help file was created with HelpScribble.

.topic 198
Считывает текст SQL запроса из файла

This help file was created with HelpScribble.

.topic 199
Записывает текст SQL запроса в файл

This help file was created with HelpScribble.

.topic 200
Показывает выпадающее меню для выбора масштаба изображения. Команда также доступна при нажатии клавиши "Пробел".

This help file was created with HelpScribble.

.topic 201
Открывает ранее сохраненный отчет (файл с расширением .frp). Команда также доступна при нажатии клавиш Ctrl+O.

This help file was created with HelpScribble.

.topic 202
Вызывает диалог сохранения файла. По умолчанию сохраняет отчет в файле .frp. Если доступны фильтры экспорта, то соответствующие типы файлов появятся в выпадающем списке "Тип файла". Команда также доступна при нажатии клавиш Ctrl+S.

This help file was created with HelpScribble.

.topic 203
Вызывает диалог печати файла. Команда также доступна при нажатии клавиш Ctrl+P.

This help file was created with HelpScribble.

.topic 204
Осуществляет поиск строки текста в сформированном отчете. Эта команда доступна также при нажатии клавиш Ctrl+F (начать поиск) и F3 (продолжить поиск).

This help file was created with HelpScribble.

.topic 205
Закрывает окно.

This help file was created with HelpScribble.

.topic 206
Отображает номер текущей страницы.

This help file was created with HelpScribble.

.topic 207
Отображает страницы отчета. При нажатии правой кнопки мыши выводится контекстное меню, в котором можно сменить масштаб изображения, а также редактировать содержимое текущей страницы, добавить новую страницу или удалить текущую.

This help file was created with HelpScribble.

.topic 208
Показывать название и числовое значение в качестве пометки.

This help file was created with HelpScribble.#

.topic 209
Настройка параметров шрифта.

This help file was created with HelpScribble.

.topic 210
Для построения графика необходимо указать имена двух объектов типа "Текст", в которых содержится название и соответствующее числовое значение. При построении отчета содержимое этих объектов будет накапливаться в мемо диаграммы. В этом поле указывается имя объекта, содержащего название.

This help file was created with HelpScribble.

.topic 211
Текст, который будет отображаться внутри элемента.

This help file was created with HelpScribble.

.topic 212
Определяет позицию страницы отчета в окне дизайнера.

This help file was created with HelpScribble.

.topic 213
Использовать символы псевдографики при экспорте рамок.

This help file was created with HelpScribble.

.topic 214
При включении флажка становится доступным поле для ввода выражения.

This help file was created with HelpScribble.

.topic 220
Для построения графика необходимо указать имена двух объектов типа "Текст", в которых содержится название и соответствующее числовое значение. При построении отчета содержимое этих объектов будет накапливаться в мемо диаграммы. В этом поле указывается имя объекта, содержащего числовое значение.

This help file was created with HelpScribble.

.topic 221
Элемент является строкой ввода.

This help file was created with HelpScribble.

.topic 222
При редактировании объекта "Текст" использовать тот же шрифт, что и в объекте.

This help file was created with HelpScribble.

.topic 223
Экспортировать линии рамок объектов.

This help file was created with HelpScribble.

.topic 224
Список всех наборов данных, имеющихся в приложении. Для того, чтобы использовать только нужные данные, перетащите их в список в правой части окна.

This help file was created with HelpScribble.

.topic 230
Объект позволяет легко строить графики типа "Top10", т.е. график, в котором представлены только первые самые большие значения, а остальные значения просуммированы в отдельную группу с названием. В этом поле указывается количество выводимых значений.

This help file was created with HelpScribble.

.topic 231
Элемент является выпадающим списком.

This help file was created with HelpScribble.

.topic 232
При редактировании объекта "Текст" использовать фиксированные установки шрифта.

This help file was created with HelpScribble.

.topic 233
Вставлять символы разрыва страницы в выходной файл.

This help file was created with HelpScribble.

.topic 234
Список наборов данных, используемых в текущем отчете. Остальные данные, имеющиеся в приложении, будут недоступны.

This help file was created with HelpScribble.

.topic 250
Размер шрифта для использования в редакторе текста.

This help file was created with HelpScribble.

.topic 251
Создает новую базу данных. Это обязательно при работе с IBX или ADO.

This help file was created with HelpScribble.

.topic 252
Имя компонента - базы данных.

This help file was created with HelpScribble.

.topic 253
Имя нового алиаса, представляющего эту базу данных. Если вы работаете с IBX или ADO, здесь указывается имя файла с базой данных. Чтобы выбрать файл, воспользуйтесь кнопкой справа.

This help file was created with HelpScribble.

.topic 254
Имя драйвера БД (при работе с BDE).

This help file was created with HelpScribble.

.topic 255
Параметры соединения с БД. Здесь можно указать имя пользователя, пароль и другие нужные параметры. Замечание: разные драйверы БД используют разные наименования параметров.

This help file was created with HelpScribble.

.topic 256
При установленной опции будет выводиться окно запроса имени пользователя и его пароля, когда вы подключаетесь к БД. Если эти параметры уже заданы в списке параметров БД, эту опцию можно отключать.

This help file was created with HelpScribble.

.topic 257
Список доступных БД. Выберите нужную БДиз списка, потом выберите таблицу из списка ниже. Для выбора локальных таблиц (Paradox, DBase) можно воспользоваться кнопкой "Обзор".

This help file was created with HelpScribble.

.topic 258
Список доступных таблиц в выбранной базе данных.

This help file was created with HelpScribble.

.topic 259
Вы можете выбрать таблицу прямо из файла (если вы используете локальные таблицы Paradox, DBase совместно с BDE).

This help file was created with HelpScribble.

.topic 260
Код, котрый нужно напечатать. Для вставки в это поле переменной FR или поля таблицы БД используйте кнопку справа от строки ввода.

This help file was created with HelpScribble.

.topic 261
Тип штрихкода.

This help file was created with HelpScribble.

.topic 262
Установка этой опции приведет к формированию дополнительного проверочного кода.

This help file was created with HelpScribble.

.topic 263
Установка этой опции приведет к печати кода в виде читаемого текста.

This help file was created with HelpScribble.

.topic 264
Ориентация штрихкода.

This help file was created with HelpScribble.

.topic 265
Образец шрифта, используемого в редакторе текста.

This help file was created with HelpScribble.

.topic 266
Коэффициент масштабирования по X.

This help file was created with HelpScribble.

.topic 267
Экспортировать изображения.

This help file was created with HelpScribble.

.topic 268
В этом поле можно задать более понятное название для элемента (набора данных или его поля), выбранного в списке в правой части окна.

This help file was created with HelpScribble.

.topic 270
Имя шрифта для использования в редакторе скрипта.

This help file was created with HelpScribble.

.topic 271
В этом поле можно задать более понятное название для элемента, выбранного в списке в правой части окна.

This help file was created with HelpScribble.

.topic 276
Символ-разделить формата CSV.

This help file was created with HelpScribble.

.topic 277
Конвертировать выходной файл в таблицу.

This help file was created with HelpScribble.

.topic 280
Размер шрифта для использования в редакторе скрипта.

This help file was created with HelpScribble.

.topic 281
Список всех источников данных для бэндов, имеющихся в приложении. Для использования только нужных источников, перетащите их в список в правой части окна.

This help file was created with HelpScribble.

.topic 290
Образец шрифта, используемого в редакторе скрипта.

This help file was created with HelpScribble.

.topic 291
Список источников данных для бэндов, используемых в текущем отчете.

This help file was created with HelpScribble.

.topic 300
Открывает файл в формате .RTF.

This help file was created with HelpScribble.

.topic 301
Записывает содержимое в файл формата .RTF.

This help file was created with HelpScribble.

.topic 302
Отменяет последнее выполненное изменение.

This help file was created with HelpScribble.

.topic 303
Показывает диалог установки параметров шрифта.

This help file was created with HelpScribble.

.topic 304
Позволяет быстро вставить переменную в текст.

This help file was created with HelpScribble.

.topic 307
Показывает список установленных в системе шрифтов.

This help file was created with HelpScribble.

.topic 308
Устанавливает размер шрифта.

This help file was created with HelpScribble.

.topic 309
Устанавливает или снимает утолщение у шрифта.

This help file was created with HelpScribble.

.topic 310
Устанавливает или снимает наклон у шрифта.

This help file was created with HelpScribble.

.topic 311
Устанавливает или снимает подчеркивание у шрифта.

This help file was created with HelpScribble.

.topic 312
Устанавливает выравнивание текста влево.

This help file was created with HelpScribble.

.topic 313
Устанавливает выравнивание текста по центру.

This help file was created with HelpScribble.

.topic 314
Устанавливает выравнивание текста вправо.

This help file was created with HelpScribble.

.topic 315
Устанавливает или снимает маркировку в выделенном фрагменте.

This help file was created with HelpScribble.

.topic 316
Устанавливает отступ для первой строки абзаца.

This help file was created with HelpScribble.

.topic 317
Устанавливает отступ для всех строк абзаца, кроме первой.

This help file was created with HelpScribble.

.topic 318
Устанавливает отступ справа для текста.

This help file was created with HelpScribble.

.topic 319
Содержимое объекта.

This help file was created with HelpScribble.

.topic 400
Текущая страница документа. Если в документе несколько страниц, то в верхней части страницы появятся дополнительные закладки. Чтобы вывести нужную страницу, щелкните мышкой на соответствующей закладке.

This help file was created with HelpScribble.

.topic 401
Включает или выключает верхнюю линию рамки выделенного объекта.

This help file was created with HelpScribble.

.topic 402
Включает или выключает левую линию рамки выделенного объекта.

This help file was created with HelpScribble.

.topic 404
Включает или выключает правую линию рамки выделенного объекта.

This help file was created with HelpScribble.

.topic 405
Выбор цвета заливки объекта. При нажатии кнопки показывает выпадающий список цветов. Если в списке выбран цвет "Другие", то показывает стандартный диалог выбора цвета.

This help file was created with HelpScribble.

.topic 406
Устанавливает толщину рамки выделенного объекта. Команда также доступна при нажатии Ctrl+1..9.

This help file was created with HelpScribble.

.topic 407
Название шрифта, которым отображается выбранный объект "Текст". Чтобы сменить шрифт, щелкните мышью на этом поле и выберите нужный шрифт из списка. Желательно использовать шрифты с символом "Тт" - TrueType, так как они лучше масштабируются.

This help file was created with HelpScribble.

.topic 408
Размер шрифта, которым отображается выбранный объект "Текст". Чтобы сменить размер, щелкните мышью на кнопке со стрелкой в правой части поля и выберите нужный размер из списка. Если такого размера в списке нет, щелкните мышью на самом поле и введите размер вручную, после этого нажмите Enter.

This help file was created with HelpScribble.

.topic 409
Устанавливает или снимает утолщение для шрифта, которым отображается выделенный объект "Текст".

This help file was created with HelpScribble.

.topic 410
Устанавливает или снимает наклон для шрифта, которым отображается выделенный объект "Текст".

This help file was created with HelpScribble.

.topic 411
Устанавливает выравнивание текста по левому краю в выделенном объекте "Текст".

This help file was created with HelpScribble.

.topic 412
Устанавливает выравнивание текста по правому краю в выделенном объекте "Текст".

This help file was created with HelpScribble.

.topic 414
Ориентация шрифта для выбранного объекта "Текст". В нажатом положении выводит вертикальный шрифт.

This help file was created with HelpScribble.

.topic 415
Устанавливает вертикальное выравнивание текста (по верхнему краю, по центру и по нижнему краю) в выделенном объекте "Текст".

This help file was created with HelpScribble.

.topic 417
Выбор цвета шрифта. При нажатии кнопки показывает выпадающий список цветов. Если в списке выбран цвет "Другие", то показывает стандартный диалог выбора цвета.

This help file was created with HelpScribble.

.topic 418
Устанавливает или снимает подчеркивание для шрифта, которым отображается выделенный объект "Текст".

This help file was created with HelpScribble.

.topic 419
Выбор цвета рамки объекта. При нажатии кнопки показывает выпадающий список цветов. Если в списке выбран цвет "Другие", то показывает стандартный диалог выбора цвета.

This help file was created with HelpScribble.

.topic 420
Включает все линии рамки выделенного объекта. Команда также доступна при нажатии Ctrl+F.

This help file was created with HelpScribble.

.topic 421
Выключает все линии рамки выделенного объекта. Команда также доступна при нажатии Ctrl+D.

This help file was created with HelpScribble.

.topic 422
Устанавливает выравнивание текста по обоим краям в выделенном объекте "Текст".

This help file was created with HelpScribble.

.topic 429
При нажатой кнопке курсором мыши можно выделять объекты, перемещать их и изменять размеры.

This help file was created with HelpScribble.

.topic 430
Вставка в документ объекта "Текст". Объект предназначен для отображения многострочного текста, полей из таблицы БД, служебной информации (например, номера страницы, даты, времени).

This help file was created with HelpScribble.

.topic 431
Вставка в документ рисунка. Рисунок может быть загружен из графического файла в формате BMP, ICO, WMF, EMF, JPG (рисунки в формате JPG доступны в Delphi 3 и выше).

This help file was created with HelpScribble.

.topic 432
Вставка секции (бэнда) в документ.

This help file was created with HelpScribble.

.topic 434
Вставка горизонтальной или вертикальной линии в документ. При нажатии кнопки включается режим рисования, при котором курсор мыши принимает вид карандаша. Для отмены режима нажмите кнопку со стрелкой на этой панели.

This help file was created with HelpScribble.

.topic 435
Вставка подключаемого (Add-In) объекта в документ.

This help file was created with HelpScribble.

.topic 436
Мастера, установленные в системе. Список мастеров также доступен в меню "Сервис", "Мастера".

This help file was created with HelpScribble.

.topic 440
Создает новый пустой документ. Новый документ можно также создать на основе шаблона, воспользовавшись командой меню "Файл", "Новый...".

This help file was created with HelpScribble.

.topic 441
Открывает существующий документ (файл в формате FRF). Команда также доступна при нажатии Ctrl+O.

This help file was created with HelpScribble.

.topic 442
Сохраняет документ в файле. Если документ новый, запрашивает имя файла. Если в списке "Тип файла" выбран шаблон FastReport, то будет показан диалог для описания шаблона. Команда также доступна при нажатии Ctrl+S.

This help file was created with HelpScribble.

.topic 447
Отменяет последнее действие. Система помнит список из последних 100 изменений. Некоторые операции (удаление страницы, установка опций) не могут быть отменены. Команда также доступна при нажатии Ctrl+Z.

This help file was created with HelpScribble.

.topic 448
Повторяет отмененное действие. Система помнит список из последних 100 отмененных действий. Команда также доступна при нажатии Ctrl+Y.

This help file was created with HelpScribble.

.topic 449
Перемещает выделенный объект или группу объектов на передний план.

This help file was created with HelpScribble.

.topic 450
Перемещает выделенный объект или группу объектов на задний план.

This help file was created with HelpScribble.

.topic 451
Выделяет все объекты на странице. Команда также доступна при нажатии Ctrl+A.

This help file was created with HelpScribble.

.topic 452
Добавляет новую страницу в документ.

This help file was created with HelpScribble.

.topic 454
Вызывает диалог настройки параметров страницы. Команда доступна также при двойном щелчке мышью на пустом месте страницы.

This help file was created with HelpScribble.

.topic 455
Показывает на странице точечную сетку для более удобного размещения объектов. Повторное нажатие прячет сетку. Шаг сетки может быть задан в диалоговом окне, которое можно вызвать из меню "Сервис", "Настройка". Команда также доступна при нажатии Ctrl+G.

This help file was created with HelpScribble.

.topic 456
Выравнивание объектов по сетке. При перемещении объекта мышью или при изменении его размеров положение и размеры объекта меняются скачкообразно, в соответствии с шагом сетки. Это позволяет более ровно размещать объекты на листе. Команда также доступна при нажатии Ctrl+B.

This help file was created with HelpScribble.

.topic 457
Меняет позицию и размеры выделенных объектов таким образом, чтобы они располагались в узлах сетки.

This help file was created with HelpScribble.

.topic 458
Закрывает окно дизайнера.

This help file was created with HelpScribble.#

.topic 459
Показывает диалог, в котором можно задать атрибуты выделения. Эта команда доступна, если выбран объект "Текст".

This help file was created with HelpScribble.

.topic 460
Панель инструментов, с помощью которой можно задать выравнивание объектов относительно друг друга или в окне. При выравнивании учитывается, какой из объектов был выделен первым.

This help file was created with HelpScribble.

.topic 470
Добавляет в отчет диалоговую страницу.

This help file was created with HelpScribble.

.topic 500
data-бэнд

Бэнд, который может быть подключен к источнику данных. Data-бэндами являются Master data, Detail data, Subdetail data, Cross data.

This help file was created with HelpScribble.

.topic 30
Редактор текста.

This help file was created with HelpScribble.