TfrChartObject component
See also
Top Next

Unit
FR_Chart

Description
Компонент TfrChartObject является пустым и предназначен только для автоматического добавления модуля FR_Chart в список uses. Все необходимые действия выполняются в секции инициализации этого модуля. См. TfrChartView object

This help file was created with HelpScribble.


TfrChartView object
See also Properties Methods
Previous Top Next

Unit
FR_Chart

Description
Объект "Диаграмма". Предназначен для вставки графика или диаграммы в документ. Возможно использование шести типов графиков: линии, точки, столбцы горизонтальные и вертикальные, области и круговые диаграммы.

Для использования этого объекта в run-time следует использовать компонент TfrChartObject из палитры компонентов FR. Если открываемый отчет содержит неподключенные компоненты, то выдастся сообщение об ошибке.

Доступен в Delphi 3 и выше. Для использования в Delphi 2 необходимо установить компонент TeeChart для Delphi 2, затем исправить строку в подключаемом файле FR.inc и перекомпилировать библиотеку FR.


TfrCheckBoxObject component
See also
Previous Top Next

Unit
FR_ChBox

Description
Компонент TfrCheckBoxObject является пустым и предназначен только для автоматического добавления модуля FR_ChBox в список uses. Все необходимые действия выполняются в секции инициализации этого модуля. См. TfrCheckBoxView object


TfrCheckBoxView object
See also Properties Methods
Previous Top Next

Unit
FR_ChBox

Description
Объект "CheckBox". Представляет собой прямоугольник с крестиком внутри. Если в мемо объекта разместить ссылку на переменную либо на поле таблицы БД, то крестик будет показан при ненулевом значении переменной. В мемо можно также разместить символ "0" либо отличный от нуля.

Для использования этого объекта в run-time следует использовать компонент TfrCheckBoxObject из палитры компонентов FR. Если открываемый отчет содержит неподключенные компоненты, то выдастся сообщение об ошибке.


TfrOLEObject component
See also
Previous Top Next

Unit
FR_OLE

Description
Компонент TfrOLEObject является пустым и предназначен только для автоматического добавления модуля FR_OLE в список uses. Все необходимые действия выполняются в секции инициализации этого модуля. См. TfrOLEView object


TfrOLEView object
See also Properties Methods
Previous Top Next

Unit
FR_OLE

Description
Объект "OLE". Предназначен для вставки OLE объектов в документ.

Для использования этого объекта в run-time следует использовать компонент TfrOLEObject из палитры компонентов FR. Если открываемый отчет содержит неподключенные компоненты, то выдастся сообщение об ошибке.


TfrRichObject component
See also
Previous Top Next

Unit
FR_Rich

Description
Компонент TfrRichObject является пустым и предназначен только для автоматического добавления модуля FR_Rich в список uses. Все необходимые действия выполняются в секции инициализации этого модуля. См. TfrRichView object


TfrRichView object
See also Properties Methods
Previous Top Next

Unit
FR_Rich

Description
Объект "RichText". Предназначен для вставки текста в формате RTF (Rich Text Format) в документ.

Для использования этого объекта в run-time следует использовать компонент TfrRichObject из палитры компонентов FR. Если открываемый отчет содержит неподключенные компоненты, то выдастся сообщение об ошибке.


TfrShapeObject component
See also
Previous Top Next

Unit
FR_Shape

Description
Компонент TfrRichObject является пустым и предназначен только для автоматического добавления модуля FR_Rich в список uses. Все необходимые действия выполняются в секции инициализации этого модуля. См. TfrRichView object


TfrShapeView object
See also Properties Methods
Previous Top Next

Unit
FR_Shape

Description
Объект "Фигура". Предназначен для вставки геометрических фигур (прямоугольник, прямоугольник с закругленными углами, эллипс, треугольник) в документ.

Для использования этого объекта в run-time следует использовать компонент TfrShapeObject из палитры компонентов FR. Если открываемый отчет содержит неподключенные компоненты, то выдастся сообщение об ошибке.


TfrView object

See also Properties Methods
Previous Top Next

Unit
FR_Class

Description
Базовый объект. Все визуальные объекты FastReport наследуются от него.


TfrMemoView object
See also Properties Methods
Previous Top Next

Unit
FR_Class

Description
Объект "Текст". Представляет собой произвольным образом обрамленный прямоугольник с многострочным текстом внутри. Задается цвет текста/заливка, тип рамки, толщина рамки и цвет, все параметры шрифта текста, выравнивание текста внутри прямоугольника и ориентация текста (норм./90 градусов). В мемо объекта можно поместить многострочный текст с переменными.


TfrBandView object
See also Properties Methods
Previous Top Next

Unit
FR_Class

Description
Объект "Секция" (бэнд). Предназначен для вставки секции в документ.


TfrSubReportView object
See also Properties Methods
Previous Top Next

Unit
FR_Class

Description
Объект "Вложенный отчет". Вложенный отчет - это отчет с размещенным на нем объектом SubReport, который представляет собой ссылку на другой отчет, расположенный на отдельной странице. При формировании такого отчета вместо объекта SubReport будет выведен соответствующий отчет.


TfrPictureView object
See also Properties Methods
Previous Top Next

Unit
FR_Class

Description
Объект "Рисунок". Предназначен для вставки графического файла в формате BMP/WMF/ICO (и JPG, если установлен соответствующий модуль) в документ.


TfrLineView object
See also Properties Methods
Previous Top Next

Unit
FR_Class

Description
Объект "Линия". Представляет собой вертикальную либо горизонтальную линию с изменяемым цветом и толщиной.


TfrBand object

See also Properties
Previous Top Next

Unit
FR_Class

Description
Объект преставляет собой бэнд в режиме построения отчета. В режиме дизайнера бэнд представлен объектом TfrBandView и предназначен только для отображения в дизайнере. Перед началом построения содержимое объектов TfrBandView копируется в объекты TfrBand. Объект TfrBand содержит список принадлежащих ему визуальных объектов Objects и источник данных DataSet (только для дата-бэндов).


TfrPage object

See also Properties Methods
Previous Top Next

Unit
FR_Class

Description
Объект представляет собой страницу в режиме дизайнера. Содержит параметры страницы и список визуальных объектов, расположенных на странице. В режиме построения отчета предоставляет методы управления процессом построения ShowBandByName, ShowBandByType, NewPage.


TfrPages object

See also Properties Methods
Previous Top Next

Unit
FR_Class

Description
Объект представляет собой список страниц отчета (под страницей подразумевается страница в режиме дизайнера). Содержит набор методов для управления списком.


TfrEMFPages object

Properties Methods
Previous Top Next

Unit
FR_Class

Description
Объект представляет собой список страниц построенного отчета. Содержит набор методов для управления списком.


TfrReport component
See also Properties Methods Events
Previous Top Next

Unit
FR_Class

Description
Компонент является ядром FastReport. Он содержит все необходимые методы для хранения, построения, предварительного просмотра, экспорта и печати отчета.

Свойство Pages предоставляет доступ к страницам формы отчета. Свойство EMFPages позволяет обращаться к страницам сформированного отчета.

Группа методов LoadFromStream, SaveToStream, LoadFromFile, SaveToFile, LoadFromDB, SaveToDB предназначена для считывания/записи документа, шаблона документа (LoadTemplate, SaveTemplate) и сформированного отчета (LoadPreparedReport, SavePreparedReport).

Метод DesignReport запускает дизайнер, если он используется в проекте.

Методы PrepareReport и ShowReport выполняют построение отчета (ShowReport после этого показывает отчет в окне предварительного просмотра).

Метод PrintPreparedReport печатает отчет, метод ExportTo выполняет экспорт отчета с использованием фильтра экспорта.


TfrCompositeReport component
See also Properties Methods Events
Previous Top Next

Unit
FR_Class

Description
Компонент представляет собой композитный (составной) отчет и предназначен для "склеивания" нескольких отчетов в один. Для этого программно заполняется список Reports ссылками на нужные объекты TfrReport.


TfrFunctionLibrary object

Properties Methods
Previous Top Next

Unit
FR_Class

Description
Объект представляет собой библиотеку функций. Каждый раз, когда встроенный парсер выражений обнаруживает вызов внешней функции, функция ищется в подключенных библиотеках.


TfrDataset object

See also Properties Methods Events
Previous Top Next

Unit
FR_DSet

Description
Объект, предназначенный для навигации по набору данных. Является базовым для компонентов TfrDBDataSet, TfrUserDataSet.


TfrUserDataset component
See also Properties Methods Events
Previous Top Next

Unit
FR_DSet

Description
Представляет собой пользовательский набор данных. Компонент особенно удобен для навигации по таким объектам, как массив, файл данных, содержимое TStringGrid и пр. Для навигации по такому набору надо определить обработчики событий OnFirst, OnNext, OnCheckEOF компонента. В большинстве случаев можно просто указать диапазон навигации с помощью свойств RangeBegin, RangeEnd, RangeEndCount. Текущая позиция указателя доступна с помощью свойства RecNo.


TfrDBDataSet component
See also Properties Methods Events
Previous Top Next

Unit
FR_DBSet

Description
Компонент предназначен для навигации по набору данных, основанному на таблице БД. Для связи с таблицей служит свойство DataSource, которое подключается к связке TDataSource -> TDataSet. В качестве TDataSet может выступать любой его потомок (TTable, TQuery и пр).


TfrCSVExport component

Previous Top Next

Unit
FR_E_CSV

Description
При использовании компонента в системе регистрируется фильтр экспорта в формат .CSV. Фильтр можно вызвать из окна предварительного просмотра, выполнив команду "Сохранить в файл". При этом в стандартном диалоге сохранения в файл в выпадающем списке "Тип файла" появляются типы файлов, соответствующие установленным фильтрам экспорта.


TfrHTMExport component

Previous Top Next

Unit
FR_E_HTM

Description
При использовании компонента в системе регистрируется фильтр экспорта в формат .HTM (файлы HTML). Фильтр можно вызвать из окна предварительного просмотра, выполнив команду "Сохранить в файл". При этом в стандартном диалоге сохранения в файл в выпадающем списке "Тип файла" появляются типы файлов, соответствующие установленным фильтрам экспорта.


TfrRTFExport component

Previous Top Next

Unit
FR_E_RTF

Description
При использовании компонента в системе регистрируется фильтр экспорта в формат .RTF. Фильтр можно вызвать из окна предварительного просмотра, выполнив команду "Сохранить в файл". При этом в стандартном диалоге сохранения в файл в выпадающем списке "Тип файла" появляются типы файлов, соответствующие установленным фильтрам экспорта.


TfrTextExport component

Previous Top Next

Unit
FR_E_TXT

Description
При использовании компонента в системе регистрируется фильтр экспорта в формат .TXT. Фильтр можно вызвать из окна предварительного просмотра, выполнив команду "Сохранить в файл". При этом в стандартном диалоге сохранения в файл в выпадающем списке "Тип файла" появляются типы файлов, соответствующие установленным фильтрам экспорта.


TfrInterpretator object

Methods
Previous Top Next

Unit
FR_Intrp

Description
Объект представляет собой встроенный интепретатор языка управления процессом формирования отчета. В качестве языка используется диалект Pascal, со следующими возможностями:
· операторы: присваивания; if...then...else; while...do; repeat...until;
· блоки begin...end;
· бестиповые переменные;
· обращение к полям визуальных объектов FR через точечную нотацию.

В каждом визуальном объекте может быть размещен один или несколько (блок) операторов. Редактирование скрипта производится в окне редактора мемо (для того, чтобы увидеть скрипт, надо включить соответствующую галочку в верхней части окна). Скрипт выполняется каждый раз перед печатью объекта.

Для работы со скриптом объект предоставляет два метода: PrepareScript и DoScript.

В модуле FR_Class определена глобальная переменная frInterpretator типа TfrInterpretator, которая инициализируется в секции инициализации модуля и используется при построении отчета.


TfrVariables object

Properties Methods
Previous Top Next

Unit
FR_Intrp

Description
Объект предоставляет удобные средства для управления списком переменных. Переменные имеют тип Variant, т.е. фактически могут быть любого типа, совместимого с Variant.

В модуле FR_Class определена глобальная переменная frVariables типа TfrVariables, которая инициализируется в секции инициализации модуля и используется при построении отчета.


TfrParser object

Methods Events
Previous Top Next

Unit
FR_Pars

Description
В состав FastReport входит разборщик выражений (парсер). Его цель - вычислить значение вида "1 + 2 * (3 + 4)", переданное в виде строки. Он обрабатывает математические и логические выражения, операции сложения строк, внешние переменные и функции. Принцип работы основан на разборе выражений по методу обратной польской записи. Быстродействие парсера более чем достаточно для применения в критических участках кода.

Парсер имеет два свойства для подключения обработчиков событий - OnGetValue и OnGetFunction.

Парсер может использоваться и самостоятельно, без FR, для этого достаточно использовать модуль FR_Pars.


TfrDesigner component
Properties
Previous Top

Unit
FR_Desgn

Description
Компонент TfrDesigner является пустым и предназначен только для автоматического добавления модуля FR_Desgn в список uses. Все необходимые действия выполняются в секции инициализации этого модуля.

При подключении модуля FR_Desgn в системе регистрируется дизайнер отчетов. Он может быть вызван с помощью метода DesignReport объекта TfrReport. Дизайнер может понадобиться в приложениях, которые хранят отчеты не в виде ресурсов формы (файле .DFM), а во внешних файлах, и предоставляют пользователю возможность корректировки внешнего вида отчетов. Также использование дизайнера дает возможность редактирования формы построенного отчета. Если приложение не нуждается в таких возможностях, то отключение дизайнера резко уменьшает размер исполняемого модуля.


TFunctionEvent type

Top

Unit
FR_Pars

Declaration
type
TFunctionEvent = procedure(const name: String; p1, p2, p3: Variant; var val: String) of object;

Description
Тип определен для события OnFunction объекта TfrParser.


 See also

SetValue method
DoFunction method


GetValue method

See also

Applies to
TfrInterpretator object

Declaration
procedure GetValue(const Name: String; var Value: Variant); virtual;

Description
Метод вызывается, когда в выражении обнаружено обращение к внешней переменной с именем Name. Значение переменной должно быть возвращено в параметре Value.


FR_Intrp unit

Модуль содержит описания некоторых компонентов и объектов FastReport.

Objects
TfrInterpretator
TfrVariables

Variables
frInterpretator
frVariables


 See also

Name property
Variable property


Value property

See also

Applies to
TfrVariables object

Declaration
property Value[Index: Integer]: Variant;

Description
Возвращает значение переменной, имеющей порядковый номер Index в списке.


 Methods

Key methods
IndexOf
Clear
Delete


FR_E_HTM unit

Модуль содержит описания некоторых компонентов и объектов FastReport.

Components
TfrHTMExport


FR_E_RTF unit

Модуль содержит описания некоторых компонентов и объектов FastReport.

Components
TfrRTFExport


FR_E_TXT unit

Модуль содержит описания некоторых компонентов и объектов FastReport.

Components
TfrTextExport


FR_View unit

Модуль содержит описания некоторых компонентов и объектов FastReport.

Components
TfrPreview


FR_Desgn unit

Модуль содержит описания некоторых компонентов и объектов FastReport.

Components
TfrDesigner


Script property

Script field

Applies to
TfrBand object

Declaration
Script: TStringList;

Description
Скрипт бэнда.


y property

y field

See also
Top

Applies to
TfrBand object

Declaration
y: Integer;

Description
Вертикальная позиция бэнда. Измеряется в экранных пикселах, для перевода в миллиметры надо умножить на коэффициент 5/18.


 See also

x field
dx field
dy field


ColCount property

ColCount field

See also
Top

Applies to
TfrPage object

Declaration
ColCount: Integer;

Description
Количество колонок для многоколоночных отчетов.


CurBottomY property

CurBottomY field

See also
Top

Applies to
TfrPage object

Declaration
CurBottomY: Integer;

Description
Текущее значение нижней границы листа, выраженное в экранных пикселах. Актуально только в процессе построения отчета.


 See also

CurY field


CurY property

CurY field

See also
Top

Applies to
TfrPage object

Declaration
CurY: Integer;

Description
Текущее значение координаты Y, выраженное в экранных пикселах. Актуально только в процессе построения отчета.


 See also

TfrBand object
TfrPages object


pgHeight property

pgHeight field

See also
Top

Applies to
TfrPage object

Declaration
pgHeight: Integer;

Description
Высота страницы в десятых долях мм. Это поле используется, если установлен пользовательский размер страницы (pgSize = 255).


pgOr property

pgOr field

See also
Top

Applies to
TfrPage object

Declaration
pgOr: TPrinterOrientation;

Description
Ориентация листа.


 See also

pgWidth field
pgHeight field
pgSize field


pgSize property

pgSize field

See also
Top

Applies to
TfrPage object

Declaration
pgSize: Integer;

Description
Размер страницы. Используется нумерация размеров страницы, принятая в Windows. Так, формату A4 соответствует размер 9.


 See also

CurBottomY field


PrintToPrevPage property

PrintToPrevPage field

Applies to
TfrPage object

Declaration
PrintToPrevPage: WordBool;

Description
Если True, начинает печать страницы на свободном месте предыдущего листа.


 See also

pgMargins field


Create method

Applies to
TfrPage object

Declaration
constructor Create(ASize, AWidth, AHeight: Integer; AOr: TPrinterOrientation);

Description
Создает страницу с заданным размером (если размер листа = 255 - пользовательский формат - то ширина и высота листа задается в параметрах AWidth и AHeight). Параметр AOr определяет ориентацию листа.


 See also

pgWidth field
pgHeight field
pgOr field


Clear method

Applies to
TfrPage object

Declaration
procedure Clear;

Description
Очищает страницу (удаляет все объекты, расположенные на ней).


Delete method

Applies to
TfrPage object

Declaration
procedure Delete(Index: Integer);

Description
Удаляет объект, имеющий порядковый номер Index в списке объектов.


NewPage method

Applies to
TfrPage object

Declaration
procedure NewPage;

Description
Формирует новую страницу. Эта процедура должна применяться только в обработчике события TfrReport.OnManualBuild.


FindObject method

See also

Applies to
TfrPage object

Declaration
function FindObject(Name: String): TfrView;

Description
Ищет объект с именем Name в списке объектов на странице. Если объект не найден, возвращает nil.


ShowBandByType method

See also Example

Applies to
TfrPage object

Declaration
procedure ShowBandByType(bt: TfrBandType);

Description
Печатает бэнд, имеющий тип bt. Эта процедура должна применяться только в обработчике события TfrReport.OnManualBuild.


 See also

TfrPage object


 Properties

Key properties
Count
Pages


 Methods

Key methods
Add
Clear
Delete


ShowBandByName method

See also Example

Applies to
TfrPage object

Declaration
procedure ShowBandByName(s: String);

Description
Печатает бэнд с именем s. Эта процедура должна применяться только в обработчике события TfrReport.OnManualBuild.


Add method

Applies to
TfrPages object

Declaration
procedure Add;

Description
Добавляет новую страницу формата А4 в список. При необходимости формат можно поменять вызовом метода TfrPage.ChangePaper.


 Properties

Key properties
Count


 Methods

Key methods
Add
Clear
Delete
Insert


Count property

Applies to
TfrPages object

Declaration
property Count: Integer;

Description
Количество страниц в списке.


Add method

Applies to
TfrEMFPages object

Declaration
procedure Add(APage: TfrPage);

Description
Добавляет страницу в список. Параметры страницы устанавливаются на основе страницы APage.


 See also

TfrCompositeReport component


 Properties

Run-time only [image] Key properties
Dataset
DefaultCollate
DefaultCopies
Dictionary
EMFPages
GrayedButtons
MDIPreview
MixVariablesAndDBFields
ModalPreview
Modified
Pages
Preview
ReportType
ShowProgress
StoreInDFM
Title


Count property

Applies to
TfrEMFPages object

Declaration
property Count: Integer;

Description
Количество страниц в списке.


GetVariableValue method

Applies to
TfrReport component

Declaration
procedure GetVariableValue(const s: String; var v: Variant);

Description
Возвращает значение переменной s в параметре v.


 See also

LoadFromDB method
LoadFromStream method


LoadFromStream method

See also

Applies to
TfrReport component

Declaration
procedure LoadFromStream(Stream: TStream);

Description
Считывает содержимое документа из потока.


 See also

LoadFromDB method
LoadFromFile method


EditPreparedReport method

Applies to
TfrReport component

Declaration
procedure EditPreparedReport(PageIndex: Integer);

Description
Запускает дизайнер для редактирования страницы PageIndex построенного отчета. Если проект скомпилирован без использования дизайнера, этот метод ничего не делает. Предполагается, что отчет был построен ранее вызовом метода PrepareReport либо загружен из файла методом LoadPreparedReport.


 See also

SaveTemplate method


SaveTemplate method

See also

Applies to
TfrReport component

Declaration
procedure SaveTemplate(fname: String; comm: TStrings; Bmp: TBitmap);

Description
Записывает форму документа как шаблон с именем fname. Комментарий и рисунок к шаблону передаются в виде параметров comm и Bmp. Расширение файла должно быть .frt (FastReport Template).


 See also

LoadTemplate method


SaveToDB method

See also

Applies to
TfrReport component

Declaration
procedure SaveToDB(Table: TDataSet; DocN: Integer);

Description
Записывает содержимое документа в таблицу БД под номером DocN. Структура таблицы простая: первое поле целое - это номер документа, а второе - типа BLOb - форма документа.


LoadPreparedReport method

See also

Applies to
TfrReport component

Declaration
procedure LoadPreparedReport(FName: String);

Description
Считывает содержимое ранее построенного отчета из файла с именем FName. Расширение файла должно быть .frp (FastReport Prepared report).


SaveToStream method

See also

Applies to
TfrReport component

Declaration
procedure SaveToStream(Stream: TStream);

Description
Записывает содержимое документа в поток.


ShowReport method

See also

Applies to
TfrReport component

Declaration
procedure ShowReport;

Description
Запускает построение отчета и его преварительный просмотр. После закрытия окна предварительного просмотра построенный отчет разрушается.


 See also

PrepareReport method
ShowPreparedReport method


OnBeginColumn event

Applies to
TfrReport component

Declaration
property OnBeginColumn: TBeginColumnEvent;

Description
Обработчик события вызывается при формировании отчета с переменным количеством столбцов. Параметр Band показывает, для какого бэнда в данный момент строится многоколоночная часть. Обработчик может быть полезен для переключения источника данных (т.к. многоколоночная часть может иметь заголовок, данные первого уровня, второго и пр., для которых используются разные источники данных).


 See also

SaveToFile method
SaveToStream method


 See also

OnEndPage event


 See also

OnBeginPage event


OnBeforePrint event

Example

Applies to
TfrReport component

Declaration
property OnBeforePrint: TEnterRectEvent;

Description
Обработчик события вызывается перед отображением каждого объекта. Ссылка View позволяет манипулировать свойствами объекта. Это событие наиболее часто применяется для загрузки картинки из файла в объект TfrPictureView.


 OnBeforePrint event example

procedure TForm1.frReport1BeforePrint(Memo: TStringList; View: TView);
begin
  if Memo.Count > 0 then
    if Memo[0] = '[Memo]' then
      Memo.Assign(Table1Memo)
    else if (Memo[0] = '[Picture]') and (View is TPictureView) then
     (View as TPictureView).Picture.Assign(Table1Picture);
end;


OnBeginDoc event

See also

Applies to
TfrReport component

Declaration
property OnBeginDoc: TBeginDocEvent;

Description
Обработчик события вызывается перед началом формирования отчета.


 OnManualBuild event example

procedure TForm1.frReport1ManualBuild(Page: TfrPage);
begin
  with Page do
  begin
    ShowBandByType(btReportTitle);
    ShowBandByName('Band1');
    ShowBandByName('Band1');
    ShowBandByName('Band2');
    NewPage;
    ShowBandByName('Band1');
    ShowBandByType(btReportSummary);
  end;
end;


 See also

<<< See also of TfrCompositeReport component >>>


 Properties

Run-time only [image] Key properties
EMFPages
GrayedButtons
ModalPreview
Reports
ShowProgress
Title


OnGetValue event

Example

Applies to
TfrReport component

Declaration
property OnGetValue: TDetailEvent;

Description
Обработчик события вызывается, если в тексте обнаружена переменная ParName. Значение переменной должно быть помещено в ParValue.


 Methods

Key methods
PrepareReport
EditPreparedReport
ExportTo
LoadPreparedReport
PrintPreparedReport
SavePreparedReport
ShowPreparedReport
ShowReport


OnFunction method

Applies to
TfrFunctionLibrary object

Declaration
function OnFunction(const FName: String; p1, p2, p3: Variant; var val: String): Boolean;

Description
Метод просматривает список List на наличие функции FName. Если функция найдена, она обрабатывается методом DoFunction.


DoFunction method

Example

Applies to
TfrFunctionLibrary object

Declaration
procedure DoFunction(FNo: Integer; p1, p2, p3: Variant; var val: String); virtual; abstract;

Description
Выполняет функцию с порядковым номером FNo в списке List.


 DoFunction method example

Это фрагмент метода DoFunction стандартной библиотеки функций TfrStdFunctionLibrary:

procedure TfrStdFunctionLibrary.DoFunction(FNo: Integer; p1, p2, p3: Variant;
  var val: String);
var
  ...
begin
  case FNo of
// AVG
    0: dk := dkAvg;
// COUNT
    1: dk := dkCount;
// FORMATDATETIME
    2: val := '''' + FormatDateTime(Parser.Calc(p1), Parser.Calc(p2)) + '''';
// FORMATFLOAT
    3: val := '''' + FormatFloat(Parser.Calc(p1), Parser.Calc(p2)) + '''';
// INPUT
    4:
      begin
        s1 := InputBox('', Parser.Calc(p1), Parser.Calc(p2));
        val := '''' + s1 + '''';
      end;
// LOWERCASE
    5: val := '''' + AnsiLowerCase(Parser.Calc(p1)) + '''';
// MAX
    6: dk := dkMax;
// MIN
    7: dk := dkMin;
// NAMECASE
    8:
      begin
        s1 := AnsiLowerCase(Parser.Calc(p1));
        if Length(s1) > 0 then
          val := '''' + AnsiUpperCase(s1[1]) + Copy(s1, 2, Length(s1) - 1) + ''''
        else
          val := '''' + '''';
      end;
// STRTODATE
    9: val := '%d''' + Parser.Calc(p1) + '''';
// STRTOTIME
    10: val := '%t''' + Parser.Calc(p1) + '''';
// SUM
    11: dk := dkSum;
// UPPERCASE
    12: val := '''' + AnsiUpperCase(Parser.Calc(p1)) + '''';
  end;
  ...
end;


 See also

OnManualBuild event


frRegisterExportFilter procedure

Unit
FR_Class

Declaration
procedure frRegisterExportFilter(ClassRef: TClass; const FilterDesc, FilterExt: String);

Description
Регистрирует в системе фильтр экспорта.


frRegisterFunctionLibrary procedure

Unit
FR_Class

Declaration
procedure frRegisterFunctionLibrary(ClassRef: TClass);

Description
Регистрирует в системе библиотеку функций.


frRegisterObject procedure

Unit
FR_Class

Declaration
procedure frRegisterObject(ClassRef: TClass; ButtonBmp: TBitmap; const ButtonHint: String; EditorForm: TfrObjEditorForm);

Description
Регистрирует в системе визуальный объект.


TfrRgnType type

See also

Unit
FR_Class

Declaration
type
TfrRgnType = (rtNormal, rtExtended);

Description
Возможные типы регионов для функции GetClipRGN.


 Methods

Key methods
Compress
DeCompress


frRegisterTool procedure

Unit
FR_Class

Declaration
procedure frRegisterTool(MenuCaption: String; ButtonBmp: TBitmap; OnClick: TNotifyEvent);

Description
Регистрирует в системе мастер. Мастер - это Add-in, подключаемый к дизайнеру.


DataSet property

DataSet field

See also
Top

Applies to
TfrBand object

Declaration
DataSet: TfrDataSet;

Description
Источник данных бэнда. Только для дата-бэндов.


dy property

dy field

See also
Top

Applies to
TfrBand object

Declaration
dy: Integer;

Description
Высота бэнда. Измеряется в экранных пикселах, для перевода в миллиметры надо умножить на коэффициент 5/18.


 See also

x field
y field
dx field


Memo property

Memo field

Applies to
TfrBand object

Declaration
Memo: TStringList;

Description
Мемо бэнда.


StoreInDFM property

Applies to
TfrReport component

Declaration
property StoreInDFM: Boolean;

Description
Определяет способ хранения формы отчета. Если True, то форма отчета сохраняется в DFM-файле, как это делается во всех распространенных генераторах отчетов. По умолчанию это свойство имеет значение False.


PrepareReport method

See also

Applies to
TfrReport component

Declaration
function PrepareReport: Boolean;

Description
Запускает построение отчета. Если пользователь прервал процесс, возвращает ложь.


 See also

ShowReport method


DesignReport method

Applies to
TfrReport component

Declaration
procedure DesignReport;

Description
Запускает дизайнер. Если проект скомпилирован без использования дизайнера, этот метод ничего не делает.


 Pages property example

Пример устанавливает количество колонок на первой странице = 2.

frReport1.Pages[0].ColCount := 2;


 See also

OnBeforePrint event


 See also

Highlight field


TfrReportType type

See also

Unit
FR_Class

Declaration
type
TfrReportType = (rtSimple, rtMultiple);

Description
Возможные типы отчета.


 See also

ReportType property


TEndPageEvent type

See also

Unit
FR_Class

Declaration
type
TEndPageEvent = procedure(pg: Integer) of object;

Description
Тип определен для события OnEndPage компонента TfrReport.


Pages property

See also

Applies to
TfrPages object

Declaration
property Pages[Index: Integer]: TfrPage;

Description
Список страниц.


Clear method

Applies to
TfrPages object

Declaration
procedure Clear;

Description
Очищает список страниц.


Delete method

Applies to
TfrPages object

Declaration
procedure Delete(Index: Integer);

Description
Удаляет страницу с индексом Index из списка.


ReportType property

Applies to
TfrReport component

Declaration
property ReportType: TfrReportType;

Description
Тип отчета. При значении rtMultiple используется источник данных Dataset и отчет строится для каждой записи из этого источника. Эта возможность особенно удобна для печати многостраничных бланков.
По умолчанию значение свойства rtSimple.


Title property

Applies to
TfrReport component

Declaration
property Title: String;

Description
Заголовок отчета. Показывается в окне прогресса, в окне предварительного просмотра и присваивается печатаемому документу.


FindObject method

See also

Applies to
TfrReport component

Declaration
function FindObject(Name: String): TfrView;

Description
Возвращает ссылку на объект с именем Name.


 See also

TfrPage.FindObject method


Preview property

Applies to
TfrReport component

Declaration
property Preview: TfrPreview;

Description
Ссылка на объект - компонент предварительного просмотра. Если это свойство пустое, предварительный просмотр отчета будет выполняться в стандартном окне. Иначе отчет будет показан в компоненте.


Highlight property

Highlight field

See also
Top

Applies to
TfrMemoView object

Declaration
Highlight: TfrHighlightAttr;

Description
Атрибуты выделения. Объект выводится с использованием этих атрибутов, если условие выделения HighlightStr истинно.


 See also

HighlightStr field


HighlightStr property

HighlightStr field

See also
Top

Applies to
TfrMemoView object

Declaration
HighlightStr: String;

Description
Условие выделения.


FR_Class unit

Модуль содержит описания некоторых компонент и объектов FastReport.

Components
TfrReport
TfrCompositeReport
TfrExportFilter

Objects
TfrView
TfrMemoView
TfrBandView
TfrSubReportView
TfrPictureView
TfrLineView
TfrBand
TfrPage
TfrPages
TfrEMFPages
TfrFunctionLibrary
TfrDataDictionary
TfrLocale

Types
TBeginColumnEvent
TBeginDocEvent
TBeginPageEvent
TDetailEvent
TEndDocEvent
TEndPageEvent
TEnterRectEvent
TfrBandType
TfrHighlightAttr
TfrReportType
TfrRgnType
TManualBuildEvent
TProgressEvent
TAfterExportEvent
TBeforeExportEvent
TfrDocMode
TfrPageType
TfrPrintPages
TLocalizeEvent
TMouseOverObjectEvent
TObjectClickEvent
TPrintReportEvent

Routines
frCreateObject
frRegisterExportFilter
frRegisterFunctionLibrary
frRegisterObject
frRegisterTool
frLocale
frAddFunctionDesc

Constants
baBottom
baCenter
baLeft
baNone
baRight
baWidth
flBandPrintChildIfInvisible
flHideZeros
flSuppressRepeated
flTextOnly
flUnderlines
flBandNewPageAfter
flBandOnFirstPage
flBandOnLastPage
flBandPageBreak
flBandPrintifSubsetEmpty
flBandRepeatHeader
flPictCenter
flPictRatio
flStretched
flWantHook
flWordBreak
flWordWrap
frCurrentVersion
gtAddIn
gtBand
gtLine
gtMemo
gtPicture
gtSubReport
frrfDontDelete
frrfDontEditContents
frrfDontEditMemo
frrfDontEditScript
frrfDontModify
frrfDontMove
frrfDontSize

Variables
CurBand
CurPage
CurReport
CurView
DisableDrawing
DocMode
frDataManager
frDesigner
frParser
frInterpretator
frVariables
frVersion
MasterReport
PageNo
frConsts


 See also

TfrMemoView object
TfrBandView object
TfrSubReportView object
TfrPictureView object
TfrLineView object


 Properties

Key properties
BandAlign
dx
dy
FillColor
Flags
Format
FormatStr
FrameColor
FrameTyp
FrameWidth
gapx
gapy
HVersion
IsPrinting
LVersion
Memo
Name
OffsX
OffsY
Parent
Restrictions
ScaleX
ScaleY
Script
Selected
Tag
Typ
Visible
x
y


 Methods

Key methods
GetClipRgn
Assign
CreateUniqueName
DefinePopupMenu
Draw
ExportData
LoadFromStream
StreamOut
SaveToStream
SetBounds
ShowEditor


dx property

dx field

See also
Top

Applies to
TfrView object

Declaration
dx: Integer;

Description
Ширина объекта. Измеряется в экранных пикселах, для перевода в миллиметры надо умножить на коэффициент 5/18.


 See also

x field
y field
dy field


dy property

dy field

See also
Top

Applies to
TfrView object

Declaration
dy: Integer;

Description
Высота объекта. Измеряется в экранных пикселах, для перевода в миллиметры надо умножить на коэффициент 5/18.


gapx property

Applies to
TfrView class

Declaration
property gapx: Integer;

Description
Отступ текста слева от рамки объекта.
Run-time only


BandAlign property

Applies to
TfrView class

Declaration
property BandAlign: Byte;

Description
Выравнивание объекта относительно его бэнда. Одно из значений frbaXXXX:

baNone = 0; //Выводить объект без выравнивания по бэнду.
baLeft = 1; //Прижать объект к левому краю бэнда.
baRight = 2; //Прижать объект к правому краю бэнда.
baCenter = 3; //Центрировать объект внутри бэнда по горизонтали.
baWidth = 4; //Растянуть объект по ширине бэнда.
baBottom = 5; //Прижать объект к нижнему краю бэнда.


HVersion property

Applies to
TfrView class

Declaration
property HVersion: Byte;

Description
Версия компонента. Старшая часть (HVersion) фиксирована и изменению не подлежит. Младшую часть (LVersion) можно менять перед записью объекта в поток (перед вызовом inherited SaveToStream). Версию надо менять при изменениях в свойствах объекта (например, при добавлении новых свойств, изменении формата или удалении старых свойств). Проверку на номер версии надо делать в методе LoadFromStream.
Run-time only


gapy property

Applies to
TfrView class

Declaration
property gapy: Integer;

Description
Отступ текста сверху от рамки объекта.
Run-time only


Restrictions property

Applies to
TfrView class

Declaration
property Restrictions: Word;

Description
Набор флагов, запрещающих те или иные действия над объектом в режиме дизайнера. Например, можно запретить удаление или перемещение объекта.

frrfDontEditMemo = 1; //Запретить редактировать мемо объекта.
frrfDontEditScript = 2; //Запретить редактировать скрипт объекта.
frrfDontEditContents = 4; //Запретить вызов редактора объекта.
frrfDontModify = 8; //Запретить модификацию объекта (например, смену шрифта).
frrfDontSize = 16; //Запретить изменение размеров объекта.
frrfDontMove = 32; //Запретить сдвигать объект.
frrfDontDelete = 64; //Запретить удалять объект.


LVersion property

Applies to
TfrView class

Declaration
property LVersion: Byte;

Description
Версия компонента. Старшая часть (HVersion) фиксирована и изменению не подлежит. Младшую часть (LVersion) можно менять перед записью объекта в поток (перед вызовом inherited SaveToStream). Версию надо менять при изменениях в свойствах объекта (например, при добавлении новых свойств, изменении формата или удалении старых свойств). Проверку на номер версии надо делать в методе LoadFromStream.
Run-time only


ShowEditor method

Applies to
TfrView class

Declaration
procedure ShowEditor; virtual;

Description
Метод вызывается при редактировании содержимого объекта. Метод должен вызвать диалоговое окно редактора объекта.


Tag property

Applies to
TfrView class

Declaration
property Tag: String;

Description
Идентификатор объекта. Строка, которая может содержать переменные. Это свойство нужно для поддержки "живых отчетов", когда в окне preview пользователь может нажать на объект и при этом выполнится какое-либо действие (например, построится другой отчет). Цель свойства - облегчить распознавание нажатого объекта. Например, объект может содержать текст "12.25р", по которому идентификация невозможна. Но в свойство Tag можно поместить более развернутую информацию, например, значение ключа таблицы, из которой был получен текст "12.25р", номер строки или колонки в отчете, и пр.
Run-time only


ColumnGap property

Applies to
TfrBandView class

Declaration
property ColumnGap: Integer;

Description
Промежуток между колонками бэнда в пикселах.
Run-time only


ChildBand property

Applies to
TfrBandView class

Declaration
property ChildBand: String;

Description
Имя бэнда, который будет выведен после основного бэнда. Аналогично childband в QuickReport.
Run-time only


ColumnWidth property

Applies to
TfrBandView class

Declaration
property ColumnWidth: Integer;

Description
Ширина колонки бэнда.
Run-time only


Columns property

Applies to
TfrBandView class

Declaration
property Columns: Integer;

Description
Задает количество колонок у бэнда. При этом содержимое бэнда будет выводиться слева направо и сверху вниз.
Run-time only


.topic 1010

Unit
FR_Chart

Description
Компонент TfrChartObject является пустым и предназначен только для автоматического добавления модуля FR_Chart в список uses. Все необходимые действия выполняются в секции инициализации этого модуля. См. TfrChartView object

This help file was created with HelpScribble.

.topic 1100

Unit
FR_Chart

Description
Объект "Диаграмма". Предназначен для вставки графика или диаграммы в документ. Возможно использование шести типов графиков: линии, точки, столбцы горизонтальные и вертикальные, области и круговые диаграммы.

Для использования этого объекта в run-time следует использовать компонент TfrChartObject из палитры компонентов FR. Если открываемый отчет содержит неподключенные компоненты, то выдастся сообщение об ошибке.

Доступен в Delphi 3 и выше. Для использования в Delphi 2 необходимо установить компонент TeeChart для Delphi 2, затем исправить строку в подключаемом файле FR.inc и перекомпилировать библиотеку FR.

This help file was created with HelpScribble.

.topic 2010

Unit
FR_ChBox

Description
Компонент TfrCheckBoxObject является пустым и предназначен только для автоматического добавления модуля FR_ChBox в список uses. Все необходимые действия выполняются в секции инициализации этого модуля. См. TfrCheckBoxView object

This help file was created with HelpScribble.

.topic 2100

Unit
FR_ChBox

Description
Объект "CheckBox". Представляет собой прямоугольник с крестиком внутри. Если в мемо объекта разместить ссылку на переменную либо на поле таблицы БД, то крестик будет показан при ненулевом значении переменной. В мемо можно также разместить символ "0" либо отличный от нуля.

Для использования этого объекта в run-time следует использовать компонент TfrCheckBoxObject из палитры компонентов FR. Если открываемый отчет содержит неподключенные компоненты, то выдастся сообщение об ошибке.

This help file was created with HelpScribble.

.topic 3010

Unit
FR_OLE

Description
Компонент TfrOLEObject является пустым и предназначен только для автоматического добавления модуля FR_OLE в список uses. Все необходимые действия выполняются в секции инициализации этого модуля. См. TfrOLEView object

This help file was created with HelpScribble.

.topic 3100

Unit
FR_OLE

Description
Объект "OLE". Предназначен для вставки OLE объектов в документ.

Для использования этого объекта в run-time следует использовать компонент TfrOLEObject из палитры компонентов FR. Если открываемый отчет содержит неподключенные компоненты, то выдастся сообщение об ошибке.

This help file was created with HelpScribble.

.topic 4010

Unit
FR_Rich

Description
Компонент TfrRichObject является пустым и предназначен только для автоматического добавления модуля FR_Rich в список uses. Все необходимые действия выполняются в секции инициализации этого модуля. См. TfrRichView object

This help file was created with HelpScribble.

.topic 4100

Unit
FR_Rich

Description
Объект "RichText". Предназначен для вставки текста в формате RTF (Rich Text Format) в документ.

Для использования этого объекта в run-time следует использовать компонент TfrRichObject из палитры компонентов FR. Если открываемый отчет содержит неподключенные компоненты, то выдастся сообщение об ошибке.

This help file was created with HelpScribble.

.topic 5010

Unit
FR_Shape

Description
Компонент TfrRichObject является пустым и предназначен только для автоматического добавления модуля FR_Rich в список uses. Все необходимые действия выполняются в секции инициализации этого модуля. См. TfrRichView object

This help file was created with HelpScribble.

.topic 5100

Unit
FR_Shape

Description
Объект "Фигура". Предназначен для вставки геометрических фигур (прямоугольник, прямоугольник с закругленными углами, эллипс, треугольник) в документ.

Для использования этого объекта в run-time следует использовать компонент TfrShapeObject из палитры компонентов FR. Если открываемый отчет содержит неподключенные компоненты, то выдастся сообщение об ошибке.

This help file was created with HelpScribble.

.topic 20030

Unit
FR_Class

Description
Базовый объект. Все визуальные объекты FastReport наследуются от него.

This help file was created with HelpScribble.

.topic 20610

Unit
FR_Class

Description
Объект "Текст". Представляет собой произвольным образом обрамленный прямоугольник с многострочным  текстом внутри. Задается цвет текста/заливка, тип рамки, толщина  рамки и цвет, все параметры шрифта текста, выравнивание текста внутри прямоугольника и ориентация текста (норм./90 градусов). В мемо объекта можно поместить многострочный текст с переменными.

This help file was created with HelpScribble.

.topic 20790

Unit
FR_Class

Description
Объект "Секция" (бэнд). Предназначен для вставки секции в документ.

This help file was created with HelpScribble.

.topic 20860

Unit
FR_Class

Description
Объект "Вложенный отчет". Вложенный отчет - это отчет с размещенным на нем объектом SubReport, который   представляет собой ссылку на другой отчет, расположенный на отдельной странице. При формировании такого отчета вместо объекта SubReport будет выведен соответствующий отчет.

This help file was created with HelpScribble.

.topic 20910

Unit
FR_Class

Description
Объект "Рисунок". Предназначен для вставки графического файла в формате BMP/WMF/ICO (и JPG, если установлен соответствующий модуль) в документ.

This help file was created with HelpScribble.

.topic 20960

Unit
FR_Class

Description
Объект "Линия". Представляет собой вертикальную либо горизонтальную линию с изменяемым цветом и толщиной.

This help file was created with HelpScribble.

.topic 21000

Unit
FR_Class

Description
Объект преставляет собой бэнд в режиме построения отчета. В режиме дизайнера бэнд представлен объектом TfrBandView и предназначен только для отображения в дизайнере. Перед началом построения содержимое объектов TfrBandView копируется в объекты TfrBand. Объект TfrBand содержит список принадлежащих ему визуальных объектов Objects и источник данных DataSet (только для дата-бэндов).

This help file was created with HelpScribble.

.topic 21190

Unit
FR_Class

Description
Объект представляет собой страницу в режиме дизайнера. Содержит параметры страницы и список визуальных объектов, расположенных на странице. В режиме построения отчета предоставляет методы управления процессом построения ShowBandByName, ShowBandByType, NewPage.

This help file was created with HelpScribble.

.topic 21660

Unit
FR_Class

Description
Объект представляет собой список страниц отчета (под страницей подразумевается страница в режиме дизайнера). Содержит набор методов для управления списком.

This help file was created with HelpScribble.

.topic 21760

Unit
FR_Class

Description
Объект представляет собой список страниц построенного отчета. Содержит набор методов для управления списком.

This help file was created with HelpScribble.

.topic 21870

Unit
FR_Class

Description
Компонент является ядром FastReport. Он содержит все необходимые методы для хранения, построения, предварительного просмотра, экспорта и печати отчета.

Свойство Pages предоставляет доступ к страницам формы отчета. Свойство EMFPages позволяет обращаться к страницам сформированного отчета.

Группа методов LoadFromStream, SaveToStream, LoadFromFile, SaveToFile, LoadFromDB, SaveToDB предназначена для считывания/записи документа, шаблона документа (LoadTemplate, SaveTemplate) и сформированного отчета (LoadPreparedReport, SavePreparedReport).

Метод DesignReport запускает дизайнер, если он используется в проекте.

Методы PrepareReport и ShowReport выполняют построение отчета (ShowReport после этого показывает отчет в окне предварительного просмотра).

Метод PrintPreparedReport печатает отчет, метод ExportTo выполняет экспорт отчета с использованием фильтра экспорта.

This help file was created with HelpScribble.

.topic 22570

Unit
FR_Class

Description
Компонент представляет собой композитный (составной) отчет и предназначен для "склеивания" нескольких отчетов в один. Для этого программно заполняется список Reports ссылками на нужные объекты TfrReport.

This help file was created with HelpScribble.

.topic 22820

Unit
FR_Class

Description
Объект представляет собой библиотеку функций. Каждый раз, когда встроенный парсер выражений обнаруживает вызов внешней функции, функция ищется в подключенных библиотеках.

This help file was created with HelpScribble.

.topic 8010

Unit
FR_DSet

Description
Объект, предназначенный для навигации по набору данных. Является базовым для компонентов TfrDBDataSet, TfrUserDataSet.

This help file was created with HelpScribble.

.topic 8100

Unit
FR_DSet

Description
Представляет собой пользовательский набор данных. Компонент особенно удобен для навигации по таким объектам, как массив, файл данных, содержимое TStringGrid и пр. Для навигации по такому набору надо определить обработчики событий OnFirst, OnNext, OnCheckEOF компонента. В большинстве случаев можно просто указать диапазон навигации с помощью свойств RangeBegin, RangeEnd, RangeEndCount. Текущая позиция указателя доступна с помощью свойства RecNo.

This help file was created with HelpScribble.

.topic 9010

Unit
FR_DBSet

Description
Компонент предназначен для навигации по набору данных, основанному на таблице БД. Для связи с таблицей служит свойство DataSource, которое подключается к связке TDataSource -> TDataSet. В качестве TDataSet может выступать любой его потомок (TTable, TQuery и пр).

This help file was created with HelpScribble.

.topic 10010

Unit
FR_E_CSV

Description
При использовании компонента в системе регистрируется фильтр экспорта в формат .CSV. Фильтр можно вызвать из окна предварительного просмотра, выполнив команду "Сохранить в файл". При этом в стандартном диалоге сохранения в файл в выпадающем списке "Тип файла" появляются типы файлов, соответствующие установленным фильтрам экспорта.

This help file was created with HelpScribble.

.topic 11010

Unit
FR_E_HTM

Description
При использовании компонента в системе регистрируется фильтр экспорта в формат .HTM (файлы HTML). Фильтр можно вызвать из окна предварительного просмотра, выполнив команду "Сохранить в файл". При этом в стандартном диалоге сохранения в файл в выпадающем списке "Тип файла" появляются типы файлов, соответствующие установленным фильтрам экспорта.

This help file was created with HelpScribble.

.topic 12010

Unit
FR_E_RTF

Description
При использовании компонента в системе регистрируется фильтр экспорта в формат .RTF. Фильтр можно вызвать из окна предварительного просмотра, выполнив команду "Сохранить в файл". При этом в стандартном диалоге сохранения в файл в выпадающем списке "Тип файла" появляются типы файлов, соответствующие установленным фильтрам экспорта.

This help file was created with HelpScribble.

.topic 13010

Unit
FR_E_TXT

Description
При использовании компонента в системе регистрируется фильтр экспорта в формат .TXT. Фильтр можно вызвать из окна предварительного просмотра, выполнив команду "Сохранить в файл". При этом в стандартном диалоге сохранения в файл в выпадающем списке "Тип файла" появляются типы файлов, соответствующие установленным фильтрам экспорта.

This help file was created with HelpScribble.

.topic 14010

Unit
FR_Intrp

Description
Объект представляет собой встроенный интепретатор языка управления процессом формирования отчета. В качестве языка используется диалект Pascal, со следующими возможностями:
·		операторы: присваивания; if...then...else; while...do; repeat...until;
·		блоки begin...end;
·		бестиповые переменные;
·		обращение к полям визуальных объектов FR через точечную нотацию.

В каждом визуальном объекте может быть размещен один или несколько (блок) операторов. Редактирование скрипта производится в окне редактора мемо (для того, чтобы увидеть скрипт, надо включить соответствующую галочку в верхней части окна). Скрипт выполняется каждый раз перед печатью объекта.

Для работы со скриптом объект предоставляет два метода: PrepareScript и DoScript.

В модуле FR_Class определена глобальная переменная frInterpretator типа TfrInterpretator, которая инициализируется в секции инициализации модуля и используется при построении отчета.

This help file was created with HelpScribble.

.topic 14100

Unit
FR_Intrp

Description
Объект предоставляет удобные средства для управления списком переменных. Переменные имеют тип Variant, т.е. фактически могут быть любого типа, совместимого с Variant.

В модуле FR_Class определена глобальная переменная frVariables типа TfrVariables, которая инициализируется в секции инициализации модуля и используется при построении отчета.

This help file was created with HelpScribble.

.topic 15010

Unit
FR_Pars

Description
В состав FastReport входит разборщик выражений (парсер). Его цель - вычислить значение вида "1 + 2 * (3 + 4)", переданное в виде строки. Он обрабатывает математические и логические выражения, операции сложения строк, внешние переменные и функции. Принцип работы основан на разборе выражений по методу обратной польской записи. Быстродействие парсера более чем достаточно для применения в критических участках кода.

Парсер имеет два свойства для подключения обработчиков событий - OnGetValue и OnGetFunction.

Парсер может использоваться и самостоятельно, без FR, для этого достаточно использовать модуль FR_Pars.

This help file was created with HelpScribble.

.topic 24010

Unit
FR_Desgn

Description
Компонент TfrDesigner является пустым и предназначен только для автоматического добавления модуля FR_Desgn в список uses. Все необходимые действия выполняются в секции инициализации этого модуля.

При подключении модуля FR_Desgn в системе регистрируется дизайнер отчетов. Он может быть вызван с помощью метода DesignReport объекта TfrReport. Дизайнер может понадобиться в приложениях, которые хранят отчеты не в виде ресурсов формы (файле .DFM), а во внешних файлах, и предоставляют пользователю возможность корректировки внешнего вида отчетов. Также использование дизайнера дает возможность редактирования формы построенного отчета. Если приложение не нуждается в таких возможностях, то отключение дизайнера резко уменьшает размер исполняемого модуля.

This help file was created with HelpScribble.

.topic 1000

Модуль содержит описания некоторых компонентов и объектов FastReport.

Components
TfrChartObject

Objects
TfrChartView

Types
TChartOptions

This help file was created with HelpScribble.

.topic 1011
See also

TfrChartView object

This help file was created with HelpScribble.

.topic 1101
See also

TfrChartObject component
TfrView object

This help file was created with HelpScribble.

.topic 1102
Properties

  Key properties
                 ChartOptions
                dx
                dy
                FillColor
                Flags
                Format
                FormatStr
                FrameColor
                FrameTyp
                FrameWidth
                IsPrinting
                 LegendObj
                Memo
                Name
                OffsX
                OffsY
                Parent
                ScaleX
                ScaleY
                Script
                Selected
                 Top10Label
                Typ
                 ValueObj
                Visible
                x
                y

This help file was created with HelpScribble.

.topic 1103
Methods

  Key methods
                GetClipRgn
                Assign
                CreateUniqueName
                DefinePopupMenu
                Draw
                ExportData
                LoadFromStream
                Print
                SaveToStream
                SetBounds

This help file was created with HelpScribble.

.topic 1110

Applies to
TfrChartView object

Declaration
ChartOptions: TChartOptions;

Description
Опции диаграммы.

This help file was created with HelpScribble.

.topic 1115

Applies to
TfrChartView object

Declaration
LegendObj: String;

Description
Имя объекта, содержимое которого будет использовано как подпись к диаграмме. Для построения диаграммы необходимо указать имена двух объектов типа "Текст", в которых содержится название и соответствующее числовое значение. При построении отчета содержимое этих объектов будет накапливаться в мемо диаграммы.

This help file was created with HelpScribble.

.topic 1120

Applies to
TfrChartView object

Declaration
Top10Label: String;

Description
Подпись для диаграммы типа "Top10". Обычно используется слово "Другие".

This help file was created with HelpScribble.

.topic 1125

Applies to
TfrChartView object

Declaration
ValueObj: String;

Description
Имя объекта, содержимое которого будет использовано как значения диаграммы. Для построения диаграммы необходимо указать имена двух объектов типа "Текст", в которых содержится название и соответствующее числовое значение. При построении отчета содержимое этих объектов будет накапливаться в мемо диаграммы.

This help file was created with HelpScribble.

.topic 1200

Unit
FR_Chart

Declaration
type
  TChartOptions = packed record
    ChartType: Byte;
    Dim3D, IsSingle, ShowLegend, ShowAxis, ShowMarks, Colored: Boolean;
    MarksStyle: Byte;
    Top10Num: Integer;
    Reserved: Array[0..35] of Byte;
  end;

Description
Опции диаграммы:
·		ChartType - тип диаграммы - одно из шести значений (0..5) - линии, точки, столбцы горизонтальные и вертикальные, области и круговые диаграммы;
·		Dim3D - объемность;
·		IsSingle - одиночная диаграмма;
·		ShowLegend - показывать сноску;
·		ShowAxis - показывать оси;
·		ShowMarks - показывать пометки;
·		Colored - разноцветная диаграмма;
·		MarksStyle - тип пометок;
·		Top10Num - количество отображаемых значений в диаграмме типа "Top10". Если это поле равно 0, то строится обычная (не Top10) диаграмма;
·		Reserved - резервное поле.

This help file was created with HelpScribble.

.topic 2000

Модуль содержит описания некоторых компонентов и объектов FastReport.

Components
TfrCheckBoxObject

Objects
TfrCheckBoxView

This help file was created with HelpScribble.

.topic 2011
See also

TfrCheckBoxView object

This help file was created with HelpScribble.

.topic 2101
See also

TfrCheckBoxObject component
TfrView object

This help file was created with HelpScribble.

.topic 2102
Properties

  Key properties
                dx
                dy
                FillColor
                Flags
                Format
                FormatStr
                FrameColor
                FrameTyp
                FrameWidth
                IsPrinting
                Memo
                Name
                OffsX
                OffsY
                Parent
                ScaleX
                ScaleY
                Script
                Selected
                Typ
                Visible
                x
                y

This help file was created with HelpScribble.

.topic 2103
Methods

  Key methods
                GetClipRgn
                Assign
                CreateUniqueName
                DefinePopupMenu
                Draw
                ExportData
                LoadFromStream
                Print
                SaveToStream
                SetBounds

This help file was created with HelpScribble.

.topic 3000

Модуль содержит описания некоторых компонентов и объектов FastReport.

Components
TfrOLEObject

Objects
TfrOLEView

This help file was created with HelpScribble.

.topic 3011
See also

TfrOLEView object

This help file was created with HelpScribble.

.topic 3101
See also

TfrOLEObject component
TfrView object

This help file was created with HelpScribble.

.topic 3102
Properties

  Key properties
                dx
                dy
                FillColor
                Flags
                Format
                FormatStr
                FrameColor
                FrameTyp
                FrameWidth
                IsPrinting
                Memo
                Name
                OffsX
                OffsY
                 OleContainer
                Parent
                ScaleX
                ScaleY
                Script
                Selected
                Typ
                Visible
                x
                y

This help file was created with HelpScribble.

.topic 3103
Methods

  Key methods
                GetClipRgn
                Assign
                CreateUniqueName
                DefinePopupMenu
                Draw
                ExportData
                LoadFromStream
                Print
                SaveToStream
                SetBounds

This help file was created with HelpScribble.

.topic 3110

Applies to
TfrOLEView object

Declaration
OleContainer: TOleContainer;

Description
Ссылка на контейнер с содержащимся в нем объектом OLE.

This help file was created with HelpScribble.

.topic 4000

Модуль содержит описания некоторых компонентов и объектов FastReport.

Components
TfrRichObject

Objects
TfrRichView

This help file was created with HelpScribble.

.topic 4011
See also

TfrRichView object

This help file was created with HelpScribble.

.topic 4101
See also

TfrRichObject component
TfrView object

This help file was created with HelpScribble.

.topic 4102
Properties

  Key properties
                dx
                dy
                FillColor
                Flags
                Format
                FormatStr
                FrameColor
                FrameTyp
                FrameWidth
                IsPrinting
                Memo
                Name
                OffsX
                OffsY
                Parent
                 RichEdit
                ScaleX
                ScaleY
                Script
                Selected
                Typ
                Visible
                x
                y

This help file was created with HelpScribble.

.topic 4103
Methods

  Key methods
                GetClipRgn
                Assign
                CreateUniqueName
                DefinePopupMenu
                Draw
                ExportData
                LoadFromStream
                Print
                SaveToStream
                SetBounds

This help file was created with HelpScribble.

.topic 4110

Applies to
TfrRichView object

Declaration
RichEdit: TRichEdit;

Description
Ссылка на текст в формате RTF.

This help file was created with HelpScribble.

.topic 5000

Модуль содержит описания некоторых компонентов и объектов FastReport.

Components
TfrShapeObject

Objects
TfrShapeView

Constants
skEllipse
skRectangle
skRoundRectangle
skTriangle

This help file was created with HelpScribble.

.topic 5011
See also

TfrShapeView object

This help file was created with HelpScribble.

.topic 5101
See also

TfrShapeObject component
TfrView object

This help file was created with HelpScribble.

.topic 5102
Properties

  Key properties
                dx
                dy
                FillColor
                Flags
                Format
                FormatStr
                FrameColor
                FrameTyp
                FrameWidth
                IsPrinting
                Memo
                Name
                OffsX
                OffsY
                Parent
                ScaleX
                ScaleY
                Script
                Selected
                 ShapeType
                Typ
                Visible
                x
                y

This help file was created with HelpScribble.

.topic 5103
Methods

  Key methods
                GetClipRgn
                Assign
                CreateUniqueName
                DefinePopupMenu
                Draw
                ExportData
                LoadFromStream
                Print
                SaveToStream
                SetBounds

This help file was created with HelpScribble.#

.topic 5110

Applies to
TfrShapeView object

Declaration
ShapeType: Byte;

Description
Тип фигуры. Одно из значений skRectangle, skRoundRectangle, skEllipse, skTriangle.

This help file was created with HelpScribble.

.topic 8000

Модуль содержит описания некоторых компонентов и объектов FastReport.

Components
TfrUserDataset

Objects
TfrDataset

Types
TCheckEOFEvent
TRangeBegin
TRangeEnd

This help file was created with HelpScribble.

.topic 8011
See also

TfrUserDataset component
TfrDBDataSet component

This help file was created with HelpScribble.

.topic 8012
Properties

  Run-time only		  Key properties
                  RangeBegin
                  RangeEnd
                  RangeEndCount
                  RecNo

This help file was created with HelpScribble.

.topic 8013
Methods

  Key methods
                 EOF
                 Exit
                 First
                 Init
                 Next

This help file was created with HelpScribble.

.topic 8014
Events

  Key events
                 OnCheckEOF
                 OnFirst
                 OnNext

This help file was created with HelpScribble.

.topic 8020

Applies to
TfrDataset object

Declaration
property RangeBegin: TRangeBegin;

Description
Определяет начальную точку при навигации по набору данных.

This help file was created with HelpScribble.

.topic 8021
See also

RangeEnd property
RangeEndCount property

This help file was created with HelpScribble.

.topic 8025

Applies to
TfrDataset object

Declaration
property RangeEnd: TRangeEnd;

Description
Определяет конечную точку при навигации по набору данных.

This help file was created with HelpScribble.

.topic 8026
See also

RangeBegin property
RangeEndCount property

This help file was created with HelpScribble.

.topic 8030

Applies to
TfrDataset object

Declaration
property RangeEndCount: Integer;

Description
Определяет максимальное количество записей в наборе, по которым будет осуществляться навигация. При этом свойство RangeEnd должно быть установлено в reCount.

Таким образом, для просмотра первых 20 записей надо установить RangeBegin = rbFirst, RangeEnd = reCount и RangeEndCount = 20.

This help file was created with HelpScribble.

.topic 8031
See also

RangeBegin property
RangeEnd property

This help file was created with HelpScribble.

.topic 8033

Applies to
TfrDataset object

Declaration
property RecNo: Integer;

Description
Возвращает текущую позицию указателя.

This help file was created with HelpScribble.

.topic 8035

Applies to
TfrDataset object

Declaration
function EOF: Boolean; virtual;

Description
Функция возвращает истину, если достигнут конец набора данных.

This help file was created with HelpScribble.

.topic 8036
See also

First method
Next method
OnCheckEOF event

This help file was created with HelpScribble.

.topic 8040

Applies to
TfrDataset object

Declaration
procedure Exit; virtual;

Description
Метод вызывается в конце работы с набором данных. Устанавливает указатель на запись, которая была текущей при вызове метода Init.

This help file was created with HelpScribble.

.topic 8041
See also

Init method

This help file was created with HelpScribble.

.topic 8045

Applies to
TfrDataset object

Declaration
procedure First; virtual;

Description
Метод устанавливает указатель на первую запись в наборе данных. Если свойство RangeBegin установлено в rbCurrent, то указатель устанавливается на запись, которая была текущей при начале работы с набором данных (до вызова метода Init).

This help file was created with HelpScribble.

.topic 8046
See also

Next method
EOF method
OnFirst event

This help file was created with HelpScribble.

.topic 8050

Applies to
TfrDataset object

Declaration
procedure Init; virtual;

Description
Выполняет инициализацию набора данных и запоминает текущую позицию указателя.

This help file was created with HelpScribble.

.topic 8051
See also

Exit method

This help file was created with HelpScribble.

.topic 8055

Applies to
TfrDataset object

Declaration
procedure Next; virtual;

Description
Перемещает указатель на следующую запись в наборе данных.

This help file was created with HelpScribble.

.topic 8056
See also

First method
EOF method
OnNext event

This help file was created with HelpScribble.

.topic 8060

Applies to
TfrDataset object

Declaration
property OnCheckEOF: TCheckEOFEvent;

Description
Обработчик события вызывается каждый раз при вызове функции EOF.

This help file was created with HelpScribble.

.topic 8061
See also

EOF method

This help file was created with HelpScribble.

.topic 8065

Applies to
TfrDataset object

Declaration
property OnFirst: TNotifyEvent;

Description
Обработчик события вызывается каждый раз при вызове функции First.

This help file was created with HelpScribble.

.topic 8066
See also

First method

This help file was created with HelpScribble.

.topic 8070

Applies to
TfrDataset object

Declaration
property OnNext: TNotifyEvent;

Description
Обработчик события вызывается каждый раз при вызове функции Next.

This help file was created with HelpScribble.

.topic 8071
See also

Next method

This help file was created with HelpScribble.

.topic 8101
See also

TfrDataset object
TfrDBDataSet component

This help file was created with HelpScribble.

.topic 8102
Properties

  Run-time only		  Key properties
                RangeBegin
                RangeEnd
                RangeEndCount
                 RecNo

This help file was created with HelpScribble.

.topic 8103
Methods

  Key methods
                EOF
                Exit
                First
                Init
                Next

This help file was created with HelpScribble.

.topic 8104
Events

  Key events
                OnCheckEOF
                OnFirst
                OnNext

This help file was created with HelpScribble.

.topic 8200

Unit
FR_DSet

Declaration
type
TCheckEOFEvent = procedure(Sender: TObject; var EOF: Boolean) of object;

Description
Тип, определенный для события OnCheckEOF объекта TfrDataSet.

This help file was created with HelpScribble.

.topic 8201
See also

EOF method
OnCheckEOF event

This help file was created with HelpScribble.

.topic 8205

Unit
FR_DSet

Declaration
type
TRangeBegin = (rbFirst, rbCurrent);

Description
Тип, определенный для свойства RangeBegin объекта TfrDataSet.

This help file was created with HelpScribble.

.topic 8206
See also

RangeBegin property

This help file was created with HelpScribble.

.topic 8210

Unit
FR_DSet

Declaration
type
TRangeEnd = (reLast, reCurrent, reCount);

Description
Тип, определенный для свойства RangeEnd объекта TfrDataSet.

This help file was created with HelpScribble.

.topic 8211
See also

RangeEnd property

This help file was created with HelpScribble.

.topic 9000

Модуль содержит описания некоторых компонентов и объектов FastReport.

Components
TfrDBDataSet

This help file was created with HelpScribble.

.topic 9011
See also

TfrDataset object
TfrUserDataset component

This help file was created with HelpScribble.

.topic 9012
Properties

  Run-time only		  Key properties
                 CloseDataSource
                 DataSource
                 OpenDataSource
                RangeBegin
                RangeEnd
                RangeEndCount
                 RecNo

This help file was created with HelpScribble.

.topic 9013
Methods

  Key methods
                 Close
                EOF
                Exit
                First
                Init
                Next
                 Open

This help file was created with HelpScribble.

.topic 9014
Events

  Key events
                OnCheckEOF
                 OnClose
                OnFirst
                OnNext
                 OnOpen

This help file was created with HelpScribble.

.topic 9020

Applies to
TfrDBDataSet component

Declaration
property CloseDataSource: Boolean;

Description
Определяет, надо ли закрывать таблицу БД после окончания работы с набором данных. По умолчанию False.

This help file was created with HelpScribble.

.topic 9021
See also

DataSource property
OpenDataSource property
OnClose event

This help file was created with HelpScribble.

.topic 9025

Applies to
TfrDBDataSet component

Declaration
property DataSource: TDataSource;

Description
Источник данных - связка TDataSource -> TDataSet.

This help file was created with HelpScribble.

.topic 9026
See also

OpenDataSource property
CloseDataSource property

This help file was created with HelpScribble.

.topic 9030

Applies to
TfrDBDataSet component

Declaration
property OpenDataSource: Boolean;

Description
Определяет, надо ли открывать таблицу БД перед началом работы с ней. По умолчанию - True.

This help file was created with HelpScribble.

.topic 9031
See also

DataSource property
CloseDataSource property
OnOpen event

This help file was created with HelpScribble.

.topic 9035

Applies to
TfrDBDataSet component

Declaration
procedure Close;

Description
Закрывает таблицу БД.

This help file was created with HelpScribble.

.topic 9036
See also

Open method
CloseDataSource property
OnClose event

This help file was created with HelpScribble.

.topic 9040

Applies to
TfrDBDataSet component

Declaration
procedure Open;

Description
Открывает таблицу БД.

This help file was created with HelpScribble.

.topic 9041
See also

Close method
OpenDataSource property
OnOpen event

This help file was created with HelpScribble.

.topic 9045

Applies to
TfrDBDataSet component

Declaration
property OnClose: TNotifyEvent;

Description
Обработчик события вызывается каждый раз при вызове функции Close.

This help file was created with HelpScribble.

.topic 9046
See also

Close method

This help file was created with HelpScribble.

.topic 9050

Applies to
TfrDBDataSet component

Declaration
property OnOpen: TNotifyEvent;

Description
Обработчик события вызывается каждый раз при вызове функции Open.

This help file was created with HelpScribble.

.topic 9051
See also

Open method

This help file was created with HelpScribble.

.topic 10000

Модуль содержит описания некоторых компонентов и объектов FastReport.

Components
TfrCSVExport

This help file was created with HelpScribble.

.topic 11000

Модуль содержит описания некоторых компонентов и объектов FastReport.

Components
TfrHTMExport

This help file was created with HelpScribble.

.topic 12000

Модуль содержит описания некоторых компонентов и объектов FastReport.

Components
TfrRTFExport

This help file was created with HelpScribble.

.topic 13000

Модуль содержит описания некоторых компонентов и объектов FastReport.

Components
TfrTextExport

This help file was created with HelpScribble.

.topic 14000

Модуль содержит описания некоторых компонентов и объектов FastReport.

Objects
TfrInterpretator
TfrVariables

Variables
frInterpretator
frVariables

This help file was created with HelpScribble.

.topic 14013
Methods

  Key methods
                 DoFunction
                 DoScript
                 GetValue
                 PrepareScript
                 SetValue

This help file was created with HelpScribble.

.topic 14020

Applies to
TfrInterpretator object

Declaration
procedure DoScript(Memo: TStringList); virtual;

Description
Метод осуществляет выполнение скрипта. Скрипт должен быть предварительно обработан методом PrepareScript.

This help file was created with HelpScribble.

.topic 14021
See also

PrepareScript method

This help file was created with HelpScribble.

.topic 14025

Applies to
TfrInterpretator object

Declaration
procedure PrepareScript(MemoFrom, MemoTo, MemoErr: TStringList); virtual;

Description
Метод осуществляет подготовку скрипта к исполнению. Исходный скрипт из MemoFrom переводится в форму, более удобную для исполнения, и помещается в MemoTo. Ошибки, найденные при обработке, помещаются в MemoErr.

This help file was created with HelpScribble.

.topic 14026
See also

DoScript method

This help file was created with HelpScribble.

.topic 14030

Applies to
TfrInterpretator object

Declaration
procedure GetValue(const Name: String; var Value: Variant); virtual;

Description
Метод вызывается, когда в выражении обнаружено обращение к внешней переменной с именем Name. Значение переменной должно быть возвращено в параметре Value.

This help file was created with HelpScribble.

.topic 14031
See also

SetValue method
DoFunction method

This help file was created with HelpScribble.

.topic 14040

Applies to
TfrInterpretator object

Declaration
procedure SetValue(const Name: String; Value: Variant); virtual;

Description
Метод вызывается, когда обнаружено присвоение значения Value внешней переменной с именем Name.

This help file was created with HelpScribble.

.topic 14041
See also

GetValue method
DoFunction method

This help file was created with HelpScribble.

.topic 14050

Applies to
TfrInterpretator object

Declaration
procedure DoFunction(const Name: String; p1, p2, p3: Variant; var Val: String); virtual;

Description
Метод вызывается, когда в выражении обнаружен вызов внешней функции с именем Name. Параметры функции передаются в параметрах p1, p2, p3. Значение функции должно быть возвращено в параметре Val.

This help file was created with HelpScribble.

.topic 14051
See also

GetValue method
SetValue method

This help file was created with HelpScribble.

.topic 14102
Properties

  Run-time only		  Key properties
                  Count
                  Name
                  Value
                  Variable

This help file was created with HelpScribble.

.topic 14103
Methods

  Key methods
                 IndexOf
                 Clear
                 Delete

This help file was created with HelpScribble.

.topic 14110

Applies to
TfrVariables object

Declaration
property Count: Integer;

Description
Возвращает количество переменных в списке.

This help file was created with HelpScribble.

.topic 14115

Applies to
TfrVariables object

Declaration
property Name[Index: Integer]: String;

Description
Возвращает имя переменной, имеющей порядковый номер Index в списке.

This help file was created with HelpScribble.

.topic 14116
See also

Value property
Variable property

This help file was created with HelpScribble.

.topic 14120

Applies to
TfrVariables object

Declaration
property Value[Index: Integer]: Variant;

Description
Возвращает значение переменной, имеющей порядковый номер Index в списке.

This help file was created with HelpScribble.

.topic 14121
See also

Name property
Variable property

This help file was created with HelpScribble.

.topic 14125

Applies to
TfrVariables object

Declaration
property Variable[Name: String]: Variant; default;

Description
Возвращает значение переменной, имеющей имя Name. Т.к. свойство определено по умолчанию, к нему можно обращаться без указания имени Variable, например frVar['MyVar'].

This help file was created with HelpScribble.

.topic 14126
See also

Name property
Value property

This help file was created with HelpScribble.

.topic 14135

Applies to
TfrVariables object

Declaration
function IndexOf(Name: String): Integer;

Description
Возвращает порядковый номер переменной, имеющей имя Name.

This help file was created with HelpScribble.

.topic 14140

Applies to
TfrVariables object

Declaration
procedure Clear;

Description
Очищает список переменных.

This help file was created with HelpScribble.

.topic 14145

Applies to
TfrVariables object

Declaration
procedure Delete(Index: Integer);

Description
Удаляет переменную, имеющую порядковый номер Index в списке.

This help file was created with HelpScribble.

.topic 15000

Модуль содержит описания некоторых компонентов и объектов FastReport.

Objects
TParser

Types
TFunctionEvent
TGetPValueEvent

Variables
Parser

This help file was created with HelpScribble.

.topic 15013
Methods

  Key methods
                 Calc
                 CalcOPZ
                 Str2OPZ

This help file was created with HelpScribble.

.topic 15014
Events

  Key events
                 OnFunction
                 OnGetValue

This help file was created with HelpScribble.

.topic 15020

Applies to
TfrParser object

Declaration
function Calc(const s: String): Variant;

Description
Вычисляет выражение s и возвращает результат. Вызов функции Calc эквивалентен вызову CalcOPZ(Str2OPZ(s)).

This help file was created with HelpScribble.

.topic 15021
See also

CalcOPZ method
Str2OPZ method

This help file was created with HelpScribble.

.topic 15025

Applies to
TfrParser object

Declaration
function CalcOPZ(const s: String): Variant;

Description
Вычисляет выражение s и возвращает результат. Выражение s должно быть представлено в форме обратной польской записи.

This help file was created with HelpScribble.

.topic 15026
See also

Calc method
Str2OPZ method

This help file was created with HelpScribble.

.topic 15030

Applies to
TfrParser object

Declaration
function Str2OPZ(s: String): String;

Description
Переводит выражение s в форму обратной польской записи.

This help file was created with HelpScribble.

.topic 15031
See also

Calc method
CalcOPZ method

This help file was created with HelpScribble.

.topic 15035

Applies to
TfrParser object

Declaration
property OnFunction: TFunctionEvent;

Description
Обработчик события OnUserFunction вызывается, когда в выражении обнаружен вызов внешней функции. Функция может иметь до 3-х параметров любого типа. Параметры передаются в переменных p1, p2, p3.

This help file was created with HelpScribble.

.topic 15036
See also

OnGetValue event

This help file was created with HelpScribble.

.topic 15040

Applies to
TfrParser object

Declaration
property OnGetValue: TGetPValueEvent;

Description
Обработчик события OnGetValue вызывается, когда в выражении обнаружена внешняя переменная.

This help file was created with HelpScribble.

.topic 15041
See also

OnFunction event

This help file was created with HelpScribble.

.topic 15100

Unit
FR_Pars

Declaration
type
TFunctionEvent = procedure(const name: String; p1, p2, p3: Variant; var val: String) of object;

Description
Тип определен для события OnFunction объекта TfrParser.

This help file was created with HelpScribble.

.topic 15105

Unit
FR_Pars

Declaration
type
TGetPValueEvent = procedure(const s: String; var v: Variant) of object;

Description
Тип определен для события OnGetValue объекта TfrParser.

This help file was created with HelpScribble.

.topic 20010

Модуль содержит описания некоторых компонент и объектов FastReport.

Components
TfrReport
TfrCompositeReport
TfrExportFilter

Objects
TfrView
TfrMemoView
TfrBandView
TfrSubReportView
TfrPictureView
TfrLineView
TfrBand
TfrPage
TfrPages
TfrEMFPages
TfrFunctionLibrary
TfrDataDictionary
TfrLocale

Types
TBeginColumnEvent
TBeginDocEvent
TBeginPageEvent
TDetailEvent
TEndDocEvent
TEndPageEvent
TEnterRectEvent
TfrBandType
TfrHighlightAttr
TfrReportType
TfrRgnType
TManualBuildEvent
TProgressEvent
TAfterExportEvent
TBeforeExportEvent
TfrDocMode
TfrPageType
TfrPrintPages
TLocalizeEvent
TMouseOverObjectEvent
TObjectClickEvent
TPrintReportEvent

Routines
frCreateObject
frRegisterExportFilter
frRegisterFunctionLibrary
frRegisterObject
frRegisterTool
frLocale
frAddFunctionDesc

Constants
baBottom
baCenter
baLeft
baNone
baRight
baWidth
flBandPrintChildIfInvisible
flHideZeros
flSuppressRepeated
flTextOnly
flUnderlines
flBandNewPageAfter
flBandOnFirstPage
flBandOnLastPage
flBandPageBreak
flBandPrintifSubsetEmpty
flBandRepeatHeader
flPictCenter
flPictRatio
flStretched
flWantHook
flWordBreak
flWordWrap
frCurrentVersion
gtAddIn
gtBand
gtLine
gtMemo
gtPicture
gtSubReport
frrfDontDelete
frrfDontEditContents
frrfDontEditMemo
frrfDontEditScript
frrfDontModify
frrfDontMove
frrfDontSize

Variables
CurBand
CurPage
CurReport
CurView
DisableDrawing
DocMode
frDataManager
frDesigner
frParser
frInterpretator
frVariables
frVersion
MasterReport
PageNo
frConsts

This help file was created with HelpScribble.

.topic 20040
See also

TfrMemoView object
TfrBandView object
TfrSubReportView object
TfrPictureView object
TfrLineView object

This help file was created with HelpScribble.

.topic 20050
Properties

  Key properties
                 BandAlign
                 dx
                 dy
                 FillColor
                 Flags
                 Format
                 FormatStr
                 FrameColor
                 FrameTyp
                 FrameWidth
                 gapx
                 gapy
                 HVersion
                 IsPrinting
                 LVersion
                 Memo
                 Name
                 OffsX
                 OffsY
                 Parent
                 Restrictions
                 ScaleX
                 ScaleY
                 Script
                 Selected
                 Tag
                 Typ
                 Visible
                 x
                 y

This help file was created with HelpScribble.

.topic 20060
Methods

  Key methods
                 GetClipRgn
                 Assign
                 CreateUniqueName
                 DefinePopupMenu
                 Draw
                 ExportData
                 LoadFromStream
                 StreamOut
                 SaveToStream
                 SetBounds
                 ShowEditor

This help file was created with HelpScribble.

.topic 20070

Applies to
TfrView object

Declaration
dx: Integer;

Description
Ширина объекта. Измеряется в экранных пикселах, для перевода в миллиметры надо умножить на коэффициент 5/18.

This help file was created with HelpScribble.

.topic 20080
See also

x field
y field
dy field

This help file was created with HelpScribble.

.topic 20090

Applies to
TfrView object

Declaration
dy: Integer;

Description
Высота объекта. Измеряется в экранных пикселах, для перевода в миллиметры надо умножить на коэффициент 5/18.

This help file was created with HelpScribble.

.topic 20100
See also

x field
y field
dx field

This help file was created with HelpScribble.

.topic 20110

Applies to
TfrView object

Declaration
FillColor: TColor;

Description
Цвет фона объекта. Если FillColor равен clNone, то объект при печати будет прозрачным. В режиме дизайнера прозрачные объекты показываются с белым фоном.

This help file was created with HelpScribble.

.topic 20130

Applies to
TfrView object

Declaration
Flags: Word;

Description
Набор флагов - опций объекта. Может быть комбинацией следующих значений:

Все объекты:
·		flStretched - объект растягиваемый.
·		flWantHook - объект получает управление после отрисовки любого объекта.

Объект TfrMemoView:
·		flWordWrap - перенос слов.
·		flWordBreak - перенос слов по слогам.
·		flTextOnly - выводить содержимое объекта "как есть", без проверки на наличие переменных.
·		flSuppressRepeated - подавлять повторяющиеся значения.
·		flHideZeros - не отображать нулевые значения.
·		flUnderlines - подчеркивать строки текста.

Объект TfrBandView:
·		flBandNewPageAfter - формировать новую страницу.
·		flBandPrintifSubsetEmpty - печатать, если подчиненный список пуст.
·		flBandPageBreak - разрываемый бэнд.
·		flBandOnFirstPage - печатать на первой странице.
·		flBandOnLastPage - печатать на последней странице.
·		flBandRepeatHeader - повторять на всех страницах.
·		flBandPrintChildIfInvisible - печатать child-бэнды, если бэнд-родитель невидим.

Объект TfrPictureView:
·		flPictCenter - центрировать картинку.
·		flPictRatio - сохранять пропорции.

This help file was created with HelpScribble.

.topic 20140

Applies to
TfrView object

Declaration
Format: Integer;

Description
Формат переменных объекта. Используется только в объекте TfrMemoView.

This help file was created with HelpScribble.

.topic 20150
See also

FormatStr field

This help file was created with HelpScribble.

.topic 20160

Applies to
TfrView object

Declaration
FormatStr: String;

Description
Строка форматирования. Используется только в объекте TfrMemoView.

This help file was created with HelpScribble.

.topic 20170
See also

Format field

This help file was created with HelpScribble.

.topic 20180

Applies to
TfrView object

Declaration
FrameColor: TColor;

Description
Цвет рамки объекта.

This help file was created with HelpScribble.

.topic 20190
See also

FrameTyp field
FrameWidth field

This help file was created with HelpScribble.

.topic 20200

Applies to
TfrView object

Declaration
FrameTyp: Word;

Description
Тип рамки объекта. Набор битовых полей, показывающих, из каких линий состоит рамка.

This help file was created with HelpScribble.

.topic 20210
See also

FrameColor field
FrameWidth field

This help file was created with HelpScribble.

.topic 20220

Applies to
TfrView object

Declaration
FrameWidth: Single;

Description
Толщина рамки объекта в экранных пикселах.

This help file was created with HelpScribble.

.topic 20230
See also

FrameColor field
FrameTyp field

This help file was created with HelpScribble.

.topic 20240

Applies to
TfrView object

Declaration
IsPrinting: Boolean;

Description
True, если рисование осуществляется на холсте принтера. Анализируя это значение, можно осуществлять отрисовку в методе Draw в двух вариантах: для экрана и для принтера.

This help file was created with HelpScribble.

.topic 20250

Applies to
TfrView object

Declaration
Memo: TStringList;

Description
Содержимое Memo объекта.

This help file was created with HelpScribble.

.topic 20270

Applies to
TfrView object

Declaration
Name: String;

Description
Уникальное имя объекта.

This help file was created with HelpScribble.

.topic 20280
See also

CreateUniqueName method

This help file was created with HelpScribble.

.topic 20290

Applies to
TfrView object

Declaration
OffsX: Integer;

Description
Коэффициент смещения по горизонтали. Перед началом рисования объекта его позиция и размеры масштабируются и смещаются.

This help file was created with HelpScribble.

.topic 20300
See also

OffsY field

This help file was created with HelpScribble.

.topic 20310

Applies to
TfrView object

Declaration
OffsY: Integer;

Description
Коэффициент смещения по вертикали. Перед началом рисования объекта его позиция и размеры масштабируются и смещаются.

This help file was created with HelpScribble.

.topic 20320
See also

OffsX field

This help file was created with HelpScribble.

.topic 20330

Applies to
TfrView object

Declaration
Parent: TfrBand;

Description
Ссылка на бэнд - владелец объекта. Только в режиме построения отчета.

This help file was created with HelpScribble.

.topic 20340

Applies to
TfrView object

Declaration
ScaleX: Double;

Description
Коэффициент масштабирования по горизонтали. Перед началом рисования объекта его позиция и размеры масштабируются и смещаются.

This help file was created with HelpScribble.

.topic 20350
See also

ScaleY field

This help file was created with HelpScribble.

.topic 20360

Applies to
TfrView object

Declaration
ScaleY: Double;

Description
Коэффициент масштабирования по вертикали. Перед началом рисования объекта его позиция и размеры масштабируются и смещаются.

This help file was created with HelpScribble.

.topic 20370
See also

ScaleX field

This help file was created with HelpScribble.

.topic 20380

Applies to
TfrView object

Declaration
Script: TStringList;

Description
Скрипт объекта.

This help file was created with HelpScribble.

.topic 20390
See also

<<< See also of Script property >>>

This help file was created with HelpScribble.

.topic 20400

Applies to
TfrView object

Declaration
Selected: Boolean;

Description
True, если объект выделен в режиме дизайнера.

This help file was created with HelpScribble.

.topic 20410

Applies to
TfrView object

Declaration
Typ: Byte;

Description
Тип объекта. Одно из значений gtMemo, gtPicture, gtBand, gtSubReport , gtLine, gtAddIn.

This help file was created with HelpScribble.

.topic 20420

Applies to
TfrView object

Declaration
Visible: WordBool;

Description
Видимость объекта. Невидимые объекты при построении отчета не показываются.

This help file was created with HelpScribble.

.topic 20430

Applies to
TfrView object

Declaration
x: Integer;

Description
Позиция объекта по горизонтали. Измеряется в экранных пикселах, для перевода в миллиметры надо умножить на коэффициент 5/18.

This help file was created with HelpScribble.

.topic 20440
See also

y field
dx field
dy field
SetBounds method

This help file was created with HelpScribble.

.topic 20450

Applies to
TfrView object

Declaration
y: Integer;

Description
Позиция объекта по вертикали. Измеряется в экранных пикселах, для перевода в миллиметры надо умножить на коэффициент 5/18.

This help file was created with HelpScribble.

.topic 20460
See also

x field
dx field
dy field
SetBounds method

This help file was created with HelpScribble.

.topic 20470

Applies to
TfrView object

Declaration
function GetClipRgn(rt: TfrRgnType): HRGN; virtual;

Description
Возвращает регион - область рисования объекта. Если параметр rt = rtExtended, то возвращает регион, расширенный на 10 точек. Функцию необходимо переопределять, если объект имеет непрямоугольную форму.

This help file was created with HelpScribble.

.topic 20480

Applies to
TfrView object

Declaration
procedure Assign(From: TfrView);

Description
Копирует содержимое из объекта From.

This help file was created with HelpScribble.

.topic 20490

Applies to
TfrView object

Declaration
procedure CreateUniqueName;

Description
Создает уникальное имя для объекта.

This help file was created with HelpScribble.

.topic 20500
See also

Name field

This help file was created with HelpScribble.

.topic 20510

Applies to
TfrView object

Declaration
procedure DefinePopupMenu(Popup: TPopupMenu); virtual;

Description
Вызывается перед прорисовкой контекстного меню объекта в режиме дизайнера. Позволяет определить свои пункты меню и реакцию на них. У класса TfrView этот метод создает в меню разделительную черту, пункт "Редактор" и флажок "Растягиваемый".

This help file was created with HelpScribble.

.topic 20520

Applies to
TfrView object

Declaration
procedure Draw(Canvas: TCanvas); virtual; abstract;

Description
Выполняет отрисовку объекта. Этот метод необходимо переопределять всегда.

This help file was created with HelpScribble.

.topic 20530

Applies to
TfrView object

Declaration
procedure ExportData; virtual;

Description
Экспортирует данные в фильтр экспорта.

This help file was created with HelpScribble.

.topic 20540

Applies to
TfrView object

Declaration
procedure LoadFromStream(Stream: TStream); virtual;

Description
Считывает содержимое объекта из потока Stream. Необходимо переопределять этот метод, если объект имеет дополнительные поля, которые надо хранить в потоке.

This help file was created with HelpScribble.

.topic 20550
See also

SaveToStream method

This help file was created with HelpScribble.

.topic 20560

Applies to
TfrView object

Declaration
procedure StreamOut(Stream: TStream); virtual;

Description
Запоминает содержимое объекта в потоке Stream в процессе построения отчета. Необходимо переопределять этот метод, если объект нуждается в предварительной обработке перед выводом в поток.

This help file was created with HelpScribble.

.topic 20570

Applies to
TfrView object

Declaration
procedure SaveToStream(Stream: TStream); virtual;

Description
Записывает содержимое объекта в поток Stream. Необходимо переопределять этот метод, если объект имеет дополнительные поля, которые надо хранить в потоке.

This help file was created with HelpScribble.

.topic 20580
See also

LoadFromStream method

This help file was created with HelpScribble.

.topic 20590

Applies to
TfrView object

Declaration
procedure SetBounds(Left, Top, Width, Height: Integer);

Description
Устанавливает значения полей x, y, dx, dy объекта.

This help file was created with HelpScribble.

.topic 20600
See also

x field
y field
dx field
dy field

This help file was created with HelpScribble.

.topic 20620
See also

TfrView object
TfrBandView object
TfrSubReportView object
TfrPictureView object
TfrLineView object

This help file was created with HelpScribble.

.topic 20630
Properties

  Key properties

                 Alignment
                dx
                dy
                FillColor
                Flags
                 Font
                Format
                FormatStr
                FrameColor
                FrameTyp
                FrameWidth
                 Highlight
                 HighlightStr
                IsPrinting
                Memo
                Name
                OffsX
                OffsY
                Parent
                ScaleX
                ScaleY
                Script
                Selected
                Typ
                Visible
                x
                y

This help file was created with HelpScribble.

.topic 20640
Methods

  Key methods
                GetClipRgn
                Assign
                CreateUniqueName
                DefinePopupMenu
                Draw
                ExportData
                LoadFromStream
                Print
                SaveToStream
                SetBounds

This help file was created with HelpScribble.

.topic 20650

Applies to
TfrMemoView object

Declaration
Alignment: Integer;

Description
Выравнивание текста (1 - по правому краю, 2 - по центру, 3 - по ширине, +4 - текст по вертикали, +8 - центровка по высоте, +16 - по нижнему краю).

This help file was created with HelpScribble.

.topic 20670

Applies to
TfrMemoView object

Declaration
Font: TFont;

Description
Используемый шрифт.

This help file was created with HelpScribble.

.topic 20750

Applies to
TfrMemoView object

Declaration
Highlight: TfrHighlightAttr;

Description
Атрибуты выделения. Объект выводится с использованием этих атрибутов, если условие выделения HighlightStr истинно.

This help file was created with HelpScribble.

.topic 20760
See also

HighlightStr field

This help file was created with HelpScribble.

.topic 20770

Applies to
TfrMemoView object

Declaration
HighlightStr: String;

Description
Условие выделения.

This help file was created with HelpScribble.

.topic 20780
See also

Highlight field

This help file was created with HelpScribble.

.topic 20800
See also

TfrView object
TfrMemoView object
TfrSubReportView object
TfrPictureView object
TfrLineView object
TfrBand object

This help file was created with HelpScribble.

.topic 20810
Properties

  Key properties
                 BandType
                 ChildBand
                 ColumnGap
                 Columns
                 ColumnWidth
                 DataSet
                dx
                dy
                FillColor
                Flags
                Format
                FormatStr
                FrameColor
                FrameTyp
                FrameWidth
                 GroupCondition
                IsPrinting
                 Master
                Memo
                Name
                OffsX
                OffsY
                Parent
                ScaleX
                ScaleY
                Script
                Selected
                Typ
                Visible
                x
                y

This help file was created with HelpScribble.

.topic 20820
Methods

  Key methods
                GetClipRgn
                Assign
                CreateUniqueName
                DefinePopupMenu
                Draw
                ExportData
                LoadFromStream
                Print
                SaveToStream
                SetBounds

This help file was created with HelpScribble.

.topic 20830

Applies to
TfrBandView object

Declaration
property BandType: TfrBandType;

Description
Тип бэнда.

This help file was created with HelpScribble.

.topic 20840

Applies to
TfrBandView object

Declaration
property DataSet: String;

Description
Источник данных для бэнда. Свойство актуально только для дата-бэндов (Master data, Detail data, Subdetail data, Cross data).

This help file was created with HelpScribble.

.topic 20850

Applies to
TfrBandView object

Declaration
property GroupCondition: String;

Description
Условие группировки. Это свойство актуально только для бэнда Group header.

This help file was created with HelpScribble.

.topic 20870
See also

TfrView object
TfrMemoView object
TfrBandView object
TfrPictureView object
TfrLineView object

This help file was created with HelpScribble.

.topic 20880
Properties

  Key properties
                dx
                dy
                FillColor
                Flags
                Format
                FormatStr
                FrameColor
                FrameTyp
                FrameWidth
                IsPrinting
                Memo
                Name
                OffsX
                OffsY
                Parent
                ScaleX
                ScaleY
                Script
                Selected
                 SubPage
                Typ
                Visible
                x
                y

This help file was created with HelpScribble.

.topic 20890
Methods

  Key methods
                GetClipRgn
                Assign
                CreateUniqueName
                DefinePopupMenu
                Draw
                ExportData
                LoadFromStream
                Print
                SaveToStream
                SetBounds

This help file was created with HelpScribble.

.topic 20900

Applies to
TfrSubReportView object

Declaration
SubPage: Integer;

Description
Номер страницы, на которой содержится вложенный отчет.

This help file was created with HelpScribble.

.topic 20920
See also

TfrView object
TfrMemoView object
TfrBandView object
TfrSubReportView object
TfrLineView object

This help file was created with HelpScribble.

.topic 20930
Properties

  Key properties
                 BlobType
                dx
                dy
                FillColor
                Flags
                Format
                FormatStr
                FrameColor
                FrameTyp
                FrameWidth
                IsPrinting
                Memo
                Name
                OffsX
                OffsY
                Parent
                 Picture
                ScaleX
                ScaleY
                Script
                Selected
                Typ
                Visible
                x
                y

This help file was created with HelpScribble.

.topic 20940
Methods

  Key methods
                GetClipRgn
                Assign
                CreateUniqueName
                DefinePopupMenu
                Draw
                ExportData
                LoadFromStream
                Print
                SaveToStream
                SetBounds

This help file was created with HelpScribble.

.topic 20950

Applies to
TfrPictureView object

Declaration
Picture: TPicture;

Description
Ссылка на изображение в формате BMP, ICO, WMF, EMF, JPG (изображения в формате JPG поддерживаются в Delphi 3 и выше, если используется модуль JPEG).

This help file was created with HelpScribble.

.topic 20970
See also

TfrView object
TfrMemoView object
TfrBandView object
TfrSubReportView object
TfrPictureView object

This help file was created with HelpScribble.

.topic 20980
Properties

  Key properties
                dx
                dy
                FillColor
                Flags
                Format
                FormatStr
                FrameColor
                FrameTyp
                FrameWidth
                IsPrinting
                Memo
                Name
                OffsX
                OffsY
                Parent
                ScaleX
                ScaleY
                Script
                Selected
                Typ
                Visible
                x
                y

This help file was created with HelpScribble.

.topic 20990
Methods

  Key methods
                GetClipRgn
                Assign
                CreateUniqueName
                DefinePopupMenu
                Draw
                ExportData
                LoadFromStream
                Print
                SaveToStream
                SetBounds

This help file was created with HelpScribble.

.topic 21010
See also

TfrPage object

This help file was created with HelpScribble.

.topic 21020
Properties

  Key properties
                 DataSet
                 dx
                 dy
                 Memo
                 Objects
                 Script
                 Typ
                 x
                 y

This help file was created with HelpScribble.

.topic 21030

Applies to
TfrBand object

Declaration
DataSet: TfrDataSet;

Description
Источник данных бэнда. Только для дата-бэндов.

This help file was created with HelpScribble.

.topic 21040
See also

TfrDataset object
TfrUserDataset component
TfrDBDataSet component

This help file was created with HelpScribble.

.topic 21050

Applies to
TfrBand object

Declaration
dx: Integer;

Description
Ширина бэнда. Измеряется в экранных пикселах, для перевода в миллиметры надо умножить на коэффициент 5/18.

This help file was created with HelpScribble.

.topic 21060
See also

x field
y field
dy field

This help file was created with HelpScribble.

.topic 21070

Applies to
TfrBand object

Declaration
dy: Integer;

Description
Высота бэнда. Измеряется в экранных пикселах, для перевода в миллиметры надо умножить на коэффициент 5/18.

This help file was created with HelpScribble.

.topic 21080
See also

x field
y field
dx field

This help file was created with HelpScribble.

.topic 21090

Applies to
TfrBand object

Declaration
Memo: TStringList;

Description
Мемо бэнда.

This help file was created with HelpScribble.

.topic 21110

Applies to
TfrBand object

Declaration
Objects: TList;

Description
Объекты, находящиеся на бэнде.

This help file was created with HelpScribble.

.topic 21120

Applies to
TfrBand object

Declaration
Script: TStringList;

Description
Скрипт бэнда.

This help file was created with HelpScribble.

.topic 21140

Applies to
TfrBand object

Declaration
Typ: TfrBandType;

Description
Тип бэнда.

This help file was created with HelpScribble.

.topic 21150

Applies to
TfrBand object

Declaration
x: Integer;

Description
Горизонтальная позиция бэнда. Измеряется в экранных пикселах, для перевода в миллиметры надо умножить на коэффициент 5/18.

This help file was created with HelpScribble.

.topic 21160
See also

y field
dx field
dy field

This help file was created with HelpScribble.

.topic 21170

Applies to
TfrBand object

Declaration
y: Integer;

Description
Вертикальная позиция бэнда. Измеряется в экранных пикселах, для перевода в миллиметры надо умножить на коэффициент 5/18.

This help file was created with HelpScribble.

.topic 21180
See also

x field
dx field
dy field

This help file was created with HelpScribble.

.topic 21200
See also

TfrBand object
TfrPages object

This help file was created with HelpScribble.

.topic 21210
Properties

  Key properties
                 ColCount
                 ColGap
                 CurBottomY
                 CurY
                 Objects
                 pgHeight
                 pgMargins
                 pgOr
                 pgSize
                 pgWidth
                 PrintToPrevPage
                 UseMargins

This help file was created with HelpScribble.

.topic 21220
Methods

  Key methods
                 Create
                 FindObject
                 ChangePaper
                 Clear
                 Delete
                 NewPage
                 ShowBandByName
                 ShowBandByType

This help file was created with HelpScribble.

.topic 21230

Applies to
TfrPage object

Declaration
ColCount: Integer;

Description
Количество колонок для многоколоночных отчетов.

This help file was created with HelpScribble.

.topic 21240
See also

ColGap field

This help file was created with HelpScribble.

.topic 21250

Applies to
TfrPage object

Declaration
ColGap: Integer;

Description
Промежуток между колонками для многоколоночных отчетов.

This help file was created with HelpScribble.

.topic 21260
See also

ColCount field

This help file was created with HelpScribble.

.topic 21270

Applies to
TfrPage object

Declaration
CurBottomY: Integer;

Description
Текущее значение нижней границы листа, выраженное в экранных пикселах. Актуально только в процессе построения отчета.

This help file was created with HelpScribble.

.topic 21280
See also

CurY field

This help file was created with HelpScribble.

.topic 21290

Applies to
TfrPage object

Declaration
CurY: Integer;

Description
Текущее значение координаты Y, выраженное в экранных пикселах. Актуально только в процессе построения отчета.

This help file was created with HelpScribble.

.topic 21300
See also

CurBottomY field

This help file was created with HelpScribble.

.topic 21310

Applies to
TfrPage object

Declaration
Objects: TList;

Description
Список объектов, расположенных на листе.

This help file was created with HelpScribble.

.topic 21320
See also

FindObject method

This help file was created with HelpScribble.

.topic 21330

Applies to
TfrPage object

Declaration
pgHeight: Integer;

Description
Высота страницы в десятых долях мм. Это поле используется, если установлен пользовательский размер страницы (pgSize = 255).

This help file was created with HelpScribble.

.topic 21340
See also

pgWidth field
pgSize field
pgOr field

This help file was created with HelpScribble.

.topic 21350

Applies to
TfrPage object

Declaration
pgMargins: TRect;

Description
Поля страницы. Структура TRect содержит значения отступов от краев листа, выраженных в пикселах. Эти значения устанавливаются в дизайнере в диалоге "Параметры страницы", "поля".

This help file was created with HelpScribble.

.topic 21360
See also

UseMargins field

This help file was created with HelpScribble.

.topic 21370

Applies to
TfrPage object

Declaration
pgOr: TPrinterOrientation;

Description
Ориентация листа.

This help file was created with HelpScribble.

.topic 21380
See also

pgWidth field
pgHeight field
pgSize field

This help file was created with HelpScribble.

.topic 21390

Applies to
TfrPage object

Declaration
pgSize: Integer;

Description
Размер страницы. Используется нумерация размеров страницы, принятая в Windows. Так, формату A4 соответствует размер 9.

This help file was created with HelpScribble.

.topic 21400
See also

pgWidth field
pgHeight field
pgOr field

This help file was created with HelpScribble.

.topic 21410

Applies to
TfrPage object

Declaration
pgWidth: Integer;

Description
Ширина страницы в десятых долях мм. Это поле используется, если установлен пользовательский размер страницы (pgSize = 255).

This help file was created with HelpScribble.

.topic 21420
See also

pgHeight field
pgSize field
pgOr field

This help file was created with HelpScribble.

.topic 21430

Applies to
TfrPage object

Declaration
PrintToPrevPage: WordBool;

Description
Если True, начинает печать страницы на свободном месте предыдущего листа.

This help file was created with HelpScribble.

.topic 21460

Applies to
TfrPage object

Declaration
UseMargins: WordBool;

Description
Использовать поля страницы.

This help file was created with HelpScribble.

.topic 21470
See also

pgMargins field

This help file was created with HelpScribble.

.topic 21480

Applies to
TfrPage object

Declaration
constructor Create(ASize, AWidth, AHeight: Integer; AOr: TPrinterOrientation);

Description
Создает страницу с заданным размером (если размер листа = 255 - пользовательский формат - то ширина и высота листа задается в параметрах AWidth и AHeight). Параметр AOr определяет ориентацию листа.

This help file was created with HelpScribble.

.topic 21500

Applies to
TfrPage object

Declaration
function FindObject(Name: String): TfrView;

Description
Ищет объект с именем Name в списке объектов на странице. Если объект не найден, возвращает nil.

This help file was created with HelpScribble.

.topic 21510
See also

Objects field

This help file was created with HelpScribble.

.topic 21550

Applies to
TfrPage object

Declaration
procedure ChangePaper(ASize, AWidth, AHeight: Integer; AOr: TPrinterOrientation);

Description
Меняет размер и ориентацию листа.

This help file was created with HelpScribble.

.topic 21570

Applies to
TfrPage object

Declaration
procedure Clear;

Description
Очищает страницу (удаляет все объекты, расположенные на ней).

This help file was created with HelpScribble.

.topic 21580

Applies to
TfrPage object

Declaration
procedure Delete(Index: Integer);

Description
Удаляет объект, имеющий порядковый номер Index в списке объектов.

This help file was created with HelpScribble.

.topic 21590

Applies to
TfrPage object

Declaration
procedure NewPage;

Description
Формирует новую страницу. Эта процедура должна применяться только в обработчике события TfrReport.OnManualBuild.

This help file was created with HelpScribble.

.topic 21600

Applies to
TfrPage object

Declaration
procedure ShowBandByName(s: String);

Description
Печатает бэнд с именем s. Эта процедура должна применяться только в обработчике события TfrReport.OnManualBuild.

This help file was created with HelpScribble.

.topic 21610
See also

ShowBandByType method

This help file was created with HelpScribble.

.topic 21620
ShowBandBy... method example

procedure TForm1.frReport1ManualBuild(Page: TfrPage);
begin
  with Page do
  begin
    ShowBandByType(btReportTitle);
    ShowBandByName('Band1');
    ShowBandByName('Band1');
    ShowBandByName('Band2');
    NewPage;
    ShowBandByName('Band1');
    ShowBandByType(btReportSummary);
  end;
end;

This help file was created with HelpScribble.

.topic 21630

Applies to
TfrPage object

Declaration
procedure ShowBandByType(bt: TfrBandType);

Description
Печатает бэнд, имеющий тип bt. Эта процедура должна применяться только в обработчике события TfrReport.OnManualBuild.

This help file was created with HelpScribble.

.topic 21640
See also

ShowBandByName method

This help file was created with HelpScribble.

.topic 21670
See also

TfrPage object

This help file was created with HelpScribble.

.topic 21680
Properties

  Key properties
                 Count
                 Pages

This help file was created with HelpScribble.

.topic 21690
Methods

  Key methods
                 Add
                 Clear
                 Delete

This help file was created with HelpScribble.

.topic 21700

Applies to
TfrPages object

Declaration
property Count: Integer;

Description
Количество страниц в списке.

This help file was created with HelpScribble.

.topic 21710

Applies to
TfrPages object

Declaration
property Pages[Index: Integer]: TfrPage;

Description
Список страниц.

This help file was created with HelpScribble.

.topic 21720
See also

TfrPage object

This help file was created with HelpScribble.

.topic 21730

Applies to
TfrPages object

Declaration
procedure Add;

Description
Добавляет новую страницу формата А4 в список. При необходимости формат можно поменять вызовом метода TfrPage.ChangePaper.

This help file was created with HelpScribble.

.topic 21740

Applies to
TfrPages object

Declaration
procedure Clear;

Description
Очищает список страниц.

This help file was created with HelpScribble.

.topic 21750

Applies to
TfrPages object

Declaration
procedure Delete(Index: Integer);

Description
Удаляет страницу с индексом Index из списка.

This help file was created with HelpScribble.

.topic 21780
Properties

  Key properties
                 Count

This help file was created with HelpScribble.

.topic 21790
Methods

  Key methods
                 Add
                 Clear
                 Delete
                 Insert

This help file was created with HelpScribble.

.topic 21800

Applies to
TfrEMFPages object

Declaration
property Count: Integer;

Description
Количество страниц в списке.

This help file was created with HelpScribble.

.topic 21830

Applies to
TfrEMFPages object

Declaration
procedure Add(APage: TfrPage);

Description
Добавляет страницу в список. Параметры страницы устанавливаются на основе страницы APage.

This help file was created with HelpScribble.

.topic 21840

Applies to
TfrEMFPages object

Declaration
procedure Clear;

Description
Очищает список.

This help file was created with HelpScribble.

.topic 21850

Applies to
TfrEMFPages object

Declaration
procedure Delete(Index: Integer);

Description
Удаляет страницу с индексом Index из списка.

This help file was created with HelpScribble.

.topic 21860

Applies to
TfrEMFPages object

Declaration
procedure Insert(Index: Integer; APage: TfrPage);

Description
Вставляет страницу внутрь списка. Параметры страницы устанавливаются на основе страницы APage.

This help file was created with HelpScribble.

.topic 21880
See also

TfrCompositeReport component

This help file was created with HelpScribble.

.topic 21890
Properties

  Run-time only		  Key properties
                 Dataset
                 DefaultCollate
                 DefaultCopies
                  Dictionary
                  EMFPages
                 GrayedButtons
                 MDIPreview
                  MixVariablesAndDBFields
                 ModalPreview
                  Modified
                  Pages
                 Preview
                 ReportType
                 ShowProgress
                 StoreInDFM
                 Title

This help file was created with HelpScribble.

.topic 21900
Methods

  Key methods
                 Clear
                 FindObject
                 PrepareReport
                 DesignReport
                 EditPreparedReport
                 ExportTo
                 GetVariableValue
                 LoadFromBlobField
                 LoadFromDB
                 LoadFromFile
                 LoadFromStream
                 LoadPreparedReport
                 LoadTemplate
                 PrintPreparedReport
                 PrintPreparedReportDlg
                 SavePreparedReport
                 SaveTemplate
                 SaveToBlobField
                 SaveToDB
                 SaveToFile
                 SaveToStream
                 ShowPreparedReport
                 ShowReport

This help file was created with HelpScribble.

.topic 21910
Events

  Key events
                 OnBeginColumn
                 OnBeginDoc
                 OnBeginPage
                 OnEndDoc
                 OnEndPage
                 OnEnterRect
                 OnGetValue
                 OnManualBuild
                 OnMouseOverObject
                 OnObjectClick
                 OnPrintColumn
                 OnPrintReport
                 OnProgress
                 OnUserFunction

This help file was created with HelpScribble.

.topic 21920

Applies to
TfrReport component

Declaration
property Dataset: TfrDataset;

Description
Источник данных для отчета. Используется при значении ReportType = rtMultiple: отчет в этом случае строится для каждой записи из этого источника. Эта возможность особенно удобна для печати многостраничных бланков.

This help file was created with HelpScribble.

.topic 21930
See also

TfrDataset object
TfrUserDataset component
TfrDBDataSet component

This help file was created with HelpScribble.

.topic 21940

Applies to
TfrReport component

Declaration
property EMFPages: TfrEMFPages;

Description
Ссылка на объект - список страниц в построенном отчете.

This help file was created with HelpScribble.

.topic 21950
See also

TfrEMFPages object

This help file was created with HelpScribble.

.topic 21960

Applies to
TfrReport component

Declaration
property GrayedButtons: Boolean;

Description
Если True, то в окне предварительного просмотра используются серые кнопки. Если проект скомпилирован с использованием дизайнера, то эта опция будет доступна и в настройках дизайнера.

This help file was created with HelpScribble.

.topic 21970

Applies to
TfrReport component

Declaration
property ModalPreview: Boolean;

Description
Если True, то окно предварительного просмотра становится модальным (т.е. управление в основную программу возвращается после закрытия окна Preview). Немодальный режим Preview позволяет открыть несколько окон предварительного просмотра и переключаться между ними. Единственное ограничение - каждое окно должно быть связано с отдельным компонентом TfrReport.

This help file was created with HelpScribble.

.topic 21980

Applies to
TfrReport component

Declaration
property Pages: TfrPages;

Description
Ссылка на объект - список страниц отчета. Под страницей понимается страница в режиме дизайнера.

This help file was created with HelpScribble.

.topic 21990
See also

TfrPages object

This help file was created with HelpScribble.

.topic 22000
Pages property example

Пример устанавливает количество колонок на первой странице = 2.

frReport1.Pages[0].ColCount := 2;

This help file was created with HelpScribble.

.topic 22005

Applies to
TfrReport component

Declaration
property Preview: TfrPreview;

Description
Ссылка на объект - компонент предварительного просмотра. Если это свойство пустое, предварительный просмотр отчета будет выполняться в стандартном окне. Иначе отчет будет показан в компоненте.

This help file was created with HelpScribble.

.topic 22010

Applies to
TfrReport component

Declaration
property ReportType: TfrReportType;

Description
Тип отчета. При значении rtMultiple используется источник данных Dataset и отчет строится для каждой записи из этого источника. Эта возможность особенно удобна для печати многостраничных бланков.
По умолчанию значение свойства rtSimple.

This help file was created with HelpScribble.

.topic 22020

Applies to
TfrReport component

Declaration
property ShowProgress: Boolean;

Description
Если True, то при построении, печати, экспорте отчета выводится окно с индикатором прогресса.

This help file was created with HelpScribble.

.topic 22030

Applies to
TfrReport component

Declaration
property StoreInDFM: Boolean;

Description
Определяет способ хранения формы отчета. Если True, то форма отчета сохраняется в DFM-файле, как это делается во всех распространенных генераторах отчетов. По умолчанию это свойство имеет значение False.

This help file was created with HelpScribble.

.topic 22040

Applies to
TfrReport component

Declaration
property Title: String;

Description
Заголовок отчета. Показывается в окне прогресса, в окне предварительного просмотра и присваивается печатаемому документу.

This help file was created with HelpScribble.

.topic 22050

Applies to
TfrReport component

Declaration
function FindObject(Name: String): TfrView;

Description
Возвращает ссылку на объект с именем Name.

This help file was created with HelpScribble.

.topic 22060
See also

TfrPage.FindObject method

This help file was created with HelpScribble.

.topic 22070

Applies to
TfrReport component

Declaration
function PrepareReport: Boolean;

Description
Запускает построение отчета. Если пользователь прервал процесс, возвращает ложь.

This help file was created with HelpScribble.

.topic 22080
See also

ShowReport method

This help file was created with HelpScribble.

.topic 22090

Applies to
TfrReport component

Declaration
procedure DesignReport;

Description
Запускает дизайнер. Если проект скомпилирован без использования дизайнера, этот метод ничего не делает.

This help file was created with HelpScribble.

.topic 22100

Applies to
TfrReport component

Declaration
procedure EditPreparedReport(PageIndex: Integer);

Description
Запускает дизайнер для редактирования страницы PageIndex построенного отчета. Если проект скомпилирован без использования дизайнера, этот метод ничего не делает. Предполагается, что отчет был построен ранее вызовом метода PrepareReport либо загружен из файла методом LoadPreparedReport.

This help file was created with HelpScribble.

.topic 22110

Applies to
TfrReport component

Declaration
procedure ExportTo(Filter: TfrExportFilter; FileName: String);

Description
Выполняет экспорт отчета в файл FileName с использованием фильтра экспорта Filter. Предполагается, что отчет был построен ранее вызовом метода PrepareReport либо загружен из файла методом LoadPreparedReport.

This help file was created with HelpScribble.

.topic 22120
ExportTo method example

procedure TForm1.ExpButtonClick(Sender: TObject);
begin
  frReport1.PrepareReport;
  frReport1.ExportTo(frRTFExportFilter1, 'export.rtf');
  // класс TfrRTFExportFilter определен в модуле FR_E_RTF.pas
end;

This help file was created with HelpScribble.

.topic 22130

Applies to
TfrReport component

Declaration
procedure GetVariableValue(const s: String; var v: Variant);

Description
Возвращает значение переменной s в параметре v.

This help file was created with HelpScribble.

.topic 22140

Applies to
TfrReport component

Declaration
procedure LoadFromDB(Table: TDataSet; DocN: Integer);

Description
Считывает содержимое документа под номером DocN из таблицы БД. Структура таблицы простая: первое поле целое - это номер документа, а второе - типа BLOb - форма документа.

This help file was created with HelpScribble.

.topic 22150
See also

LoadFromFile method
LoadFromStream method

This help file was created with HelpScribble.

.topic 22160

Applies to
TfrReport component

Declaration
procedure LoadFromFile(FName: String);

Description
Считывает содержимое документа из файла. Расширение файла должно быть .frf (FastReport Form).

This help file was created with HelpScribble.

.topic 22170
See also

LoadFromDB method
LoadFromStream method

This help file was created with HelpScribble.

.topic 22180

Applies to
TfrReport component

Declaration
procedure LoadFromStream(Stream: TStream);

Description
Считывает содержимое документа из потока.

This help file was created with HelpScribble.

.topic 22190
See also

LoadFromDB method
LoadFromFile method

This help file was created with HelpScribble.

.topic 22200

Applies to
TfrReport component

Declaration
procedure LoadPreparedReport(FName: String);

Description
Считывает содержимое ранее построенного отчета из файла с именем FName. Расширение файла должно быть .frp (FastReport Prepared report).

This help file was created with HelpScribble.

.topic 22210
See also

SavePreparedReport method

This help file was created with HelpScribble.

.topic 22220

Applies to
TfrReport component

Declaration
procedure LoadTemplate(fname: String; comm: TStrings; Bmp: TBitmap; Load: Boolean);

Description
Считывает шаблон документа из файла с именем fname. Комментарий к шаблону считывается в параметр comm, рисунок - в Bmp. Объекты comm и Bmp должны быть созданы перед вызовом этой процедуры. Параметр Load указывает, надо ли загружать собственно документ. Расширение файла должно быть .frt (FastReport Template).

This help file was created with HelpScribble.

.topic 22230
See also

SaveTemplate method

This help file was created with HelpScribble.

.topic 22240

Applies to
TfrReport component

Declaration
procedure PrintPreparedReport(PageNumbers: String; Copies: Integer;
      Collate: Boolean; PrintPages: TfrPrintPages);

Description
Печатает отчет. На печать выводятся страницы, перечисленные в строке PageNumbers, например, "1,3,5-12". Если строка PageNumbers пустая, то печатаются все страницы. Параметр Copies определяет количество печатаемых копий. Параметр Collate определяет, надо ли разбирать отчет по компиям. Параметр PrintPages определяет, какие страницы выводить на печать - все, четные или нечетные.
Предполагается, что отчет был построен ранее вызовом метода PrepareReport либо загружен из файла методом LoadPreparedReport.

This help file was created with HelpScribble.

.topic 22250

Applies to
TfrReport component

Declaration
procedure SavePreparedReport(FName: String);

Description
Записывает построенный отчет в файл FName. Расширение файла должно быть .frp (FastReport Prepared report).

This help file was created with HelpScribble.

.topic 22260
See also

LoadPreparedReport method

This help file was created with HelpScribble.

.topic 22270

Applies to
TfrReport component

Declaration
procedure SaveTemplate(fname: String; comm: TStrings; Bmp: TBitmap);

Description
Записывает форму документа как шаблон с именем fname. Комментарий и рисунок к шаблону передаются в виде параметров comm и Bmp. Расширение файла должно быть .frt (FastReport Template).

This help file was created with HelpScribble.

.topic 22280
See also

LoadTemplate method

This help file was created with HelpScribble.

.topic 22290

Applies to
TfrReport component

Declaration
procedure SaveToDB(Table: TDataSet; DocN: Integer);

Description
Записывает содержимое документа в таблицу БД под номером DocN. Структура таблицы простая: первое поле целое - это номер документа, а второе - типа BLOb - форма документа.

This help file was created with HelpScribble.

.topic 22300
See also

SaveToFile method
SaveToStream method

This help file was created with HelpScribble.

.topic 22310

Applies to
TfrReport component

Declaration
procedure SaveToFile(FName: String);

Description
Записывает содержимое документа в файл. Расширение файла должно быть .frf (FastReport Form).

This help file was created with HelpScribble.

.topic 22320
See also

SaveToDB method
SaveToStream method

This help file was created with HelpScribble.

.topic 22330

Applies to
TfrReport component

Declaration
procedure SaveToStream(Stream: TStream);

Description
Записывает содержимое документа в поток.

This help file was created with HelpScribble.

.topic 22340
See also

SaveToDB method
SaveToFile method

This help file was created with HelpScribble.

.topic 22350

Applies to
TfrReport component

Declaration
procedure ShowPreparedReport;

Description
Выполняет предварительный просмотр отчета. Предполагается, что отчет был построен ранее вызовом метода PrepareReport либо загружен из файла методом LoadPreparedReport. После закрытия окна предварительного просмотра построенный отчет разрушается.

This help file was created with HelpScribble.

.topic 22360
See also

PrepareReport method
ShowReport method

This help file was created with HelpScribble.

.topic 22370

Applies to
TfrReport component

Declaration
procedure ShowReport;

Description
Запускает построение отчета и его преварительный просмотр. После закрытия окна предварительного просмотра построенный отчет разрушается.

This help file was created with HelpScribble.

.topic 22380
See also

PrepareReport method
ShowPreparedReport method

This help file was created with HelpScribble.

.topic 22390

Applies to
TfrReport component

Declaration
property OnBeginColumn: TBeginColumnEvent;

Description
Обработчик события вызывается при формировании отчета с переменным количеством столбцов. Параметр Band показывает, для какого бэнда в данный момент строится многоколоночная часть. Обработчик может быть полезен для переключения источника данных (т.к. многоколоночная часть может иметь заголовок, данные первого уровня, второго и пр., для которых используются разные источники данных).

This help file was created with HelpScribble.

.topic 22400

Applies to
TfrReport component

Declaration
property OnBeginDoc: TBeginDocEvent;

Description
Обработчик события вызывается перед началом формирования отчета.

This help file was created with HelpScribble.

.topic 22410
See also

OnEndDoc event

This help file was created with HelpScribble.

.topic 22420

Applies to
TfrReport component

Declaration
property OnBeginPage: TBeginPageEvent;

Description
Обработчик события вызывается перед началом формирования страницы.

This help file was created with HelpScribble.

.topic 22430
See also

OnEndPage event

This help file was created with HelpScribble.

.topic 22440

Applies to
TfrReport component

Declaration
property OnEndDoc: TEndDocEvent;

Description
Обработчик события вызывается после окончания формирования отчета.

This help file was created with HelpScribble.

.topic 22450
See also

OnBeginDoc event

This help file was created with HelpScribble.

.topic 22460

Applies to
TfrReport component

Declaration
property OnEndPage: TEndPageEvent;

Description
Обработчик события вызывается после окончания формирования страницы.

This help file was created with HelpScribble.

.topic 22470
See also

OnBeginPage event

This help file was created with HelpScribble.

.topic 22480

Applies to
TfrReport component

Declaration
property OnBeforePrint: TEnterRectEvent;

Description
Обработчик события вызывается перед отображением каждого объекта. Ссылка View позволяет манипулировать свойствами объекта. Это событие наиболее часто применяется для загрузки картинки из файла в объект TfrPictureView.

This help file was created with HelpScribble.

.topic 22490
OnBeforePrint event example

procedure TForm1.frReport1BeforePrint(Memo: TStringList; View: TView);
begin
  if Memo.Count > 0 then
    if Memo[0] = '[Memo]' then
      Memo.Assign(Table1Memo)
    else if (Memo[0] = '[Picture]') and (View is TPictureView) then
     (View as TPictureView).Picture.Assign(Table1Picture);
end;

This help file was created with HelpScribble.

.topic 22500

Applies to
TfrReport component

Declaration
property OnGetValue: TDetailEvent;

Description
Обработчик события вызывается, если в тексте обнаружена переменная ParName. Значение переменной должно быть помещено в ParValue.

This help file was created with HelpScribble.

.topic 22510
OnGetValue event example

procedure TForm1.frReport1GetValue(const ParName: string; var ParValue: Variant);
begin
  if ParName = 'Var1' then
    ParValue := '1'
  else if ParName = 'Var2' then
    ParValue := 2
end;

This help file was created with HelpScribble.

.topic 22520

Applies to
TfrReport component

Declaration
property OnManualBuild: TManualBuildEvent;

Description
Обработчик этого события позволяет вручную (т.е. с помощью кода) построить отчет. Если обработчик не назначен, то отчет строится как обычно. При построении отчета вручную можно управлять порядком вывода бэндов.

This help file was created with HelpScribble.

.topic 22530
OnManualBuild event example

procedure TForm1.frReport1ManualBuild(Page: TfrPage);
begin
  with Page do
  begin
    ShowBandByType(btReportTitle);
    ShowBandByName('Band1');
    ShowBandByName('Band1');
    ShowBandByName('Band2');
    NewPage;
    ShowBandByName('Band1');
    ShowBandByType(btReportSummary);
  end;
end;

This help file was created with HelpScribble.

.topic 22540

Applies to
TfrReport component

Declaration
property OnProgress: TProgressEvent;

Description
Обработчик события вызывается для индикации прогресса выполнения текущей работы (построение отчета, печать, экспот). На этот обработчик можно повесить свою процедуру отображения прогресса.

This help file was created with HelpScribble.

.topic 22550

Applies to
TfrReport component

Declaration
property OnUserFunction: TFunctionEvent;

Description
Cобытие вызывается, когда в тексте объекта обнаружена переменная или выражение, содержащее вызов функции.

This help file was created with HelpScribble.

.topic 22560
OnUserFunction event example

procedure TForm1.frReport1UserFunction(const name: string; p1, p2, p3: Variant; var val: string);
var
  d: Double;
begin
  if name <> 'CRAZYMONEY' then exit;
  d := Parser.Calc(p1);
  // для использования парсера необходимо включить в список uses FR_Pars.pas
  if d > 10000 then
    val := '''' + FormatFloat('#,##0.00',d) + ' - ого!' + ''''
  else
    val := '''' + FormatFloat('#,##0.00',d) + '''';
  // результат - это форматированная строка, поэтому заключаем в кавычки
end;

This help file was created with HelpScribble.

.topic 22565

Applies to
TfrReport component

Declaration
property OnPrintColumn: TPrintColumnEvent;

Description
Cобытие вызывается при формировании столбцов cross-tab отчета. Обработчику события передается номер столбца и его ширина по умолчанию. Меняя ширину, можно получить cross-tab отчет с различной шириной столбцов. При этом надо также изменять ширину объекта(ов), находящегося в ячейке таблицы.

This help file was created with HelpScribble.

.topic 22567
OnPrintColumn event example

const
  ColWidths: Array[0..4] of Integer = (40, 50, 60, 70, 100);
var
  i: Integer;

procedure TForm1.frReport1PrintColumn(ColNo: Integer; var Width: Integer);
begin
  if ColNo in [0..3] then
    Width := ColWidths[ColNo] else
    Width := ColWidths[4];
  i := ColNo;
end;

procedure TForm1.frReport1EnterRect(Memo: TStringList; View: TView);
begin
  if View.Name = 'Memo1' then
    if i in [0..3] then
      View.dx := ColWidths[i] else
      View.dx := ColWidths[4];
end;

This help file was created with HelpScribble.

.topic 22580
See also

<<< See also of TfrCompositeReport component >>>

This help file was created with HelpScribble.

.topic 22590
Properties

  Run-time only		  Key properties
                 EMFPages
                GrayedButtons
                ModalPreview
                  Reports
                ShowProgress
                Title

This help file was created with HelpScribble.

.topic 22600
Methods

  Key methods
                PrepareReport
                EditPreparedReport
                ExportTo
                LoadPreparedReport
                PrintPreparedReport
                SavePreparedReport
                ShowPreparedReport
                ShowReport

This help file was created with HelpScribble.

.topic 22610
Events

  Key events
                OnBeginDoc
                OnEndDoc
                OnProgress

This help file was created with HelpScribble.

.topic 22640

Applies to
TfrCompositeReport component

Declaration
property Reports: TList;

Description
Список отчетов композитного отчета.

This help file was created with HelpScribble.

.topic 22660
Reports property example

procedure TForm1.BuildBtnClick(Sender: TObject);
begin
  frComposite1.Reports.Clear;
  frComposite1.Reports.Add(frReport1);
  frComposite1.Reports.Add(frReport2);
  frComposite1.ShowReport;
end;

This help file was created with HelpScribble.

.topic 22840
Properties

  Key properties
                 List

This help file was created with HelpScribble.

.topic 22850
Methods

  Key methods
                 OnFunction
                 DoFunction

This help file was created with HelpScribble.

.topic 22860

Applies to
TfrFunctionLibrary object

Declaration
property List: TStringList;

Description
Представляет собой список имен функций, в алфавитном порядке и в верхнем регистре.

This help file was created with HelpScribble.

.topic 22870

Applies to
TfrFunctionLibrary object

Declaration
function OnFunction(const FName: String; p1, p2, p3: Variant; var val: String): Boolean;

Description
Метод просматривает список List на наличие функции FName. Если функция найдена, она обрабатывается методом DoFunction.

This help file was created with HelpScribble.

.topic 22880

Applies to
TfrFunctionLibrary object

Declaration
procedure DoFunction(FNo: Integer; p1, p2, p3: Variant; var val: String); virtual; abstract;

Description
Выполняет функцию с порядковым номером FNo в списке List.

This help file was created with HelpScribble.

.topic 22890
DoFunction method example

Это фрагмент метода DoFunction стандартной библиотеки функций TfrStdFunctionLibrary:

procedure TfrStdFunctionLibrary.DoFunction(FNo: Integer; p1, p2, p3: Variant;
  var val: String);
var
  ...
begin
  case FNo of
// AVG
    0: dk := dkAvg;
// COUNT
    1: dk := dkCount;
// FORMATDATETIME
    2: val := '''' + FormatDateTime(Parser.Calc(p1), Parser.Calc(p2)) + '''';
// FORMATFLOAT
    3: val := '''' + FormatFloat(Parser.Calc(p1), Parser.Calc(p2)) + '''';
// INPUT
    4:
      begin
        s1 := InputBox('', Parser.Calc(p1), Parser.Calc(p2));
        val := '''' + s1 + '''';
      end;
// LOWERCASE
    5: val := '''' + AnsiLowerCase(Parser.Calc(p1)) + '''';
// MAX
    6: dk := dkMax;
// MIN
    7: dk := dkMin;
// NAMECASE
    8:
      begin
        s1 := AnsiLowerCase(Parser.Calc(p1));
        if Length(s1) > 0 then
          val := '''' + AnsiUpperCase(s1[1]) + Copy(s1, 2, Length(s1) - 1) + ''''
        else
          val := '''' + '''';
      end;
// STRTODATE
    9: val := '%d''' + Parser.Calc(p1) + '''';
// STRTOTIME
    10: val := '%t''' + Parser.Calc(p1) + '''';
// SUM
    11: dk := dkSum;
// UPPERCASE
    12: val := '''' + AnsiUpperCase(Parser.Calc(p1)) + '''';
  end;
  ...
end;

This help file was created with HelpScribble.

.topic 22900

Unit
FR_Class

Declaration
type
TBeginColumnEvent = procedure(Band: TfrBand) of object;

Description
Тип определен для события OnBeginColumn компонента TfrReport.

This help file was created with HelpScribble.

.topic 22910
See also

OnBeginColumn event

This help file was created with HelpScribble.

.topic 22920

Unit
FR_Class

Declaration
type
TBeginDocEvent = procedure(Sender: TObject) of object;

Description
Тип определен для события OnBeginDoc компонента TfrReport.

This help file was created with HelpScribble.

.topic 22930
See also

OnBeginDoc event

This help file was created with HelpScribble.

.topic 22940

Unit
FR_Class

Declaration
type
TBeginPageEvent = procedure(pg: Integer; MasterMemo, DetailMemo, SubDetailMemo: TStringList) of object;

Description
Тип определен для события OnBeginPage компонента TfrReport.

This help file was created with HelpScribble.

.topic 22950
See also

OnBeginPage event

This help file was created with HelpScribble.

.topic 22960

Unit
FR_Class

Declaration
type
TDetailEvent = procedure(const ParName: String; var ParValue: Variant) of object;

Description
Тип определен для события OnGetValue компонента TfrReport.

This help file was created with HelpScribble.

.topic 22970
See also

OnGetValue event

This help file was created with HelpScribble.

.topic 22980

Unit
FR_Class

Declaration
type
TEndDocEvent = procedure(Sender: TObject) of object;

Description
Тип определен для события OnEndDoc компонента TfrReport.

This help file was created with HelpScribble.

.topic 22990
See also

OnEndDoc event

This help file was created with HelpScribble.

.topic 23000

Unit
FR_Class

Declaration
type
TEndPageEvent = procedure(pg: Integer) of object;

Description
Тип определен для события OnEndPage компонента TfrReport.

This help file was created with HelpScribble.

.topic 23010
See also

OnEndPage event

This help file was created with HelpScribble.

.topic 23020

Unit
FR_Class

Declaration
type
TEnterRectEvent = procedure(Memo: TStringList; View: TfrView) of object;

Description
Тип определен для события OnBeforePrint компонента TfrReport.

This help file was created with HelpScribble.

.topic 23030
See also

OnBeforePrint event

This help file was created with HelpScribble.

.topic 23040

Unit
FR_Class

Declaration
type
TfrBandType = (btReportTitle, btReportSummary,
               btPageHeader, btPageFooter,
               btMasterHeader, btMasterData, btMasterFooter,
               btDetailHeader, btDetailData, btDetailFooter,
               btSubDetailHeader, btSubDetailData, btSubDetailFooter,
               btOverlay, btColumnHeader, btColumnFooter,
               btGroupHeader, btGroupFooter,
           btCrossHeader, btCrossData, btCrossFooter, btChild, btNone);

Description
Возможные типы бэндов.

This help file was created with HelpScribble.

.topic 23050
See also

BandType property

This help file was created with HelpScribble.

.topic 23060

Unit
FR_Class

Declaration
type
TfrHighlightAttr = packed record
  FontStyle: Word;
  FontColor, FillColor: TColor;
end;

Description
Атрибуты выделения объекта TfrMemoView. Включают в себя стиль шрифта FontStyle и его цвет FontColor, а также цвет фона прямоугольника FillColor. Объект выводится с использованием этих атрибутов, если условие выделения истинно.

This help file was created with HelpScribble.

.topic 23070
See also

Highlight field

This help file was created with HelpScribble.

.topic 23080

Unit
FR_Class

Declaration
type
TfrReportType = (rtSimple, rtMultiple);

Description
Возможные типы отчета.

This help file was created with HelpScribble.

.topic 23090
See also

ReportType property

This help file was created with HelpScribble.

.topic 23100

Unit
FR_Class

Declaration
type
TfrRgnType = (rtNormal, rtExtended);

Description
Возможные типы регионов для функции GetClipRGN.

This help file was created with HelpScribble.

.topic 23110
See also

GetClipRgn method

This help file was created with HelpScribble.

.topic 23120

Unit
FR_Class

Declaration
type
TManualBuildEvent = procedure(Page: TfrPage) of object;

Description
Тип определен для события OnManualBuild компонента TfrReport.

This help file was created with HelpScribble.

.topic 23130
See also

OnManualBuild event

This help file was created with HelpScribble.

.topic 23135

Unit
FR_Class

Declaration
type
TPrintColumnEvent = procedure(ColNo: Integer; var Width: Integer) of object;

Description
Тип определен для события OnPrintColumn компонента TfrReport.

This help file was created with HelpScribble.

.topic 23137
See also

OnPrintColumn event

This help file was created with HelpScribble.

.topic 23140

Unit
FR_Class

Declaration
type
TProgressEvent = procedure(n: Integer) of object;

Description
Тип определен для события OnProgress компонента TfrReport.

This help file was created with HelpScribble.

.topic 23150
See also

OnProgress event

This help file was created with HelpScribble.

.topic 23160

Unit
FR_Class

Declaration
function frCreateObject(Typ: Byte; const ClassName: String): TfrView;

Description
Функция создает объект с заданным типом Typ. Если объект типа Add-in, то надо указывать и имя класса ClassName.

This help file was created with HelpScribble.

.topic 23170

Unit
FR_Class

Declaration
procedure frRegisterExportFilter(ClassRef: TClass; const FilterDesc, FilterExt: String);

Description
Регистрирует в системе фильтр экспорта.

This help file was created with HelpScribble.

.topic 23180

Unit
FR_Class

Declaration
procedure frRegisterFunctionLibrary(ClassRef: TClass);

Description
Регистрирует в системе библиотеку функций.

This help file was created with HelpScribble.

.topic 23190

Unit
FR_Class

Declaration
procedure frRegisterObject(ClassRef: TClass; ButtonBmp: TBitmap; const ButtonHint: String; EditorForm: TfrObjEditorForm);

Description
Регистрирует в системе визуальный объект.

This help file was created with HelpScribble.

.topic 23200

Unit
FR_Class

Declaration
procedure frRegisterTool(MenuCaption: String; ButtonBmp: TBitmap; OnClick: TNotifyEvent);

Description
Регистрирует в системе мастер. Мастер - это Add-in, подключаемый к дизайнеру.

This help file was created with HelpScribble.

.topic 23210

Unit
FR_Class

Description
Объект представляет собой компрессор для упаковки/распаковки содержимого построеноого отчета. При записи отчета в файл .FRP содержимое страниц упаковывается, что резко сокращает объем файла. При чтении файла происходит распаковка содержимого.

Объект содержит два метода: Compress для упаковки и DeCompress для распаковки. Оба метода пустые и предназначены для перекрытия в потомках объекта. Для придания объекту нужной функциональности следует завести его потомка с переопределенными методами и присвоить его указатель глобальной переменной frCompressor. В качестве утилит компрессии/декомпрессии можно использовать любые подходящие компоненты (VCLZip, TZipTV и пр.), позволяющие выполнять операции "поток-поток".

This help file was created with HelpScribble.

.topic 23220
Properties

  Key properties
                 Enabled

This help file was created with HelpScribble.

.topic 23230
Methods

  Key methods
                 Compress
                 DeCompress

This help file was created with HelpScribble.

.topic 23235
TfrCompressor example

type
  TMyCompressor = class(TfrCompressor)
  public
    procedure Compress(StreamIn, StreamOut: TStream); override;
    procedure DeCompress(StreamIn, StreamOut: TStream); override;
  end;

procedure TMyCompressor.Compress(StreamIn, StreamOut: TStream);
begin
  ZipStream(StreamIn, StreamOut); // собственно компрессия.
end;

procedure TMyCompressor.DeCompress(StreamIn, StreamOut: TStream);
begin
  UnZipStream(StreamIn, StreamOut);
end;

...
  frCompressor.Free; // удаляем стандартный компрессор
  frCompressor := TMyCompressor.Create;
  frCompressor.Enabled := True;
...

This help file was created with HelpScribble.

.topic 23240

Applies to
TfrCompressor object

Declaration
Enabled: Boolean;

Description
Если установлено в True, то при записи файла .FRP происходит его компрессия. По умолчанию False.

This help file was created with HelpScribble.

.topic 23250

Applies to
TfrCompressor object

Declaration
procedure Compress(StreamIn, StreamOut: TStream); virtual;

Description
Метод осуществляет компрессию потока StreamIn в поток StreamOut. У класса TfrCompressor этот метод пустой - его необходимо переопределять для придания нужной функциональности.

This help file was created with HelpScribble.

.topic 23260

Applies to
keepn

Applies to
TfrCompressor object

Declaration
procedure DeCompress(StreamIn, StreamOut: TStream); virtual;

Description
Метод осуществляет декомпрессию потока StreamIn в поток StreamOut. У класса TfrCompressor этот метод пустой - его необходимо переопределять для придания нужной функциональности.

This help file was created with HelpScribble.

.topic 24000

Модуль содержит описания некоторых компонентов и объектов FastReport.

Components
TfrDesigner

This help file was created with HelpScribble.

.topic 24012
Properties

  Run-time only		  Key properties
                 TemplateDir

This help file was created with HelpScribble.

.topic 24020

Applies to
TfrDesigner component

Declaration
property TemplateDir: String;

Description
Имя каталога, в котором находятся шаблоны отчетов. Используется при создании отчета на основе шаблона.

This help file was created with HelpScribble.

.topic 24030

Модуль содержит описания некоторых компонентов и объектов FastReport.

Components
TfrPreview

This help file was created with HelpScribble.

.topic 24040

Unit
FR_View

Description
Компонент TfrPreview предназначен для создания окон предварительного просмотра, определяемых пользователем. При подключении компонента к генератору отчета TfrReport вывод отчета происходит не в стандартное окно Preview, а в подключенный компонент.

This help file was created with HelpScribble.

.topic 24050
Properties

  Run-time only		  Key properties
                 ScrollBars

This help file was created with HelpScribble.

.topic 24060

Applies to
TfrPreview component

Declaration
property ScrollBars: TScrollStyle;

Description
Свойство определяет, какие полосы прокрутки показывать в компоненте. Возможные значения - ssHorizontal, ssVertical, ssBoth (по умочанию), ssNone.

This help file was created with HelpScribble.

.topic 30030
Applies to
TfrView class

Declaration
property BandAlign: Byte;

Description
Выравнивание объекта относительно его бэнда. Одно из значений frbaXXXX:

  baNone = 0;		//Выводить объект без выравнивания по бэнду.
  baLeft = 1;		//Прижать объект к левому краю бэнда.
  baRight = 2;		//Прижать объект к правому краю бэнда.
  baCenter = 3;		//Центрировать объект внутри бэнда по горизонтали.
  baWidth = 4;		//Растянуть объект по ширине бэнда.
  baBottom = 5;		//Прижать объект к нижнему краю бэнда.

This help file was created with HelpScribble.

.topic 30035
Applies to
TfrView class

Declaration
property gapx: Integer;

Description
Отступ текста слева от рамки объекта.
Run-time only

This help file was created with HelpScribble.

.topic 30040
Applies to
TfrView class

Declaration
property gapy: Integer;

Description
Отступ текста сверху от рамки объекта.
Run-time only

This help file was created with HelpScribble.

.topic 30045
Applies to
TfrView class

Declaration
property HVersion: Byte;

Description
Версия компонента. Старшая часть (HVersion) фиксирована и изменению не подлежит. Младшую часть (LVersion) можно менять перед записью объекта в поток (перед вызовом inherited SaveToStream). Версию надо менять при изменениях в свойствах объекта (например, при добавлении новых свойств, изменении формата или удалении старых свойств). Проверку на номер версии надо делать в методе LoadFromStream.
Run-time only

This help file was created with HelpScribble.

.topic 30050
Applies to
TfrView class

Declaration
property LVersion: Byte;

Description
Версия компонента. Старшая часть (HVersion) фиксирована и изменению не подлежит. Младшую часть (LVersion) можно менять перед записью объекта в поток (перед вызовом inherited SaveToStream). Версию надо менять при изменениях в свойствах объекта (например, при добавлении новых свойств, изменении формата или удалении старых свойств). Проверку на номер версии надо делать в методе LoadFromStream.
Run-time only

This help file was created with HelpScribble.

.topic 30055
Applies to
TfrView class

Declaration
property Restrictions: Word;

Description
Набор флагов, запрещающих те или иные действия над объектом в режиме дизайнера. Например, можно запретить удаление или перемещение объекта.

  frrfDontEditMemo = 1;		//Запретить редактировать мемо объекта.
  frrfDontEditScript = 2;		//Запретить редактировать скрипт объекта.
  frrfDontEditContents = 4;		//Запретить вызов редактора объекта.
  frrfDontModify = 8;		//Запретить модификацию объекта (например, смену шрифта).
  frrfDontSize = 16;		//Запретить изменение размеров объекта.
  frrfDontMove = 32;		//Запретить сдвигать объект.
  frrfDontDelete = 64;		//Запретить удалять объект.

This help file was created with HelpScribble.

.topic 30060
Applies to
TfrView class

Declaration
property Tag: String;

Description
Идентификатор объекта. Строка, которая может содержать переменные. Это свойство нужно для поддержки "живых отчетов", когда в окне preview пользователь может нажать на объект и при этом выполнится какое-либо действие (например, построится другой отчет). Цель свойства - облегчить распознавание нажатого объекта. Например, объект может содержать текст "12.25р", по которому идентификация невозможна. Но в свойство Tag можно поместить более развернутую информацию, например, значение ключа таблицы, из которой был получен текст "12.25р", номер строки или колонки в отчете, и пр.
Run-time only

This help file was created with HelpScribble.

.topic 30065
Applies to
TfrView class

Declaration
procedure ShowEditor; virtual;

Description
Метод вызывается при редактировании содержимого объекта. Метод должен вызвать диалоговое окно редактора объекта.

This help file was created with HelpScribble.

.topic 30080
Applies to
TfrBandView class

Declaration
property ChildBand: String;

Description
Имя бэнда, который будет выведен после основного бэнда. Аналогично childband в QuickReport.
Run-time only

This help file was created with HelpScribble.

.topic 30085
Applies to
TfrBandView class

Declaration
property ColumnGap: Integer;

Description
Промежуток между колонками бэнда в пикселах.
Run-time only

This help file was created with HelpScribble.

.topic 30090
Applies to
TfrBandView class

Declaration
property Columns: Integer;

Description
Задает количество колонок у бэнда. При этом содержимое бэнда будет выводиться слева направо и сверху вниз.
Run-time only

This help file was created with HelpScribble.

.topic 30095
Applies to
TfrBandView class

Declaration
property ColumnWidth: Integer;

Description
Ширина колонки бэнда.
Run-time only

This help file was created with HelpScribble.

.topic 30100
Applies to
TfrBandView class

Declaration
property Master: String;

Description
Имя дата-бэнда, который будет использован для формирования тела группы в отчетах с группировкой. Применяется в случае, когда на листе отчета присутствует несколько бэндов типа master data.
Run-time only

This help file was created with HelpScribble.

.topic 30115
Applies to
TfrPictureView class

Declaration
property BlobType: Byte;

Description
Тип картинки, хранимой в BLOb-поле таблицы БД. Одно из значений 0 - BMP, 1 - JPEG, 2 - ICO, 3 - WMF/EMF.
Run-time only

This help file was created with HelpScribble.

.topic 30120
Unit
FR_Class

Description
Словарь данных. Содержит список переменных, алиасов таблиц БД, доступных таблиц, а также источников данных для бэндов.

This help file was created with HelpScribble.

.topic 30125
Properties

  Run-time only		  Key properties
                  BandDatasources
                  DisabledDatasets
                  FieldAliases
                  Variables

This help file was created with HelpScribble.

.topic 30130
Methods

  Key methods
                 Clear
                 LoadFromFile
                 LoadFromStream
                 SaveToFile
                 SaveToStream

This help file was created with HelpScribble.

.topic 30135
Applies to
TfrDataDictionary class

Declaration
property BandDatasources: TfrVariables;

Description
Список алиасов источников данных для бэндов, а также список доступных источников (содержимое страницы "Источники данных для бэндов" диалога "Словарь данных").
Run-time only

This help file was created with HelpScribble.

.topic 30140
Applies to
TfrDataDictionary class

Declaration
property DisabledDatasets: TStringList;

Description
Таблицы БД, которые надо скрыть.
Run-time only

This help file was created with HelpScribble.

.topic 30145
Applies to
TfrDataDictionary class

Declaration
property FieldAliases: TfrVariables;

Description
Список алиасов таблиц и полей таблиц БД, а также список доступных таблиц (содержимое страницы "Данные из БД" диалога "Словарь данных").
Run-time only

This help file was created with HelpScribble.

.topic 30150
Applies to
TfrDataDictionary class

Declaration
property Variables: TfrVariables;

Description
Список переменных и категорий (содержимое страницы "Переменные" диалога "Словарь данных").
Run-time only

This help file was created with HelpScribble.

.topic 30155
Applies to
TfrDataDictionary class

Declaration
procedure Clear;

Description
Очищает словарь данных.

This help file was created with HelpScribble.

.topic 30160
Applies to
TfrDataDictionary class

Declaration
procedure LoadFromFile(FName: String);

Description
Считывает словарь данных из файла.

This help file was created with HelpScribble.

.topic 30165
Applies to
TfrDataDictionary class

Declaration
procedure LoadFromStream(Stream: TStream);

Description
Считывает словарь данных из потока.

This help file was created with HelpScribble.

.topic 30170
Applies to
TfrDataDictionary class

Declaration
procedure SaveToFile(FName: String);

Description
Записывает словарь данных в файл.

This help file was created with HelpScribble.

.topic 30175
Applies to
TfrDataDictionary class

Declaration
procedure SaveToStream(Stream: TStream);

Description
Записывает словарь данных в поток.

This help file was created with HelpScribble.

.topic 30200
Applies to
TfrReport component

Declaration
property DefaultCollate: Boolean;

Description
Разбирать ли отчет по копиям при печати - значение по умолчанию, которое предлагается в диалоге печати.

This help file was created with HelpScribble.

.topic 30205
Applies to
TfrReport component

Declaration
property DefaultCopies: Integer;

Description
Количество копий по умолчанию, которое предлагается в диалоге печати.

This help file was created with HelpScribble.

.topic 30210
Applies to
TfrReport component

Declaration
property Dictionary: TfrDataDictionary;

Description
Словарь данных. Содержит список переменных, алиасов таблиц БД, доступных таблиц, а также источников данных для бэндов.
Run-time only

This help file was created with HelpScribble.

.topic 30215
Applies to
TfrReport component

Declaration
property MDIPreview: Boolean;

Description
Определяет, что окно preview надо показывать как MDI child.

This help file was created with HelpScribble.

.topic 30220
Applies to
TfrReport component

Declaration
property MixVariablesAndDBFields: Boolean;

Description
Вывести переменные и поля таблиц БД в одном диалоге ("Вставка поля БД").
Run-time only

This help file was created with HelpScribble.

.topic 30225
Applies to
TfrReport component

Declaration
property Modified: Boolean;

Description
Свойство определяет, был ли модифицирован отчет в дизайнере.
Run-time only

This help file was created with HelpScribble.

.topic 30230
Applies to
TfrReport component

Declaration
function FindObject(Name: String): TfrView;

Description
Найти объект с именем Name.

This help file was created with HelpScribble.

.topic 30235
Applies to
TfrReport component

Declaration
procedure Clear;

Description
Очистить содержимое компонента.

This help file was created with HelpScribble.

.topic 30240
Applies to
TfrReport component

Declaration
procedure LoadFromBlobField(Blob: TField);

Description
Считать отчет из BLOb-поля таблицы БД.

This help file was created with HelpScribble.

.topic 30245
Applies to
TfrReport component

Declaration
procedure PrintPreparedReportDlg;

Description
Печатает подготовленный отчет с выводом окна опций печати.

This help file was created with HelpScribble.

.topic 30250
Applies to
TfrReport component

Declaration
procedure SaveToBlobField(Blob: TField);

Description
Записать отчет в BLOb-поле таблицы БД.

This help file was created with HelpScribble.

.topic 30255
Applies to
TfrReport component

Declaration
property OnMouseOverObject: TMouseOverObjectEvent;

Description
Обработчик события вызывается, если в режиме preview пользователь провел мышкой над каким-либо объектом. Указатель на объект передается в параметре View. Обработчик может вернуть тип мышиного курсора. Таким способом можно показать пользователю, что объект является активным и при нажатии на него выполнится какое-либо действие.

This help file was created with HelpScribble.

.topic 30260
Applies to
TfrReport component

Declaration
property OnObjectClick: TObjectClickEvent;

Description
Обработчик события вызывается, если в режиме preview пользователь нажал мышкой на каком-либо объекте. Указатель на объект передается в параметре View. Обработчик события может выполнить то или иное действие, например, запустить на построение отчет с детальной информацией по нажатому объекту.

This help file was created with HelpScribble.

.topic 30265
Applies to
TfrReport component

Declaration
property OnPrintReport: TPrintReportEvent;

Description
Обработчик события вызывается перед выполнением печати отчета.

This help file was created with HelpScribble.

.topic 30290
Unit
FR_Class

Description
<<< Description of TfrExportFilter component >>>

This help file was created with HelpScribble.

.topic 30295
Properties

  Run-time only		  Key properties
                 ShowDialog

This help file was created with HelpScribble.

.topic 30300
Events

  Key events
                 OnAfterExport
                 OnBeforeExport

This help file was created with HelpScribble.

.topic 30305
Applies to
TfrExportFilter component

Declaration
property ShowDialog: Boolean;

Description
Определяет, надо ли показывать диалог опций фильтра экспорта.

This help file was created with HelpScribble.

.topic 30310
Applies to
TfrExportFilter component

Declaration
property OnAfterExport: TAfterExportEvent;

Description
Обработчик события вызывается после того, как экспорт успешно завершен. Имя файла с результатом экспорта передается в параметре FileName.

This help file was created with HelpScribble.

.topic 30315
Applies to
TfrExportFilter component

Declaration
property OnBeforeExport: TBeforeExportEvent;

Description
Обработчик события вызывается после того, как пользователь выбрал тип фильтра экспорта имя файла в стандартном диалоговом окне "Save file". В обработчике можно подменить имя файла или запретить операцию экспорта (параметр bContinue).

This help file was created with HelpScribble.

.topic 30320
Unit
FR_Class

Description
Класс содержит методы для работы с языковыми ресурсами. Ссылку на экземпляр класса возвращает функция frLocale: TfrLocale.

This help file was created with HelpScribble.

.topic 30325
Properties

  Run-time only		  Key properties
                  LocalizedPropertyNames

This help file was created with HelpScribble.

.topic 30330
Methods

  Key methods
                 LoadBmp
                 LoadStr
                 LoadDll
                 UnloadDll

This help file was created with HelpScribble.

.topic 30335
Events

  Key events
                 OnLocalize

This help file was created with HelpScribble.

.topic 30340
Applies to
TfrLocale class

Declaration
property LocalizedPropertyNames: Boolean;

Description
Свойство определяет, надо ли локализовать имена свойств в инспекторе объектов дизайнера. Имена свойств хранятся в файле fr_lng5.res, в настоящий момент не локализованы. Для локализации см. инструкции в файле fr_lng5.rc.
Run-time only

This help file was created with HelpScribble.

.topic 30345
Applies to
TfrLocale class

Declaration
function LoadBmp(ID: String): HBitmap;

Description
Функция считывает картинку с именем ID из языковых ресурсов. Например, LoadBMP('FR_BOLD').

This help file was created with HelpScribble.

.topic 30350
Applies to
TfrLocale class

Declaration
function LoadStr(ID: Integer): String;

Description
Функция считывает строку с номером ID из строковых ресурсов.

This help file was created with HelpScribble.

.topic 30355
Applies to
TfrLocale class

Declaration
procedure LoadDll(Name: String);

Description
Метод загружает DLL с языковыми ресурсами. После этого все обращения к ресурсам будут использовать ресурсы из DLL. Например, LoadDll('FR_RUS.dll').

This help file was created with HelpScribble.

.topic 30360
Applies to
TfrLocale class

Declaration
procedure UnloadDll;

Description
Метод выгружает DLL, загруженную ранее вызовом LoadDll. После этого все обращения к ресурсам будут использовать ресурсы, прикомпилированные к приложению.

This help file was created with HelpScribble.

.topic 30365
Applies to
TfrLocale class

Declaration
property OnLocalize: TLocalizeEvent;

Description
Обработчик события вызывается каждый раз, когда происходит обращение к строковым языковым ресурсам. Обработчик можно использовать для замещения встроенных ресурсов своими собственными, которые можно хранить в любом удобном месте. Обработчик должен вернуть строку ResultString по ее идентификатору StringID.

This help file was created with HelpScribble.

.topic 30370
Unit
FR_Class

Declaration
type TAfterExportEvent = procedure(const FileName: String); of object;

Description
Тип определен для события OnAfterExport компонента фильтра экспорта.

This help file was created with HelpScribble.

.topic 30375
Unit
FR_Class

Declaration
type TBeforeExportEvent = procedure(var FileName: String; var bContinue: Boolean); of object;

Description
Тип определен для события OnBeforeExport компонента фильтра экспорта.

This help file was created with HelpScribble.

.topic 30380
Unit
FR_Class

Declaration
type TfrDocMode = (dmDesigning, dmPrinting);

Description
Текущий режим: дизайн или формирование отчета (печать).

This help file was created with HelpScribble.

.topic 30385
Unit
FR_Class

Declaration
type TfrPageType = (ptReport, ptDialog);

Description
Тип страницы отчета (обычная страница/диалоговая форма).

This help file was created with HelpScribble.

.topic 30390
Unit
FR_Class

Declaration
type TfrPrintPages = (frAll, frOdd, frEven);

Description
Определяет, какие страницы отчета печатать: все, четные, нечетные.

This help file was created with HelpScribble.

.topic 30395
Unit
FR_Class

Declaration
type TLocalizeEvent = procedure(StringID: Integer; var ResultString: String); of object;

Description
Тип определен для события OnLocalize объекта TfrLocale.

This help file was created with HelpScribble.

.topic 30400
Unit
FR_Class

Declaration
type TMouseOverObjectEvent = procedure(View: TfrView; var Cursor: TCursor); of object;

Description
Тип определен для события OnMouseOverObject компонента TfrReport.

This help file was created with HelpScribble.

.topic 30405
Unit
FR_Class

Declaration
type TObjectClickEvent = procedure(View: TfrView); of object;

Description
Тип определен для события OnObjectClick компонента TfrReport.

This help file was created with HelpScribble.

.topic 30410
Unit
FR_Class

Declaration
type TPrintReportEvent = procedure; of object;

Description
Тип определен для события OnPrintReport компонента TfrReport.

This help file was created with HelpScribble.

.topic 30415
Unit
FR_Class

Declaration
function frLocale: TfrLocale;

Description
Функция возвращает ссылку на экземпляр класса TfrLocale.

This help file was created with HelpScribble.

.topic 30420
Unit
FR_Class

Declaration
procedure frAddFunctionDesc(FuncName, Category, Description: String);

Description
Процедура регистрирует новую функцию (в диалоге "Вставка функции"). Пример:

frAddFunctionDesc('SUMPROPIS', 'Мои функции', 'SUMPROPIS(<Число>)/Возвращает сумму прописью.');

Обратите внимание: символ "/" в описании функции обязателен! Он отделяет описание синтаксиса от описания самой функции.

This help file was created with HelpScribble.


ChartOptions field

Applies to
TfrChartView object

Declaration
ChartOptions: TChartOptions;

Description
Опции диаграммы.


LegendObj property

LegendObj field

Applies to
TfrChartView object

Declaration
LegendObj: String;

Description
Имя объекта, содержимое которого будет использовано как подпись к диаграмме. Для построения диаграммы необходимо указать имена двух объектов типа "Текст", в которых содержится название и соответствующее числовое значение. При построении отчета содержимое этих объектов будет накапливаться в мемо диаграммы.


Top10Label property

Top10Label field

Applies to
TfrChartView object

Declaration
Top10Label: String;

Description
Подпись для диаграммы типа "Top10". Обычно используется слово "Другие".


ValueObj property

ValueObj field

Applies to
TfrChartView object

Declaration
ValueObj: String;

Description
Имя объекта, содержимое которого будет использовано как значения диаграммы. Для построения диаграммы необходимо указать имена двух объектов типа "Текст", в которых содержится название и соответствующее числовое значение. При построении отчета содержимое этих объектов будет накапливаться в мемо диаграммы.


 See also

TfrChartObject component
TfrView object


 Properties

Key properties
ChartOptions
dx
dy
FillColor
Flags
Format
FormatStr
FrameColor
FrameTyp
FrameWidth
IsPrinting
LegendObj
Memo
Name
OffsX
OffsY
Parent
ScaleX
ScaleY
Script
Selected
Top10Label
Typ
ValueObj
Visible
x
y


 Methods

Key methods
GetClipRgn
Assign
CreateUniqueName
DefinePopupMenu
Draw
ExportData
LoadFromStream
Print
SaveToStream
SetBounds


 See also

TfrChartView object


FR_Chart unit

Модуль содержит описания некоторых компонентов и объектов FastReport.

Components
TfrChartObject

Objects
TfrChartView

Types
TChartOptions


 See also

TfrCheckBoxObject component
TfrView object


 Properties

Key properties
dx
dy
FillColor
Flags
Format
FormatStr
FrameColor
FrameTyp
FrameWidth
IsPrinting
Memo
Name
OffsX
OffsY
Parent
ScaleX
ScaleY
Script
Selected
Typ
Visible
x
y


 See also

TfrCheckBoxView object


FR_ChBox unit

Модуль содержит описания некоторых компонентов и объектов FastReport.

Components
TfrCheckBoxObject

Objects
TfrCheckBoxView


OleContainer property

OleContainer field

Applies to
TfrOLEView object

Declaration
OleContainer: TOleContainer;

Description
Ссылка на контейнер с содержащимся в нем объектом OLE.


 See also

TfrOLEObject component
TfrView object


 Properties

Key properties
dx
dy
FillColor
Flags
Format
FormatStr
FrameColor
FrameTyp
FrameWidth
IsPrinting
Memo
Name
OffsX
OffsY
OleContainer
Parent
ScaleX
ScaleY
Script
Selected
Typ
Visible
x
y


 See also

TfrOLEView object


FR_OLE unit

Модуль содержит описания некоторых компонентов и объектов FastReport.

Components
TfrOLEObject

Objects
TfrOLEView


 See also

TfrShapeView object


FR_Shape unit

Модуль содержит описания некоторых компонентов и объектов FastReport.

Components
TfrShapeObject

Objects
TfrShapeView

Constants
skEllipse
skRectangle
skRoundRectangle
skTriangle


 See also

TfrUserDataset component
TfrDBDataSet component


 Properties

Run-time only [image] Key properties
RangeBegin
RangeEnd
RangeEndCount
RecNo


 Methods

Key methods
EOF
Exit
First
Init
Next


 Events

Key events
OnCheckEOF
OnFirst
OnNext


RangeBegin property

See also

Applies to
TfrDataset object

Declaration
property RangeBegin: TRangeBegin;

Description
Определяет начальную точку при навигации по набору данных.


 See also

RangeEnd property
RangeEndCount property


RangeEnd property

See also

Applies to
TfrDataset object

Declaration
property RangeEnd: TRangeEnd;

Description
Определяет конечную точку при навигации по набору данных.


 See also

RangeBegin property
RangeEndCount property


RangeEndCount property

See also

Applies to
TfrDataset object

Declaration
property RangeEndCount: Integer;

Description
Определяет максимальное количество записей в наборе, по которым будет осуществляться навигация. При этом свойство RangeEnd должно быть установлено в reCount.

Таким образом, для просмотра первых 20 записей надо установить RangeBegin = rbFirst, RangeEnd = reCount и RangeEndCount = 20.


 See also

RangeBegin property
RangeEnd property


RecNo property

See also

Applies to
TfrDataset object

Declaration
property RecNo: Integer;

Description
Возвращает текущую позицию указателя.


EOF method

See also

Applies to
TfrDataset object

Declaration
function EOF: Boolean; virtual;

Description
Функция возвращает истину, если достигнут конец набора данных.


 See also

First method
Next method
OnCheckEOF event


Exit method

See also

Applies to
TfrDataset object

Declaration
procedure Exit; virtual;

Description
Метод вызывается в конце работы с набором данных. Устанавливает указатель на запись, которая была текущей при вызове метода Init.


 See also

Init method


First method

See also

Applies to
TfrDataset object

Declaration
procedure First; virtual;

Description
Метод устанавливает указатель на первую запись в наборе данных. Если свойство RangeBegin установлено в rbCurrent, то указатель устанавливается на запись, которая была текущей при начале работы с набором данных (до вызова метода Init).


 See also

Next method
EOF method
OnFirst event


Init method

See also

Applies to
TfrDataset object

Declaration
procedure Init; virtual;

Description
Выполняет инициализацию набора данных и запоминает текущую позицию указателя.


 See also

Exit method


Next method

See also

Applies to
TfrDataset object

Declaration
procedure Next; virtual;

Description
Перемещает указатель на следующую запись в наборе данных.


 See also

First method
EOF method
OnNext event


OnCheckEOF event

See also

Applies to
TfrDataset object

Declaration
property OnCheckEOF: TCheckEOFEvent;

Description
Обработчик события вызывается каждый раз при вызове функции EOF.


 See also

EOF method


OnFirst event

See also

Applies to
TfrDataset object

Declaration
property OnFirst: TNotifyEvent;

Description
Обработчик события вызывается каждый раз при вызове функции First.


 See also

First method


OnNext event

See also

Applies to
TfrDataset object

Declaration
property OnNext: TNotifyEvent;

Description
Обработчик события вызывается каждый раз при вызове функции Next.


 See also

Next method


FR_DSet unit

Модуль содержит описания некоторых компонентов и объектов FastReport.

Components
TfrUserDataset

Objects
TfrDataset

Types
TCheckEOFEvent
TRangeBegin
TRangeEnd


 See also

TfrDataset object
TfrUserDataset component


 Properties

Run-time only [image] Key properties
CloseDataSource
DataSource
OpenDataSource
RangeBegin
RangeEnd
RangeEndCount
RecNo


 Methods

Key methods
Close
EOF
Exit
First
Init
Next
Open


 Events

Key events
OnCheckEOF
OnClose
OnFirst
OnNext
OnOpen


CloseDataSource property

See also

Applies to
TfrDBDataSet component

Declaration
property CloseDataSource: Boolean;

Description
Определяет, надо ли закрывать таблицу БД после окончания работы с набором данных. По умолчанию False.


 See also

DataSource property
OpenDataSource property
OnClose event


DataSource property

See also

Applies to
TfrDBDataSet component

Declaration
property DataSource: TDataSource;

Description
Источник данных - связка TDataSource -> TDataSet.


 See also

OpenDataSource property
CloseDataSource property


OpenDataSource property

See also

Applies to
TfrDBDataSet component

Declaration
property OpenDataSource: Boolean;

Description
Определяет, надо ли открывать таблицу БД перед началом работы с ней. По умолчанию - True.


 See also

DataSource property
CloseDataSource property
OnOpen event


Close method

See also

Applies to
TfrDBDataSet component

Declaration
procedure Close;

Description
Закрывает таблицу БД.


 See also

Open method
CloseDataSource property
OnClose event


Open method

See also

Applies to
TfrDBDataSet component

Declaration
procedure Open;

Description
Открывает таблицу БД.


 See also

Close method
OpenDataSource property
OnOpen event


OnClose event

See also

Applies to
TfrDBDataSet component

Declaration
property OnClose: TNotifyEvent;

Description
Обработчик события вызывается каждый раз при вызове функции Close.


 See also

Close method


OnOpen event

See also

Applies to
TfrDBDataSet component

Declaration
property OnOpen: TNotifyEvent;

Description
Обработчик события вызывается каждый раз при вызове функции Open.


 See also

Open method


FR_DBSet unit

Модуль содержит описания некоторых компонентов и объектов FastReport.

Components
TfrDBDataSet


ShapeType property

ShapeType field

Applies to
TfrShapeView object

Declaration
ShapeType: Byte;

Description
Тип фигуры. Одно из значений skRectangle, skRoundRectangle, skEllipse, skTriangle.


 See also

TfrShapeObject component
TfrView object


 Properties

Key properties
dx
dy
FillColor
Flags
Format
FormatStr
FrameColor
FrameTyp
FrameWidth
IsPrinting
Memo
Name
OffsX
OffsY
Parent
ScaleX
ScaleY
Script
Selected
ShapeType
Typ
Visible
x
y


 See also

TfrDataset object
TfrDBDataSet component


 Methods

Key methods
DoFunction
DoScript
GetValue
PrepareScript
SetValue


PrepareScript method

See also

Applies to
TfrInterpretator object

Declaration
procedure PrepareScript(MemoFrom, MemoTo, MemoErr: TStringList); virtual;

Description
Метод осуществляет подготовку скрипта к исполнению. Исходный скрипт из MemoFrom переводится в форму, более удобную для исполнения, и помещается в MemoTo. Ошибки, найденные при обработке, помещаются в MemoErr.


 See also

DoScript method


SetValue method

See also

Applies to
TfrInterpretator object

Declaration
procedure SetValue(const Name: String; Value: Variant); virtual;

Description
Метод вызывается, когда обнаружено присвоение значения Value внешней переменной с именем Name.


DoFunction method

See also

Applies to
TfrInterpretator object

Declaration
procedure DoFunction(const Name: String; p1, p2, p3: Variant; var Val: String); virtual;

Description
Метод вызывается, когда в выражении обнаружен вызов внешней функции с именем Name. Параметры функции передаются в параметрах p1, p2, p3. Значение функции должно быть возвращено в параметре Val.


 Methods

Key methods
Calc
CalcOPZ
Str2OPZ


 Events

Key events
OnFunction
OnGetValue


CalcOPZ method

See also

Applies to
TfrParser object

Declaration
function CalcOPZ(const s: String): Variant;

Description
Вычисляет выражение s и возвращает результат. Выражение s должно быть представлено в форме обратной польской записи.


 See also

Calc method
Str2OPZ method


Calc method

See also

Applies to
TfrParser object

Declaration
function Calc(const s: String): Variant;

Description
Вычисляет выражение s и возвращает результат. Вызов функции Calc эквивалентен вызову CalcOPZ(Str2OPZ(s)).


OnFunction event

See also

Applies to
TfrParser object

Declaration
property OnFunction: TFunctionEvent;

Description
Обработчик события OnUserFunction вызывается, когда в выражении обнаружен вызов внешней функции. Функция может иметь до 3-х параметров любого типа. Параметры передаются в переменных p1, p2, p3.


 See also

OnGetValue event


Str2OPZ method

See also

Applies to
TfrParser object

Declaration
function Str2OPZ(s: String): String;

Description
Переводит выражение s в форму обратной польской записи.


OnGetValue event

See also

Applies to
TfrParser object

Declaration
property OnGetValue: TGetPValueEvent;

Description
Обработчик события OnGetValue вызывается, когда в выражении обнаружена внешняя переменная.


FR_Pars unit

Модуль содержит описания некоторых компонентов и объектов FastReport.

Objects
TParser

Types
TFunctionEvent
TGetPValueEvent

Variables
Parser


FR_E_CSV unit

Модуль содержит описания некоторых компонентов и объектов FastReport.

Components
TfrCSVExport


TfrBandType type

See also

Unit
FR_Class

Declaration
type
TfrBandType = (btReportTitle, btReportSummary,
               btPageHeader, btPageFooter,
               btMasterHeader, btMasterData, btMasterFooter,
               btDetailHeader, btDetailData, btDetailFooter,
               btSubDetailHeader, btSubDetailData, btSubDetailFooter,
               btOverlay, btColumnHeader, btColumnFooter,
               btGroupHeader, btGroupFooter,
         btCrossHeader, btCrossData, btCrossFooter, btChild, btNone);

Description
Возможные типы бэндов.


 See also

BandType property


TfrHighlightAttr type

See also

Unit
FR_Class

Declaration
type
TfrHighlightAttr = packed record
  FontStyle: Word;
  FontColor, FillColor: TColor;
end;

Description
Атрибуты выделения объекта TfrMemoView. Включают в себя стиль шрифта FontStyle и его цвет FontColor, а также цвет фона прямоугольника FillColor. Объект выводится с использованием этих атрибутов, если условие выделения истинно.


TfrPreview component
Properties

Unit
FR_View

Description
Компонент TfrPreview предназначен для создания окон предварительного просмотра, определяемых пользователем. При подключении компонента к генератору отчета TfrReport вывод отчета происходит не в стандартное окно Preview, а в подключенный компонент.


 Properties

Run-time only [image] Key properties
ScrollBars


ScrollBars property

Applies to
TfrPreview component

Declaration
property ScrollBars: TScrollStyle;

Description
Свойство определяет, какие полосы прокрутки показывать в компоненте. Возможные значения - ssHorizontal, ssVertical, ssBoth (по умочанию), ssNone.


 See also

GetValue method
SetValue method


 See also

TfrRichView object


FR_Rich unit

Модуль содержит описания некоторых компонентов и объектов FastReport.

Components
TfrRichObject

Objects
TfrRichView


RichEdit property

RichEdit field

Applies to
TfrRichView object

Declaration
RichEdit: TRichEdit;

Description
Ссылка на текст в формате RTF.


 See also

TfrRichObject component
TfrView object


 Properties

Key properties
dx
dy
FillColor
Flags
Format
FormatStr
FrameColor
FrameTyp
FrameWidth
IsPrinting
Memo
Name
OffsX
OffsY
Parent
RichEdit
ScaleX
ScaleY
Script
Selected
Typ
Visible
x
y


 Properties

Run-time only [image] Key properties
Count
Name
Value
Variable


 See also

CalcOPZ method
Str2OPZ method


 See also

Calc method
CalcOPZ method


 Properties

Run-time only [image] Key properties
TemplateDir


TChartOptions type

Unit
FR_Chart

Declaration
type
  TChartOptions = packed record
    ChartType: Byte;
    Dim3D, IsSingle, ShowLegend, ShowAxis, ShowMarks, Colored: Boolean;
    MarksStyle: Byte;
    Top10Num: Integer;
    Reserved: Array[0..35] of Byte;
  end;

Description
Опции диаграммы:
· ChartType - тип диаграммы - одно из шести значений (0..5) - линии, точки, столбцы горизонтальные и вертикальные, области и круговые диаграммы;
· Dim3D - объемность;
· IsSingle - одиночная диаграмма;
· ShowLegend - показывать сноску;
· ShowAxis - показывать оси;
· ShowMarks - показывать пометки;
· Colored - разноцветная диаграмма;
· MarksStyle - тип пометок;
· Top10Num - количество отображаемых значений в диаграмме типа "Top10". Если это поле равно 0, то строится обычная (не Top10) диаграмма;
· Reserved - резервное поле.


 See also

RangeEnd property


TRangeEnd type

See also

Unit
FR_DSet

Declaration
type
TRangeEnd = (reLast, reCurrent, reCount);

Description
Тип, определенный для свойства RangeEnd объекта TfrDataSet.


 See also

EOF method
OnCheckEOF event


TRangeBegin type

See also

Unit
FR_DSet

Declaration
type
TRangeBegin = (rbFirst, rbCurrent);

Description
Тип, определенный для свойства RangeBegin объекта TfrDataSet.


 See also

RangeBegin property


TCheckEOFEvent type

See also

Unit
FR_DSet

Declaration
type
TCheckEOFEvent = procedure(Sender: TObject; var EOF: Boolean) of object;

Description
Тип, определенный для события OnCheckEOF объекта TfrDataSet.


Name property

See also

Applies to
TfrVariables object

Declaration
property Name[Index: Integer]: String;

Description
Возвращает имя переменной, имеющей порядковый номер Index в списке.


 See also

Value property
Variable property


Count property

Applies to
TfrVariables object

Declaration
property Count: Integer;

Description
Возвращает количество переменных в списке.


Variable property

See also

Applies to
TfrVariables object

Declaration
property Variable[Name: String]: Variant; default;

Description
Возвращает значение переменной, имеющей имя Name. Т.к. свойство определено по умолчанию, к нему можно обращаться без указания имени Variable, например frVar['MyVar'].


 See also

Name property
Value property


IndexOf method

Applies to
TfrVariables object

Declaration
function IndexOf(Name: String): Integer;

Description
Возвращает порядковый номер переменной, имеющей имя Name.


Delete method

Applies to
TfrVariables object

Declaration
procedure Delete(Index: Integer);

Description
Удаляет переменную, имеющую порядковый номер Index в списке.


Clear method

Applies to
TfrVariables object

Declaration
procedure Clear;

Description
Очищает список переменных.


TGetPValueEvent type

Unit
FR_Pars

Declaration
type
TGetPValueEvent = procedure(const s: String; var v: Variant) of object;

Description
Тип определен для события OnGetValue объекта TfrParser.


 See also

ShowBandByType method


 See also

ShowBandByName method


Objects property

Objects field

Applies to
TfrBand object

Declaration
Objects: TList;

Description
Объекты, находящиеся на бэнде.


Typ property

Typ field

Applies to
TfrBand object

Declaration
Typ: TfrBandType;

Description
Тип бэнда.


x property

x field

See also
Top

Applies to
TfrBand object

Declaration
x: Integer;

Description
Горизонтальная позиция бэнда. Измеряется в экранных пикселах, для перевода в миллиметры надо умножить на коэффициент 5/18.


 See also

y field
dx field
dy field


 Properties

Key properties
ColCount
ColGap
CurBottomY
CurY
Objects
pgHeight
pgMargins
pgOr
pgSize
pgWidth
PrintToPrevPage
UseMargins


 See also

ColGap field


ColGap property

ColGap field

See also
Top

Applies to
TfrPage object

Declaration
ColGap: Integer;

Description
Промежуток между колонками для многоколоночных отчетов.


 See also

ColCount field


Objects property

Objects field

See also
Top

Applies to
TfrPage object

Declaration
Objects: TList;

Description
Список объектов, расположенных на листе.


 See also

pgWidth field
pgSize field
pgOr field


pgMargins property

pgMargins field

See also
Top

Applies to
TfrPage object

Declaration
pgMargins: TRect;

Description
Поля страницы. Структура TRect содержит значения отступов от краев листа, выраженных в пикселах. Эти значения устанавливаются в дизайнере в диалоге "Параметры страницы", "поля".


 See also

UseMargins field


pgWidth property

pgWidth field

See also
Top

Applies to
TfrPage object

Declaration
pgWidth: Integer;

Description
Ширина страницы в десятых долях мм. Это поле используется, если установлен пользовательский размер страницы (pgSize = 255).


UseMargins property

UseMargins field

See also
Top

Applies to
TfrPage object

Declaration
UseMargins: WordBool;

Description
Использовать поля страницы.


 See also

Objects field


ChangePaper method

Applies to
TfrPage object

Declaration
procedure ChangePaper(ASize, AWidth, AHeight: Integer; AOr: TPrinterOrientation);

Description
Меняет размер и ориентацию листа.


 Events

Key events
OnBeginColumn
OnBeginDoc
OnBeginPage
OnEndDoc
OnEndPage
OnEnterRect
OnGetValue
OnManualBuild
OnMouseOverObject
OnObjectClick
OnPrintColumn
OnPrintReport
OnProgress
OnUserFunction


Dataset property

See also

Applies to
TfrReport component

Declaration
property Dataset: TfrDataset;

Description
Источник данных для отчета. Используется при значении ReportType = rtMultiple: отчет в этом случае строится для каждой записи из этого источника. Эта возможность особенно удобна для печати многостраничных бланков.


 See also

TfrDataset object
TfrUserDataset component
TfrDBDataSet component


EMFPages property

See also

Applies to
TfrReport component

Declaration
property EMFPages: TfrEMFPages;

Description
Ссылка на объект - список страниц в построенном отчете.


 See also

TfrEMFPages object


GrayedButtons property

Applies to
TfrReport component

Declaration
property GrayedButtons: Boolean;

Description
Если True, то в окне предварительного просмотра используются серые кнопки. Если проект скомпилирован с использованием дизайнера, то эта опция будет доступна и в настройках дизайнера.


ModalPreview property

Applies to
TfrReport component

Declaration
property ModalPreview: Boolean;

Description
Если True, то окно предварительного просмотра становится модальным (т.е. управление в основную программу возвращается после закрытия окна Preview). Немодальный режим Preview позволяет открыть несколько окон предварительного просмотра и переключаться между ними. Единственное ограничение - каждое окно должно быть связано с отдельным компонентом TfrReport.


Pages property

See also Example

Applies to
TfrReport component

Declaration
property Pages: TfrPages;

Description
Ссылка на объект - список страниц отчета. Под страницей понимается страница в режиме дизайнера.


 See also

TfrPages object


 Methods

Key methods
Clear
FindObject
PrepareReport
DesignReport
EditPreparedReport
ExportTo
GetVariableValue
LoadFromBlobField
LoadFromDB
LoadFromFile
LoadFromStream
LoadPreparedReport
LoadTemplate
PrintPreparedReport
PrintPreparedReportDlg
SavePreparedReport
SaveTemplate
SaveToBlobField
SaveToDB
SaveToFile
SaveToStream
ShowPreparedReport
ShowReport


 Events

Key events
OnBeginDoc
OnEndDoc
OnProgress


Reports property

Example

Applies to
TfrCompositeReport component

Declaration
property Reports: TList;

Description
Список отчетов композитного отчета.


 Reports property example

procedure TForm1.BuildBtnClick(Sender: TObject);
begin
  frComposite1.Reports.Clear;
  frComposite1.Reports.Add(frReport1);
  frComposite1.Reports.Add(frReport2);
  frComposite1.ShowReport;
end;


ExportTo method

Example

Applies to
TfrReport component

Declaration
procedure ExportTo(Filter: TfrExportFilter; FileName: String);

Description
Выполняет экспорт отчета в файл FileName с использованием фильтра экспорта Filter. Предполагается, что отчет был построен ранее вызовом метода PrepareReport либо загружен из файла методом LoadPreparedReport.


LoadFromDB method

See also

Applies to
TfrReport component

Declaration
procedure LoadFromDB(Table: TDataSet; DocN: Integer);

Description
Считывает содержимое документа под номером DocN из таблицы БД. Структура таблицы простая: первое поле целое - это номер документа, а второе - типа BLOb - форма документа.


 See also

LoadFromFile method
LoadFromStream method


LoadFromFile method

See also

Applies to
TfrReport component

Declaration
procedure LoadFromFile(FName: String);

Description
Считывает содержимое документа из файла. Расширение файла должно быть .frf (FastReport Form).


 See also

SavePreparedReport method


PrintPreparedReport method

Applies to
TfrReport component

Declaration
procedure PrintPreparedReport(PageNumbers: String; Copies: Integer;
      Collate: Boolean; PrintPages: TfrPrintPages);

Description
Печатает отчет. На печать выводятся страницы, перечисленные в строке PageNumbers, например, "1,3,5-12". Если строка PageNumbers пустая, то печатаются все страницы. Параметр Copies определяет количество печатаемых копий. Параметр Collate определяет, надо ли разбирать отчет по компиям. Параметр PrintPages определяет, какие страницы выводить на печать - все, четные или нечетные.
Предполагается, что отчет был построен ранее вызовом метода PrepareReport либо загружен из файла методом LoadPreparedReport.


SavePreparedReport method

See also

Applies to
TfrReport component

Declaration
procedure SavePreparedReport(FName: String);

Description
Записывает построенный отчет в файл FName. Расширение файла должно быть .frp (FastReport Prepared report).


 See also

LoadPreparedReport method


SaveToFile method

See also

Applies to
TfrReport component

Declaration
procedure SaveToFile(FName: String);

Description
Записывает содержимое документа в файл. Расширение файла должно быть .frf (FastReport Form).


 See also

SaveToDB method
SaveToFile method


ShowPreparedReport method

See also

Applies to
TfrReport component

Declaration
procedure ShowPreparedReport;

Description
Выполняет предварительный просмотр отчета. Предполагается, что отчет был построен ранее вызовом метода PrepareReport либо загружен из файла методом LoadPreparedReport. После закрытия окна предварительного просмотра построенный отчет разрушается.


 See also

PrepareReport method
ShowReport method


 See also

OnEndDoc event


OnEndDoc event

See also

Applies to
TfrReport component

Declaration
property OnEndDoc: TEndDocEvent;

Description
Обработчик события вызывается после окончания формирования отчета.


 See also

OnBeginDoc event


OnEndPage event

See also

Applies to
TfrReport component

Declaration
property OnEndPage: TEndPageEvent;

Description
Обработчик события вызывается после окончания формирования страницы.


 OnGetValue event example

procedure TForm1.frReport1GetValue(const ParName: string; var ParValue: Variant);
begin
  if ParName = 'Var1' then
    ParValue := '1'
  else if ParName = 'Var2' then
    ParValue := 2
end;


OnProgress event

Applies to
TfrReport component

Declaration
property OnProgress: TProgressEvent;

Description
Обработчик события вызывается для индикации прогресса выполнения текущей работы (построение отчета, печать, экспот). На этот обработчик можно повесить свою процедуру отображения прогресса.


OnUserFunction event

Example

Applies to
TfrReport component

Declaration
property OnUserFunction: TFunctionEvent;

Description
Cобытие вызывается, когда в тексте объекта обнаружена переменная или выражение, содержащее вызов функции.


OnPrintColumn event

Example

Applies to
TfrReport component

Declaration
property OnPrintColumn: TPrintColumnEvent;

Description
Cобытие вызывается при формировании столбцов cross-tab отчета. Обработчику события передается номер столбца и его ширина по умолчанию. Меняя ширину, можно получить cross-tab отчет с различной шириной столбцов. При этом надо также изменять ширину объекта(ов), находящегося в ячейке таблицы.


 OnPrintColumn event example

const
  ColWidths: Array[0..4] of Integer = (40, 50, 60, 70, 100);
var
  i: Integer;

procedure TForm1.frReport1PrintColumn(ColNo: Integer; var Width: Integer);
begin
  if ColNo in [0..3] then
    Width := ColWidths[ColNo] else
    Width := ColWidths[4];
  i := ColNo;
end;

procedure TForm1.frReport1EnterRect(Memo: TStringList; View: TView);
begin
  if View.Name = 'Memo1' then
    if i in [0..3] then
      View.dx := ColWidths[i] else
      View.dx := ColWidths[4];
end;


 OnUserFunction event example

procedure TForm1.frReport1UserFunction(const name: string; p1, p2, p3: Variant; var val: string);
var
  d: Double;
begin
  if name <> 'CRAZYMONEY' then exit;
  d := Parser.Calc(p1);
  // для использования парсера необходимо включить в список uses FR_Pars.pas
  if d > 10000 then
    val := '''' + FormatFloat('#,##0.00',d) + ' - ого!' + ''''
  else
    val := '''' + FormatFloat('#,##0.00',d) + '''';
  // результат - это форматированная строка, поэтому заключаем в кавычки
end;


 See also

OnBeginColumn event


TBeginDocEvent type

See also

Unit
FR_Class

Declaration
type
TBeginDocEvent = procedure(Sender: TObject) of object;

Description
Тип определен для события OnBeginDoc компонента TfrReport.


TBeginPageEvent type

See also

Unit
FR_Class

Declaration
type
TBeginPageEvent = procedure(pg: Integer; MasterMemo, DetailMemo, SubDetailMemo: TStringList) of object;

Description
Тип определен для события OnBeginPage компонента TfrReport.


TDetailEvent type

See also

Unit
FR_Class

Declaration
type
TDetailEvent = procedure(const ParName: String; var ParValue: Variant) of object;

Description
Тип определен для события OnGetValue компонента TfrReport.


TEndDocEvent type

See also

Unit
FR_Class

Declaration
type
TEndDocEvent = procedure(Sender: TObject) of object;

Description
Тип определен для события OnEndDoc компонента TfrReport.


TBeginColumnEvent type

See also

Unit
FR_Class

Declaration
type
TBeginColumnEvent = procedure(Band: TfrBand) of object;

Description
Тип определен для события OnBeginColumn компонента TfrReport.


 See also

GetClipRgn method


TPrintColumnEvent type

See also

Unit
FR_Class

Declaration
type
TPrintColumnEvent = procedure(ColNo: Integer; var Width: Integer) of object;

Description
Тип определен для события OnPrintColumn компонента TfrReport.


 See also

OnPrintColumn event


TProgressEvent type

See also

Unit
FR_Class

Declaration
type
TProgressEvent = procedure(n: Integer) of object;

Description
Тип определен для события OnProgress компонента TfrReport.


 See also

OnProgress event


frCreateObject function

Unit
FR_Class

Declaration
function frCreateObject(Typ: Byte; const ClassName: String): TfrView;

Description
Функция создает объект с заданным типом Typ. Если объект типа Add-in, то надо указывать и имя класса ClassName.


TfrCompressor object

Properties Methods Example

Unit
FR_Class

Description
Объект представляет собой компрессор для упаковки/распаковки содержимого построеноого отчета. При записи отчета в файл .FRP содержимое страниц упаковывается, что резко сокращает объем файла. При чтении файла происходит распаковка содержимого.

Объект содержит два метода: Compress для упаковки и DeCompress для распаковки. Оба метода пустые и предназначены для перекрытия в потомках объекта. Для придания объекту нужной функциональности следует завести его потомка с переопределенными методами и присвоить его указатель глобальной переменной frCompressor. В качестве утилит компрессии/декомпрессии можно использовать любые подходящие компоненты (VCLZip, TZipTV и пр.), позволяющие выполнять операции "поток-поток".


 TfrCompressor example

type
  TMyCompressor = class(TfrCompressor)
  public
    procedure Compress(StreamIn, StreamOut: TStream); override;
    procedure DeCompress(StreamIn, StreamOut: TStream); override;
  end;

procedure TMyCompressor.Compress(StreamIn, StreamOut: TStream);
begin
  ZipStream(StreamIn, StreamOut); // собственно компрессия.
end;

procedure TMyCompressor.DeCompress(StreamIn, StreamOut: TStream);
begin
  UnZipStream(StreamIn, StreamOut);
end;

...
  frCompressor.Free; // удаляем стандартный компрессор
  frCompressor := TMyCompressor.Create;
  frCompressor.Enabled := True;
...


Enabled property

Applies to
TfrCompressor object

Declaration
Enabled: Boolean;

Description
Если установлено в True, то при записи файла .FRP происходит его компрессия. По умолчанию False.


Compress method

Applies to
TfrCompressor object

Declaration
procedure Compress(StreamIn, StreamOut: TStream); virtual;

Description
Метод осуществляет компрессию потока StreamIn в поток StreamOut. У класса TfrCompressor этот метод пустой - его необходимо переопределять для придания нужной функциональности.


DeCompress method

Applies to
keepn

Applies to
TfrCompressor object

Declaration
procedure DeCompress(StreamIn, StreamOut: TStream); virtual;

Description
Метод осуществляет декомпрессию потока StreamIn в поток StreamOut. У класса TfrCompressor этот метод пустой - его необходимо переопределять для придания нужной функциональности.


 See also

TfrView object
TfrBandView object
TfrSubReportView object
TfrPictureView object
TfrLineView object


 Properties

Key properties

Alignment
dx
dy
FillColor
Flags
Font
Format
FormatStr
FrameColor
FrameTyp
FrameWidth
Highlight
HighlightStr
IsPrinting
Memo
Name
OffsX
OffsY
Parent
ScaleX
ScaleY
Script
Selected
Typ
Visible
x
y


Alignment property

Alignment field

Applies to
TfrMemoView object

Declaration
Alignment: Integer;

Description
Выравнивание текста (1 - по правому краю, 2 - по центру, 3 - по ширине, +4 - текст по вертикали, +8 - центровка по высоте, +16 - по нижнему краю).


FontColor property

Font field

Applies to
TfrMemoView object

Declaration
Font: TFont;

Description
Используемый шрифт.


 See also

x field
y field
dx field
dy field


FillColor property

FillColor field

Applies to
TfrView object

Declaration
FillColor: TColor;

Description
Цвет фона объекта. Если FillColor равен clNone, то объект при печати будет прозрачным. В режиме дизайнера прозрачные объекты показываются с белым фоном.


Flags property

Flags field

Applies to
TfrView object

Declaration
Flags: Word;

Description
Набор флагов - опций объекта. Может быть комбинацией следующих значений:

Все объекты:
· flStretched - объект растягиваемый.
· flWantHook - объект получает управление после отрисовки любого объекта.

Объект TfrMemoView:
· flWordWrap - перенос слов.
· flWordBreak - перенос слов по слогам.
· flTextOnly - выводить содержимое объекта "как есть", без проверки на наличие переменных.
· flSuppressRepeated - подавлять повторяющиеся значения.
· flHideZeros - не отображать нулевые значения.
· flUnderlines - подчеркивать строки текста.

Объект TfrBandView:
· flBandNewPageAfter - формировать новую страницу.
· flBandPrintifSubsetEmpty - печатать, если подчиненный список пуст.
· flBandPageBreak - разрываемый бэнд.
· flBandOnFirstPage - печатать на первой странице.
· flBandOnLastPage - печатать на последней странице.
· flBandRepeatHeader - повторять на всех страницах.
· flBandPrintChildIfInvisible - печатать child-бэнды, если бэнд-родитель невидим.

Объект TfrPictureView:
· flPictCenter - центрировать картинку.
· flPictRatio - сохранять пропорции.


Format property

Format field

See also
Top

Applies to
TfrView object

Declaration
Format: Integer;

Description
Формат переменных объекта. Используется только в объекте TfrMemoView.


 See also

FormatStr field


FormatStr property

FormatStr field

See also
Top

Applies to
TfrView object

Declaration
FormatStr: String;

Description
Строка форматирования. Используется только в объекте TfrMemoView.


 See also

Format field


FrameColor property

FrameColor field

See also
Top

Applies to
TfrView object

Declaration
FrameColor: TColor;

Description
Цвет рамки объекта.


 See also

FrameTyp field
FrameWidth field


 See also

FrameColor field
FrameWidth field


FrameWidth property

FrameWidth field

See also
Top

Applies to
TfrView object

Declaration
FrameWidth: Single;

Description
Толщина рамки объекта в экранных пикселах.


 See also

FrameColor field
FrameTyp field


IsPrinting property

IsPrinting field

Applies to
TfrView object

Declaration
IsPrinting: Boolean;

Description
True, если рисование осуществляется на холсте принтера. Анализируя это значение, можно осуществлять отрисовку в методе Draw в двух вариантах: для экрана и для принтера.


Memo property

Memo field

Applies to
TfrView object

Declaration
Memo: TStringList;

Description
Содержимое Memo объекта.


Name property

Name field

See also
Top

Applies to
TfrView object

Declaration
Name: String;

Description
Уникальное имя объекта.


 See also

CreateUniqueName method


OffsX property

OffsX field

See also
Top

Applies to
TfrView object

Declaration
OffsX: Integer;

Description
Коэффициент смещения по горизонтали. Перед началом рисования объекта его позиция и размеры масштабируются и смещаются.


FrameTyp property

FrameTyp field

See also
Top

Applies to
TfrView object

Declaration
FrameTyp: Word;

Description
Тип рамки объекта. Набор битовых полей, показывающих, из каких линий состоит рамка.


OffsY property

OffsY field

See also
Top

Applies to
TfrView object

Declaration
OffsY: Integer;

Description
Коэффициент смещения по вертикали. Перед началом рисования объекта его позиция и размеры масштабируются и смещаются.


 See also

OffsX field


Parent property

Parent field

Applies to
TfrView object

Declaration
Parent: TfrBand;

Description
Ссылка на бэнд - владелец объекта. Только в режиме построения отчета.


ScaleX property

ScaleX field

See also
Top

Applies to
TfrView object

Declaration
ScaleX: Double;

Description
Коэффициент масштабирования по горизонтали. Перед началом рисования объекта его позиция и размеры масштабируются и смещаются.


 See also

ScaleY field


ScaleY property

ScaleY field

See also
Top

Applies to
TfrView object

Declaration
ScaleY: Double;

Description
Коэффициент масштабирования по вертикали. Перед началом рисования объекта его позиция и размеры масштабируются и смещаются.


 See also

ScaleX field


Script property

Script field

See also
Top

Applies to
TfrView object

Declaration
Script: TStringList;

Description
Скрипт объекта.


 See also

<<< See also of Script property >>>


 See also

OffsY field


Typ property

Typ field

Applies to
TfrView object

Declaration
Typ: Byte;

Description
Тип объекта. Одно из значений gtMemo, gtPicture, gtBand, gtSubReport , gtLine, gtAddIn.


Visible property

Visible field

Applies to
TfrView object

Declaration
Visible: WordBool;

Description
Видимость объекта. Невидимые объекты при построении отчета не показываются.


x property

x field

See also
Top

Applies to
TfrView object

Declaration
x: Integer;

Description
Позиция объекта по горизонтали. Измеряется в экранных пикселах, для перевода в миллиметры надо умножить на коэффициент 5/18.


 See also

y field
dx field
dy field
SetBounds method


y property

y field

See also
Top

Applies to
TfrView object

Declaration
y: Integer;

Description
Позиция объекта по вертикали. Измеряется в экранных пикселах, для перевода в миллиметры надо умножить на коэффициент 5/18.


 See also

x field
dx field
dy field
SetBounds method


GetClipRgn method

Applies to
TfrView object

Declaration
function GetClipRgn(rt: TfrRgnType): HRGN; virtual;

Description
Возвращает регион - область рисования объекта. Если параметр rt = rtExtended, то возвращает регион, расширенный на 10 точек. Функцию необходимо переопределять, если объект имеет непрямоугольную форму.


Assign method

Applies to
TfrView object

Declaration
procedure Assign(From: TfrView);

Description
Копирует содержимое из объекта From.


CreateUniqueName method

See also

Applies to
TfrView object

Declaration
procedure CreateUniqueName;

Description
Создает уникальное имя для объекта.


Selected property

Selected field

Applies to
TfrView object

Declaration
Selected: Boolean;

Description
True, если объект выделен в режиме дизайнера.


DefinePopupMenu method

Applies to
TfrView object

Declaration
procedure DefinePopupMenu(Popup: TPopupMenu); virtual;

Description
Вызывается перед прорисовкой контекстного меню объекта в режиме дизайнера. Позволяет определить свои пункты меню и реакцию на них. У класса TfrView этот метод создает в меню разделительную черту, пункт "Редактор" и флажок "Растягиваемый".


Draw method

Applies to
TfrView object

Declaration
procedure Draw(Canvas: TCanvas); virtual; abstract;

Description
Выполняет отрисовку объекта. Этот метод необходимо переопределять всегда.


ExportData method

Applies to
TfrView object

Declaration
procedure ExportData; virtual;

Description
Экспортирует данные в фильтр экспорта.


LoadFromStream method

See also

Applies to
TfrView object

Declaration
procedure LoadFromStream(Stream: TStream); virtual;

Description
Считывает содержимое объекта из потока Stream. Необходимо переопределять этот метод, если объект имеет дополнительные поля, которые надо хранить в потоке.


 See also

SaveToStream method


StreamOut method

Applies to
TfrView object

Declaration
procedure StreamOut(Stream: TStream); virtual;

Description
Запоминает содержимое объекта в потоке Stream в процессе построения отчета. Необходимо переопределять этот метод, если объект нуждается в предварительной обработке перед выводом в поток.


SaveToStream method

See also

Applies to
TfrView object

Declaration
procedure SaveToStream(Stream: TStream); virtual;

Description
Записывает содержимое объекта в поток Stream. Необходимо переопределять этот метод, если объект имеет дополнительные поля, которые надо хранить в потоке.


 See also

LoadFromStream method


SetBounds method

See also

Applies to
TfrView object

Declaration
procedure SetBounds(Left, Top, Width, Height: Integer);

Description
Устанавливает значения полей x, y, dx, dy объекта.


 See also

Name field


 Properties

Key properties
BandType
ChildBand
ColumnGap
Columns
ColumnWidth
DataSet
dx
dy
FillColor
Flags
Format
FormatStr
FrameColor
FrameTyp
FrameWidth
GroupCondition
IsPrinting
Master
Memo
Name
OffsX
OffsY
Parent
ScaleX
ScaleY
Script
Selected
Typ
Visible
x
y


 See also

TfrView object
TfrMemoView object
TfrBandView object
TfrSubReportView object
TfrLineView object


 Properties

Key properties
BlobType
dx
dy
FillColor
Flags
Format
FormatStr
FrameColor
FrameTyp
FrameWidth
IsPrinting
Memo
Name
OffsX
OffsY
Parent
Picture
ScaleX
ScaleY
Script
Selected
Typ
Visible
x
y


Picture property

Picture field

Applies to
TfrPictureView object

Declaration
Picture: TPicture;

Description
Ссылка на изображение в формате BMP, ICO, WMF, EMF, JPG (изображения в формате JPG поддерживаются в Delphi 3 и выше, если используется модуль JPEG).


 See also

TfrView object
TfrMemoView object
TfrBandView object
TfrSubReportView object
TfrPictureView object


SubPage property

SubPage field

Applies to
TfrSubReportView object

Declaration
SubPage: Integer;

Description
Номер страницы, на которой содержится вложенный отчет.


BlobType property

Applies to
TfrPictureView class

Declaration
property BlobType: Byte;

Description
Тип картинки, хранимой в BLOb-поле таблицы БД. Одно из значений 0 - BMP, 1 - JPEG, 2 - ICO, 3 - WMF/EMF.
Run-time only


 Properties

Run-time only [image] Key properties
BandDatasources
DisabledDatasets
FieldAliases
Variables


TfrDataDictionary class

Properties Methods

Unit
FR_Class

Description
Словарь данных. Содержит список переменных, алиасов таблиц БД, доступных таблиц, а также источников данных для бэндов.


BandDatasources property

Applies to
TfrDataDictionary class

Declaration
property BandDatasources: TfrVariables;

Description
Список алиасов источников данных для бэндов, а также список доступных источников (содержимое страницы "Источники данных для бэндов" диалога "Словарь данных").
Run-time only


 Methods

Key methods
Clear
LoadFromFile
LoadFromStream
SaveToFile
SaveToStream


FieldAliases property

Applies to
TfrDataDictionary class

Declaration
property FieldAliases: TfrVariables;

Description
Список алиасов таблиц и полей таблиц БД, а также список доступных таблиц (содержимое страницы "Данные из БД" диалога "Словарь данных").
Run-time only


DisabledDatasets property

Applies to
TfrDataDictionary class

Declaration
property DisabledDatasets: TStringList;

Description
Таблицы БД, которые надо скрыть.
Run-time only


Clear method

Applies to
TfrDataDictionary class

Declaration
procedure Clear;

Description
Очищает словарь данных.


Variables property

Applies to
TfrDataDictionary class

Declaration
property Variables: TfrVariables;

Description
Список переменных и категорий (содержимое страницы "Переменные" диалога "Словарь данных").
Run-time only


LoadFromStream method

Applies to
TfrDataDictionary class

Declaration
procedure LoadFromStream(Stream: TStream);

Description
Считывает словарь данных из потока.


LoadFromFile method

Applies to
TfrDataDictionary class

Declaration
procedure LoadFromFile(FName: String);

Description
Считывает словарь данных из файла.


SaveToStream method

Applies to
TfrDataDictionary class

Declaration
procedure SaveToStream(Stream: TStream);

Description
Записывает словарь данных в поток.


SaveToFile method

Applies to
TfrDataDictionary class

Declaration
procedure SaveToFile(FName: String);

Description
Записывает словарь данных в файл.


Master property

Applies to
TfrBandView class

Declaration
property Master: String;

Description
Имя дата-бэнда, который будет использован для формирования тела группы в отчетах с группировкой. Применяется в случае, когда на листе отчета присутствует несколько бэндов типа master data.
Run-time only


MDIPreview property

Applies to
TfrReport component

Declaration
property MDIPreview: Boolean;

Description
Определяет, что окно preview надо показывать как MDI child.


Dictionary property

Applies to
TfrReport component

Declaration
property Dictionary: TfrDataDictionary;

Description
Словарь данных. Содержит список переменных, алиасов таблиц БД, доступных таблиц, а также источников данных для бэндов.
Run-time only


Modified property

Applies to
TfrReport component

Declaration
property Modified: Boolean;

Description
Свойство определяет, был ли модифицирован отчет в дизайнере.
Run-time only


MixVariablesAndDBFields property

Applies to
TfrReport component

Declaration
property MixVariablesAndDBFields: Boolean;

Description
Вывести переменные и поля таблиц БД в одном диалоге ("Вставка поля БД").
Run-time only


Clear method

Applies to
TfrReport component

Declaration
procedure Clear;

Description
Очистить содержимое компонента.


FindObject method

Applies to
TfrReport component

Declaration
function FindObject(Name: String): TfrView;

Description
Найти объект с именем Name.


PrintPreparedReportDlg method

Applies to
TfrReport component

Declaration
procedure PrintPreparedReportDlg;

Description
Печатает подготовленный отчет с выводом окна опций печати.


LoadFromBlobField method

Applies to
TfrReport component

Declaration
procedure LoadFromBlobField(Blob: TField);

Description
Считать отчет из BLOb-поля таблицы БД.


OnMouseOverObject event

Applies to
TfrReport component

Declaration
property OnMouseOverObject: TMouseOverObjectEvent;

Description
Обработчик события вызывается, если в режиме preview пользователь провел мышкой над каким-либо объектом. Указатель на объект передается в параметре View. Обработчик может вернуть тип мышиного курсора. Таким способом можно показать пользователю, что объект является активным и при нажатии на него выполнится какое-либо действие.


SaveToBlobField method

Applies to
TfrReport component

Declaration
procedure SaveToBlobField(Blob: TField);

Description
Записать отчет в BLOb-поле таблицы БД.


OnPrintReport event

Applies to
TfrReport component

Declaration
property OnPrintReport: TPrintReportEvent;

Description
Обработчик события вызывается перед выполнением печати отчета.


OnObjectClick event

Applies to
TfrReport component

Declaration
property OnObjectClick: TObjectClickEvent;

Description
Обработчик события вызывается, если в режиме preview пользователь нажал мышкой на каком-либо объекте. Указатель на объект передается в параметре View. Обработчик события может выполнить то или иное действие, например, запустить на построение отчет с детальной информацией по нажатому объекту.


 Properties

Run-time only [image] Key properties
ShowDialog


TfrExportFilter component

Properties Events

Unit
FR_Class

Description
<<< Description of TfrExportFilter component >>>


DefaultCopies property

Applies to
TfrReport component

Declaration
property DefaultCopies: Integer;

Description
Количество копий по умолчанию, которое предлагается в диалоге печати.


DefaultCollate property

Applies to
TfrReport component

Declaration
property DefaultCollate: Boolean;

Description
Разбирать ли отчет по копиям при печати - значение по умолчанию, которое предлагается в диалоге печати.


OnBeforeExport event

Applies to
TfrExportFilter component

Declaration
property OnBeforeExport: TBeforeExportEvent;

Description
Обработчик события вызывается после того, как пользователь выбрал тип фильтра экспорта имя файла в стандартном диалоговом окне "Save file". В обработчике можно подменить имя файла или запретить операцию экспорта (параметр bContinue).


OnAfterExport event

Applies to
TfrExportFilter component

Declaration
property OnAfterExport: TAfterExportEvent;

Description
Обработчик события вызывается после того, как экспорт успешно завершен. Имя файла с результатом экспорта передается в параметре FileName.


 Properties

Run-time only [image] Key properties
LocalizedPropertyNames


TfrLocale class

Properties Methods Events

Unit
FR_Class

Description
Класс содержит методы для работы с языковыми ресурсами. Ссылку на экземпляр класса возвращает функция frLocale: TfrLocale.


 Events

Key events
OnLocalize


 Methods

Key methods
LoadBmp
LoadStr
LoadDll
UnloadDll


LoadBmp method

Applies to
TfrLocale class

Declaration
function LoadBmp(ID: String): HBitmap;

Description
Функция считывает картинку с именем ID из языковых ресурсов. Например, LoadBMP('FR_BOLD').


LocalizedPropertyNames property

Applies to
TfrLocale class

Declaration
property LocalizedPropertyNames: Boolean;

Description
Свойство определяет, надо ли локализовать имена свойств в инспекторе объектов дизайнера. Имена свойств хранятся в файле fr_lng5.res, в настоящий момент не локализованы. Для локализации см. инструкции в файле fr_lng5.rc.
Run-time only


LoadDll method

Applies to
TfrLocale class

Declaration
procedure LoadDll(Name: String);

Description
Метод загружает DLL с языковыми ресурсами. После этого все обращения к ресурсам будут использовать ресурсы из DLL. Например, LoadDll('FR_RUS.dll').


LoadStr method

Applies to
TfrLocale class

Declaration
function LoadStr(ID: Integer): String;

Description
Функция считывает строку с номером ID из строковых ресурсов.


OnLocalize event

Applies to
TfrLocale class

Declaration
property OnLocalize: TLocalizeEvent;

Description
Обработчик события вызывается каждый раз, когда происходит обращение к строковым языковым ресурсам. Обработчик можно использовать для замещения встроенных ресурсов своими собственными, которые можно хранить в любом удобном месте. Обработчик должен вернуть строку ResultString по ее идентификатору StringID.


UnloadDll method

Applies to
TfrLocale class

Declaration
procedure UnloadDll;

Description
Метод выгружает DLL, загруженную ранее вызовом LoadDll. После этого все обращения к ресурсам будут использовать ресурсы, прикомпилированные к приложению.


TBeforeExportEvent type

Unit
FR_Class

Declaration
type TBeforeExportEvent = procedure(var FileName: String; var bContinue: Boolean); of object;

Description
Тип определен для события OnBeforeExport компонента фильтра экспорта.


TAfterExportEvent type

Unit
FR_Class

Declaration
type TAfterExportEvent = procedure(const FileName: String); of object;

Description
Тип определен для события OnAfterExport компонента фильтра экспорта.


TfrPageType type

Unit
FR_Class

Declaration
type TfrPageType = (ptReport, ptDialog);

Description
Тип страницы отчета (обычная страница/диалоговая форма).


TfrDocMode type

Unit
FR_Class

Declaration
type TfrDocMode = (dmDesigning, dmPrinting);

Description
Текущий режим: дизайн или формирование отчета (печать).


TLocalizeEvent type

Unit
FR_Class

Declaration
type TLocalizeEvent = procedure(StringID: Integer; var ResultString: String); of object;

Description
Тип определен для события OnLocalize объекта TfrLocale.


TfrPrintPages type

Unit
FR_Class

Declaration
type TfrPrintPages = (frAll, frOdd, frEven);

Description
Определяет, какие страницы отчета печатать: все, четные, нечетные.


ShowDialog property

Applies to
TfrExportFilter component

Declaration
property ShowDialog: Boolean;

Description
Определяет, надо ли показывать диалог опций фильтра экспорта.


 Events

Key events
OnAfterExport
OnBeforeExport


frLocale function

Unit
FR_Class

Declaration
function frLocale: TfrLocale;

Description
Функция возвращает ссылку на экземпляр класса TfrLocale.


TPrintReportEvent type

Unit
FR_Class

Declaration
type TPrintReportEvent = procedure; of object;

Description
Тип определен для события OnPrintReport компонента TfrReport.


frAddFunctionDesc procedure

Unit
FR_Class

Declaration
procedure frAddFunctionDesc(FuncName, Category, Description: String);

Description
Процедура регистрирует новую функцию (в диалоге "Вставка функции"). Пример:

frAddFunctionDesc('SUMPROPIS', 'Мои функции', 'SUMPROPIS(<Число>)/Возвращает сумму прописью.');

Обратите внимание: символ "/" в описании функции обязателен! Он отделяет описание синтаксиса от описания самой функции.


TObjectClickEvent type

Unit
FR_Class

Declaration
type TObjectClickEvent = procedure(View: TfrView); of object;

Description
Тип определен для события OnObjectClick компонента TfrReport.


TMouseOverObjectEvent type

Unit
FR_Class

Declaration
type TMouseOverObjectEvent = procedure(View: TfrView; var Cursor: TCursor); of object;

Description
Тип определен для события OnMouseOverObject компонента TfrReport.


 HelpScribble

HelpScribble is a help authoring tool written by Jan Goyvaerts. This help file was created with the unregistered version of HelpScribble, which is why you can read this ad. Once the author of this help file is so honest to register the shareware he uses, you will not see this ad again in his help files.
Recompiling the help project with the registered version is all it takes to get rid of this ad.

HelpScribble is a stand-alone help authoring tool. It does not require an expensive word processor. (Only a help compiler as Microsoft likes keeping the .hlp format secret. Not my fault.)

Here are some of HelpScribble's features:

· The Setup program will properly install and uninstall HelpScribble and all of its components, including registry keys.
· Create, edit and navigate through topics right in the main window. No need to mess with heaps of dialog boxes.
· All topics are listed in a grid in the main window so you won't lose track in big help projects. You can even set bookmarks.
· Use the built-in Browse Sequence Editor to easily create browse sequences.
· Use the built-in Window Editor to change the look of your help window and create secondary windows.
· Use the built-in Contents Editor to create Windows 95-style contents files. Works a lot better than Microsoft's HCW.
· No need to mess with Microsoft's SHED: use the built-in SHG Editor to create hotspot bitmaps. Draw your hotspots on the bitmap and pick the topic to link to from the list.
· With the built-in Macro Editor you can easily compose WinHelp macros whenever needed. It will tell you what the correct parameters are and provide information on them.
· If you have a problem, just consult the online help. The help file was completely created with HelpScribble, of course.
· HelpScribble is shareware. However, the unregistered version is not crippled in any way. It will only add a small note to your help topics to encourage you to be honest and to register the shareware you use.

These options are very interesting for Delphi and C++Builder developers:

· If you are a component writer, use the Delphi Parser to build an outline help file for your component. Just fill in the spaces and you are done. HelpScribble can also extract the comments from your source file and use them as the default descriptions.
· If you are an application writer, HelpScribble provides you with a property editor for the HelpContext property. You can select the topic you need from a list of topic titles or simply instruct to create a new topic. No need to remember obscure numbers.
· The property editor also provides a tree view of all the components on your form and their HelpContext properties. This works very intuitively. (Much nicer than those help tools that simply mess with your .dfm files.)
· HelpScribble can perform syntax highlighting on any Delphi source code in your help file.

HelpScribble is shareware, so feel free to grab your copy today from my web site at http://www.ping.be/jg/


 See also

GetValue method
DoFunction method


 See also

OnFunction event